Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Andryan00
0 / 0 / 0
Регистрация: 16.05.2015
Сообщений: 4
1

Перенос данных из справочника в документ

21.03.2016, 18:46. Просмотров 1180. Ответов 6
Метки нет (Все метки)

В справочнике имеется поле цена за единицу товара. Как ее переносить автоматически в документ вместе с наименованием товара.Документ называется Приходная Накладная.
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.03.2016, 18:46
Ответы с готовыми решениями:

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке
Здравствуйте. В собственной конфигурации есть документ "Объектныйграфик" с реквизитами: ШифрОбъекта...

Перенос данных из справочника одной конфигурации в справочник другой
никогда не сталкивалась с данной проблемой. нужно перенести данные из справочника одной...

Перенос данных из справочника в документ
Здравствуйте. У меня в программе есть справочник "отливка" с реквизитами: наименование, шифр...

Перенос реквизитов справочника в документ
Есть справочник Товары с реквизитами Автор и Журнал. Есть документ Договор с реквизитами Счет и...

Перенос реквизитов справочника номенклатуры в документ Поступление ТМЦ
Здравствуйте! Есть справочник "Номенклатура" с реквизитами: Код Наименование, Артикул, Есть...

6
GreenkA
Форумчанин
Эксперт 1С
3004 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
21.03.2016, 19:09 2
Andryan00, на событие ПриИзменении поля с наименованием:
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура НаименованиеПриИзменении(Элемент)
 Объект.Цена = ПолучитьЗначениеРеквизитаНаСервере(Объект.Наименование,"Цена");
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаНаСервере(Элемент,ИмяРеквизита)
 Возврат Элемент[ИмяРеквизита];
КонецФункции
0
Andryan00
0 / 0 / 0
Регистрация: 16.05.2015
Сообщений: 4
21.03.2016, 19:32  [ТС] 3
Добавлено через 1 минуту
GreenkO,
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура НаименованиеПриИзменении(Элемент)
 Объект.Цена = ПолучитьЗначениеРеквизитаНаСервере(Объект.Наименование,"Цена");
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаНаСервере(Элемент,Цена)
 Возврат Элемент[Цена];
КонецФункции
Не срабатывает...
0
GreenkA
Форумчанин
Эксперт 1С
3004 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
21.03.2016, 19:37 4
Andryan00, а вы связали код с событием элемента формы?
0
Andryan00
0 / 0 / 0
Регистрация: 16.05.2015
Сообщений: 4
21.03.2016, 19:47  [ТС] 5
Сделал
0
Миниатюры
Перенос данных из справочника в документ  
GreenkA
Форумчанин
Эксперт 1С
3004 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
21.03.2016, 19:52 6
Лучший ответ Сообщение было отмечено Andryan00 как решение

Решение

Andryan00, надо было сразу сказать, что поля в табличной части документа. В названии процедуры вместо ТабличнаяЧасть1 напишите название вашей ТЧ.
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ТабличнаяЧасть1НаименованиеПриИзменении(Элемент)
 ТекСтрока = Элемент.Родитель.ТекущиеДанные;
 ТекСтрока.Цена = ПолучитьЗначениеРеквизитаНаСервере(ТекСтрока.Наименование,"Цена");
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаНаСервере(Элемент,Цена)
 Возврат Элемент[Цена];
КонецФункции
1
Andryan00
0 / 0 / 0
Регистрация: 16.05.2015
Сообщений: 4
21.03.2016, 20:01  [ТС] 7
Огромное вам спасибо
0
21.03.2016, 20:01
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.03.2016, 20:01

Перенос данных из справочника в табличную часть формы документа
Здравствуйте. Создаю документ в конфигурации Бухгалтерия предприятия, редакция 2.0 (2.0.43.6) на...

Перенос данных из обработки в документ
Народ, пишу небольшую программку. Смысл её в том что-бы заказчик мог искать номенклатуру по номеру...

Данные из справочника в документ и обратно.
Здравствуйте! Помогите пожалуйста. Я из справочника загружаю все элементы в Документ (в табличную...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.