Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
1

Отобразить список отчет в отдельном окне

22.03.2016, 11:50. Просмотров 501. Ответов 9
Метки нет (Все метки)

Добрый день! Подскажите как при нажатии на кнопку открывается окно со списком отчетов, где при нажатии на отчет он открывался
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.03.2016, 11:50
Ответы с готовыми решениями:

Открыть форму в отдельном окне
Открываю форму так: Форма =...

Как отобразить и заполнить список выбора в 8.3
Добрый день. Есть на форме у меня таблица. Две колонки. Одна колонка число,...

Отчет СКД. Вывод нескольких таблиц в отчет из разных запросов.
Привет, коллеги! Возникла необходимость в одном отчете видеть 2 таблички: одну...

Отчет РАУЗ переделать в отчет с партионным учетом
Возможно ли типовой отчет построенный на РАУЗ переделать так, чтобы он работал...

При нажатии на ссылку создать выпадающей список в отдельном окне
Здравствуйте. Помогите реализовать следующее: На странице разместить ссылку...

9
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
22.03.2016, 12:15 2
Ermak27, ничего непонятно. Что надо сделать?
0
SonicQ
282 / 182 / 18
Регистрация: 20.02.2012
Сообщений: 916
22.03.2016, 12:53 3
Ermak27, можно сделать форму динамическую, куда выводить ссылки на отчеты
0
Миниатюры
Отобразить список отчет в отдельном окне  
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
22.03.2016, 13:32  [ТС] 4
GreenkO, при нажатии на кнопку открывается Выбор объекта: Отчет, нужно чтобы отображались только мои отчеты, которые я выберу а не все.
0
Миниатюры
Отобразить список отчет в отдельном окне  
Jackshi
59 / 59 / 6
Регистрация: 16.01.2013
Сообщений: 155
22.03.2016, 15:23 5
Ermak27,
Рисуй форму. Отбирай через метаданные -> отчеты
0
SonicQ
282 / 182 / 18
Регистрация: 20.02.2012
Сообщений: 916
22.03.2016, 15:26 6
Описание типов в помощь
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
22.03.2016, 16:39  [ТС] 7
Jackshi, форму я нарисую, а можно пример кода
0
Yanush
159 / 156 / 61
Регистрация: 28.09.2013
Сообщений: 288
Завершенные тесты: 1
22.03.2016, 17:31 8
Такую штуку хочешь сделать?)
0
Миниатюры
Отобразить список отчет в отдельном окне  
Jackshi
59 / 59 / 6
Регистрация: 16.01.2013
Сообщений: 155
23.03.2016, 10:18 9
Ermak27

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
&НаКлиенте
Функция у15()
    
    у15НС();
    
КонецФункции
 
Функция у15НС()
    
    Для Каждого Стр Из Метаданные.Обработки Цикл
        
        Кмд                 = ЭтаФорма.Команды.Добавить(Стр.Имя);
        Кмд.Действие        = "ЗапуститьПриложениеНК";
        Кмд.Заголовок       = Стр.Синоним;
 
        Кнопка              = ЭтаФорма.Элементы.Добавить(Стр.Имя,Тип("КнопкаФормы"));
        Кнопка.Вид          = ВидКнопкиФормы.Гиперссылка;
        Кнопка.ИмяКоманды   = Стр.Имя;
        
    КонецЦикла;
    
КонецФункции
 
&НаКлиенте
Процедура ЗапуститьПриложениеНК(Команда)
    
    ОткрытьФорму("Обработка."+Команда.Имя+".Форма.Форма");
    
КонецПроцедуры
Добавлено через 53 секунды
Это на примере обработок
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
23.03.2016, 11:28  [ТС] 10
Всем спасибо, я разобрался и сделал так

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
    спЗначений=Новый СписокЗначений;
    спЗначений.Добавить(0,"Список заявок на дату документа");
    спЗначений.Добавить(1,"Список заявок на дату исполнения");
    
    ВыбранноеЗначение = спЗначений.ВыбратьЭлемент();    
    
    Если ВыбранноеЗначение=Неопределено Тогда
        Возврат 
    ИначеЕсли ВыбранноеЗначение.Значение=0 Тогда
        Форма = Отчеты.СведеньяПоЗаявкамЕдиноеОкно.ПолучитьФорму("ФормаОтчета");
        Форма.Открыть();
    ИначеЕсли ВыбранноеЗначение.Значение=1 Тогда    
        Форма = Отчеты.СведеньяПоИсполнениюЗаявкамЕдиноеОкно.ПолучитьФорму("ФормаОтчета");
        Форма.Открыть();
    КонецЕсли;
0
23.03.2016, 11:28
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.03.2016, 11:28

Создать список в отдельном окне, а затем найти в нем заданные числа
Мне нужно с помощью меню, в одном из окон, создать список, а затем посмотреть...

Отобразить в консольном окне список всех папок заданной директории
Отобразить в консольном окне список всех папок заданной (любой) директории. В...

Как отобразить информацию (введенную в форму), в новом окне и во всплывающем окне?
Подскажите пожалуйста, у меня есть форма в нее делаю запись, как сделать так,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru