Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/8: Рейтинг темы: голосов - 8, средняя оценка - 4.88
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
1

Обращение к реквизиту ТЧ

23.03.2016, 14:46. Просмотров 1492. Ответов 8
Метки нет (Все метки)

Плаваю ещё в 1С программировании...
Как в модуле формы документа обратиться к реквизиту табличной части этого документа?
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.03.2016, 14:46
Ответы с готовыми решениями:

Обращение к реквизиту
Всем привет, помогите начинающему нубу в 1с У меня в документах есть страховой акт, в реквизитах...

Обращение к реквизиту формы
Добрый день всем! Что имеем: 1. Реквизит на форме "Контрагент" 2. Происходит обращение к...

Обращение к реквизиту справочника программно
Здарова. Ситуация: создал справочник, в нём реквизиты. В справочнике ФормаЭлемента создал команду,...

Обращение к реквизиту из внешней обработки
Как обратиться к реквизиту документа из внешней обработки?

Обращение к реквизиту шапки документа
Всем доброго времени! Такой вопрос - как можно поменять реквизит шапки документа?.. Нигде не...

8
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
23.03.2016, 14:57 2
для чего это необходимо? что делать будете с реквизитом тч?
1
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
23.03.2016, 16:17 3
Тамика, для изменения текущей строки
1C
1
2
ТекСтрока = Элементы[ИмяТабличнойЧасти].ТекущиеДанные;
ТекСтрока.Количество = 5;//где Количество - реквизит табличной части
для прохождения по всем строкам используйте цикл:
1C
1
2
3
Для Каждого ТекСтрока из Объект[ИмяТабличнойЧасти] Цикл
 ТекСтрока.Количество =5;
КонецЦикла;
для добавления новой строки:
1C
1
2
НовСтрока = Объект[ИмяТабличнойЧасти].Добавить();
НовСтрока.Количество =5;
1
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
23.03.2016, 17:38  [ТС] 4
GreenkO, прошу прощения, но у меня снова ступор. Сбросила конфигурацию(не знаю верно ли выгрузила...). Проблема с документом НачисленияЗарплат. В модуле объекта я сделала автоподстановку оклада по фамилии... То есть, при выборе фамилии поле СтавкаЗаМесяц должно заполнится само. А оно мало того, что не заполняется, так ещё отладчик показал, что даже не заходит в функцию ПриИзменении... Тестовая База 1.rar
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
23.03.2016, 18:43 5
Тамика, у меня проблемы при загрузке конфигурации из файлов. На Configuration.xml выдает несоответствие XDTO.
Можете выгрузить конфигурацию одним файлом(Конфигурация - Сохранить конфигурацию в файл)? Или базу(Администрирование - Выгрузить информационную базу).
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
23.03.2016, 18:51  [ТС] 6
GreenkO, 1Cv8.rar так?
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
23.03.2016, 18:57 7
Тамика, а можете перед выгрузкой установить режим совместимости? У вас платформа 8.3.7, у меня 8.3.6, не открывает. После выгрузки можно будет все вернуть.
0
Миниатюры
Обращение к реквизиту ТЧ  
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
23.03.2016, 19:52  [ТС] 8
Поставила режим совместимости с 8.3.6. Или всё-таки лучше поставить с 8.3.4?
0
Вложения
Тип файла: rar 1Cv836.rar (37.1 Кб, 2 просмотров)
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
23.03.2016, 20:12 9
Лучший ответ Сообщение было отмечено Тамика как решение

Решение

Тамика, события элементов формы описываются &НаКлиенте(так было и по умолчанию, вы видимо изменили). Обращение к данным регистра сведений происходит &НаСервере, т.е. вам надо было вызвать функцию на сервере для получения ставки.
По работе с регистром сведений - есть такая функция ПолучитьПоследнее(...) - она сразу дает вам последнюю запись по регистру по заданному отбору.
Пользуйтесь синтакс-помощником, там так же описано, где можно вызывать определенные методы и получать свойства.

Измененный код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
&НаКлиенте
Процедура НачислениеЗарплатФИОПриИзменении(Элемент)
    ТекСтрока = Элемент.Родитель.ТекущиеДанные; //Элемент.Родитель = Табличная часть документа, получаем текущую строку 
    ТекСтрока.СтавкаЗаМесяц = ПолучитьСтавкуЗаМесяцНаСервере(ТекСтрока.ФИО);
КонецПроцедуры
 
&НаСервере
Функция  ПолучитьСтавкуЗаМесяцНаСервере(ФИО)
    Отбор = Новый Структура;
    Отбор.Вставить("Сотрудник", ФИО);
    ОкладыСотрудника = РегистрыСведений.ДанныеОСотрудниках.ПолучитьПоследнее(Объект.Дата, Отбор);   
    
    Если ОкладыСотрудника.Количество() = 0 Тогда
        Сообщить("Нет записей");
        Возврат 0;
    Иначе  
        Возврат ОкладыСотрудника.Оклад;
    КонецЕсли;
КонецФункции
1
23.03.2016, 20:12
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.03.2016, 20:12

Обращение к реквизиту формы документа через внешнюю печатную форму.
Здравствуйте Есть внешняя печатная форма и документ "Договор". У документа есть на форме реквизит...

Обращение к реквизиту (ссылка) другого документа 1с 7.7
Всем Здравствуйте! Нужна помощь, в программировании я не силен. В конфигураторе 1с 7.7 (нетиповая...

Отчёт по реквизиту
Ребят я новичок в этом деле. помогите. Допустим у номенклатуры есть реквизит (галочка) Спец товар....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru