Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
1

Выгрузка в текстовый файл данных из справочника

23.03.2016, 20:30. Просмотров 860. Ответов 10
Метки нет (Все метки)

Нужно реализовать выгрузку данных из справочника номенклатура, отпускная цена который больше 100 , но меньше 200.
Сделал так, чтобы выгружались все файлы, но чтобы отпускная цена была как по заданию реализовать не знаю как.
Помогите пожалуйста с кодом.



В этом коде просто вывожу данные из справочника номенклатура
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Процедура Кнопка5ВыполнитьНажатие(Кнопка5)
    
Текст = Новый ТекстовыйДокумент; 
Выборка = Справочники.Номенклатура.Выбрать(); 
 
Пока Выборка.Следующий() Цикл 
    Стр = СтрЗаменить(Выборка.Наименование, Символ(1), "Список"); 
    Код = Строка(Выборка.Код) + Символ(34); 
    Текст.ДобавитьСтроку(Код + Стр); 
КонецЦикла; 
 
Текст.Записать("c:\Nomen.txt");  
 
КонецПроцедуры

В этом коде сделал через "сообщить", но нужно ,чтобы данные записывались в текстовый файл, помогите с этим.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура Кнопка3ВыполнитьНажатие(Кнопка3)
    
    
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если Выборка.ОтпускнаяЦена > 100  Тогда
Сообщить(Выборка.Наименование + " Имеет цену " + Выборка.ОтпускнаяЦена);
 
Иначе
  Если Выборка.ОтпускнаяЦена <200  Тогда
Сообщить(Выборка.Наименование + " Имеет цену " + Выборка.ОтпускнаяЦена);
 
КонецЕсли; 
КонецЕсли; КонецЦикла;
КонецПроцедуры
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.03.2016, 20:30
Ответы с готовыми решениями:

Выгрузить данные из справочника в текстовый файл
Здарова. Проблема- не выгружаются данные из справочника в текстовый файл....

Выгрузка из 1С в текстовый файл
Привет. нужна помощь. срочно. есть вопрос по програмированию в 1с задача такая...

Выгрузка справочника
Подскажите, пожалуйста, в какой книге/на каком интернет-ресурсе лучше описано,...

Выгрузка данных из отчета в файл
Здравствуйте. Дано: 11 отчетов, готовых, который формируют данные. Помогите...

Выгрузка данных из Документа в DBF файл
Здравствуйте! Вот у меня следующий вопрос. Я делаю выгрузку данных из...

10
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
23.03.2016, 20:42 2
Лучший ответ Сообщение было отмечено Svyatoslav359 как решение

Решение

Svyatoslav359,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура Кнопка5ВыполнитьНажатие(Кнопка5)
    
Текст = Новый ТекстовыйДокумент; 
Выборка = Справочники.Номенклатура.Выбрать(); 
 
Пока Выборка.Следующий() Цикл 
    Если Выборка.ОтпускнаяЦена > 100 И Выборка.ОтпускнаяЦена <200  Тогда
     Cтр = СтрЗаменить(Выборка.Наименование, Символ(1), "Список"); 
     Код = Строка(Выборка.Код) + Символ(34); 
     Текст.ДобавитьСтроку(Код + Стр); 
    КонецЕсли;
КонецЦикла; 
 
Текст.Записать("c:\Nomen.txt");  
КонецПроцедуры
1
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
23.03.2016, 22:14  [ТС] 3
Вроде бы , всё так, я тоже так пробовал, но не пишет всё равно.
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
23.03.2016, 22:15 4
Svyatoslav359, а у вас в выборке есть такие значения? > 100 и < 200
Там где код про Сообщить пропишите для анализа:
1C
1
2
3
Если Выборка.ОтпускнаяЦена > 100 И Выборка.ОтпускнаяЦена <200  Тогда
     Сообщить(Выборка.ОтпускнаяЦена);
КонецЕсли;
1
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
24.03.2016, 08:44  [ТС] 5
Значения то выводятся, они у меня есть через сообщить, так изначально и было.
Но всё равно не записывается.
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
24.03.2016, 09:07 6
Svyatoslav359, а без условия записывает в текстовый файл?
Выложите вашу обработку.
1
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
24.03.2016, 09:11  [ТС] 7
Тут выводится вся номенклатура без условия больше 100 и меньше 200-от.
С условием не записывает, без условия записывает.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Процедура Кнопка5ВыполнитьНажатие(Кнопка5)
    
Текст = Новый ТекстовыйДокумент; 
Выборка = Справочники.Номенклатура.Выбрать(); 
 
Пока Выборка.Следующий() Цикл 
    Стр = Строка(Выборка.Наименование); 
   Код = Строка(Выборка.Код); 
    Текст.ДобавитьСтроку(Код + Стр); 
КонецЦикла; 
 
Текст.Записать("c:\Nomen.txt");  
 
КонецПроцедуры



1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Процедура Кнопка6ВыполнитьНажатие(Кнопка6)
        
Текст = Новый ТекстовыйДокумент; 
Выборка = Справочники.Номенклатура.Выбрать(); 
 
Пока Выборка.Следующий() Цикл 
    Если Выборка.ОтпускнаяЦена > 100 И Выборка.ОтпускнаяЦена <200  Тогда
     Cтр = Строка(Выборка.Наименование); 
     Код = Строка(Выборка.Код);
     ОтпускнаяЦена = Строка(Выборка.ОтпускнаяЦена);
     Текст.ДобавитьСтроку(Код + Cтр + ОтпускнаяЦена); 
    // Сообщить(Выборка.Наименование + " Имеет цену " + Выборка.ОтпускнаяЦена);
 
    КонецЕсли;
КонецЦикла; 
 
Текст.Записать("c:\tree.txt");      
    
    
КонецПроцедуры
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
24.03.2016, 09:13 8
Svyatoslav359, проверьте тип реквизита ОтпускнаяЦена у Номенклатуры, там точно Число?
0
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
24.03.2016, 09:21  [ТС] 9
Да, там тип "Число".
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
24.03.2016, 09:22 10
Svyatoslav359, у вас самописная конфигурация?
Если да, то лучше выложите базу, заодно и посмотрю отпускные цены.
1
Svyatoslav359
1 / 1 / 2
Регистрация: 10.06.2015
Сообщений: 53
24.03.2016, 09:52  [ТС] 11
Спросил у преподавателя, по коду всё правильно, значит что-то с технической частью программы.
Спасибо. :-)
0
24.03.2016, 09:52
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.03.2016, 09:52

Выгрузка данных в dbf файл: обработка выборки запроса на сервере, запись файла - на клиенте.
Добрый день. Пишу процедуру выгрузки данных в dbf файл. Запрос выполняется...

Не проходит выгрузка ИБ в файл
При попытке выгрузки ИБ происходит ошибка: не хватает места в папке, где...

Выгрузка Данных
Пожалуйста помогите!!! Прислали вот такое задание: &quot;Выгрузка данных...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru