Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,313
Записей в блоге: 32
1

Отчет о начислениях

24.03.2016, 23:21. Просмотров 1060. Ответов 9
Метки нет (Все метки)

Добрый день! Точнее... Уже доброй почти ночи.
Такой вопрос.
Есть конфигурация, есть документ НачисленияЗарплат. Есть Регистр актуальных зарплат. Задание такое: сформировать отчет с*колонками* "начислено",*"выплачено",*"конечный*остаток". В связи с этим два вопроса... Первый - поскольку мой регистр копит только данные об актуальных зарплатах, то нужно создать отдельный регистр для начислений, чтобы сформировать из него отчёт потом? И второй вопрос - разъясните, пожалуйста, плюснику и нубу в терминах экономики, что такое "начислено", "выплачено" и "конечный остаток".))
Я так поняла, что "начислено" - это за всё время сколько всего начислено зарплаты сотруднику?
"выплачено" - это сколько выплачено?.. Но тогда в чем разница от "начислено?"
"конечный остаток" - совсем в ступор вводит... Остаток от чего?..
Заранее спасибо всем, кто откликнется.

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.03.2016, 23:21
Ответы с готовыми решениями:

Отчет СКД. Вывод нескольких таблиц в отчет из разных запросов.
Привет, коллеги! Возникла необходимость в одном отчете видеть 2 таблички: одну по продажам, другую...

Отчет РАУЗ переделать в отчет с партионным учетом
Возможно ли типовой отчет построенный на РАУЗ переделать так, чтобы он работал в партионном учете?...

Отчет
У меня есть проблема с выводом на печать отчета: Есть отчет, ввиде таблицы, одно поле числовое -...

отчет
подскажите что повесить на кнопку чтобы отчет открывался из формы "личные карточки" с данными...

Отчет
Помогите пожалуйста доделать отчет: При выборе даты начала и окончания, фирмы, и одного из...

9
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
24.03.2016, 23:41 2
Лучший ответ Сообщение было отмечено Тамика как решение

Решение

Тамика, а у вас регистры расчета и бухгалтерии не планируются?
Давно я имела дело с ЗУП (типовая конфигурация по зарплате). Возможно объявится тот, кто все лучше прояснит и напомнит логику).
Как мне представляется, суть в следующем:
- Начислено - это общая сумма к начислению сотруднику. С учетом премий и других надбавок, но за вычетом удержаний. Это могут быть удержания на основании определенных штрафов, выговоров и т.п. Хотя здесь вообще, если вести речь об удержаниях, то я бы добавила еще одну колонку для ясности: Начислено, Удержано, Выплачено, Кон. остаток. Тогда Выплачено = Начислено - Удержано - Налоги.
- Выплачено - это та сумма (начислено) за вычетом всех налогов (подоходный, пенсионный, профсоюзный если есть)
- Конечный остаток - образовавшийся остаток по сумме, ввиду каких-либо перерасчетов ЗП, недовыплат и т.д. Для учета конечного остатка надо использовать регистр накопления Остатков.

Все эти операции еще отражаются бух. проводками: начисление ЗП сотруднику, выплата ЗП из кассы, уплата налогов и т.д. Поэтому и спросила выше про регистры.

Вообще довольно серьезная конфигурация у вас намечается. Лучше бы вам пообщаться с опытным ЗУПером)
1
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,313
Записей в блоге: 32
24.03.2016, 23:49  [ТС] 3
Цитата Сообщение от GreenkO Посмотреть сообщение
Вообще довольно серьезная конфигурация у вас намечается. Лучше бы вам пообщаться с опытным ЗУПером)
А вот мне кинули задание, упорно утверждая что это очень просто и нужо всего пару дней. Теперь комплексую, ибо уже четвертый день сижу... )))) Если бы не Вы, то ещё больше сидела бы.
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
24.03.2016, 23:51 4
Лучший ответ Сообщение было отмечено Тамика как решение

Решение

Тамика, здесь в рамках вашей задачи можно все упростить. Например, добавив регистр накопления Остатки - ВзаиморасчетыСРаботниками. В него Приход будет делать документ "Начисление зарплаты", а Расход - новый документ "Выплата зарплаты". На основании данных этого регистра вы сможете получать Кон. остаток.
На основании этого же регистра будете получать Обороты: Приход за период - как Начислено, Расход за период - как Выплачено.
Будут ли учитываться у вас налоги, не знаю.

Конечно, когда речь идет о зарплате правильнее использовать регистры расчета. Но они нужны для учета рабочих дней/часов, т.е. когда у вас есть различные невыходы, больничные и зарплата рассчитывается пропорционально отработанным дням/часам. У вас как?

Добавлено через 1 минуту
Тамика, а какой текст задания? Может там не так все сложно) Просто я анализирую то, с чем имела дело и возможно усложняю.
1
24.03.2016, 23:51
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,313
Записей в блоге: 32
24.03.2016, 23:55  [ТС] 5
Цитата Сообщение от GreenkO Посмотреть сообщение
ак мне представляется, суть в следующем:
ё-маё...

Цитата Сообщение от GreenkO Посмотреть сообщение
а какой текст задания?
Тестовое задание по программированию на базе 1С.pdf
По началу казалось всё просто... Думала, что обойдётся без налогов и прочего..((
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
25.03.2016, 00:03 6
Лучший ответ Сообщение было отмечено Тамика как решение

Решение

Тамика, ну так не страшно, смотрите сообщение выше, где описан документ "Выплата зарплаты" и регистр накопления Остатки "ВзаиморасчетыСРаботниками".
В вашем задании ни про удержания, ни про налоги речи нет, значит не надо усложнять. В идеале "начислено" должно быть равно "выплачено". Но возможно деньги в кассе закончились и т.п.))
Попробуйте пока создать документ "Выплата зарплаты" и регистр накопления, и сделать движения в него двух документов.
А к этому механизму:
В документе должна быть функция заполнить по невыплаченной зарплате сотрудников
если будут вопросы - еще вернемся.

Добавлено через 41 секунду
регистры расчета и бухгалтерии тоже делать не надо.
1
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,313
Записей в блоге: 32
25.03.2016, 14:06  [ТС] 7
GreenkO, спасибо огромное! *ушла в работу* )

Добавлено через 14 часов 0 минут
GreenkO, простите меня за наглость, но не могли бы Вы глянуть конфигурацию? Так сказать проверить с учётом задания. А то я боюсь сдавать задание... Там наверное столько ошибок...
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
25.03.2016, 15:41 8
Тамика, давайте, выкладывайте)
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,313
Записей в блоге: 32
25.03.2016, 15:49  [ТС] 9
GreenkO, только не серчайте сильно... Для Вас это будет тихий ужас. 1Cv8.rar
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
25.03.2016, 18:02 10
Тамика,
1. Документ Изменение оклада: у вас есть реквизит Дата нового оклада, зачем? В обработке проведения в Период регистра вы проставляете Дату документа.
2. Документ Прием на работу: в задании у вас сказано
Реализовать возможность отражения приема на работу сотрудника с указанием даты приема, должности и суммы оклада.
У вас ни должность, ни оклад в этом документе не указываются.
В документе по заданию должен быть механизм:
В документе должна быть возможность заполнения документа актуальными сотрудниками и их окладами.
У вас его нет.
Вам нужно создать команду в форме документа Начисление зарплаты. Там прописать следующее:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере()
    Объект.НачислениеЗарплат.Очистить();
    Запрос = Новый Запрос("ВЫБРАТЬ
                          | ДанныеОСотрудникахСрезПоследних.Сотрудник КАК ФИО,
                          | ДанныеОСотрудникахСрезПоследних.Оклад КАК СтавкаЗаМесяц
                          |ИЗ
                          | РегистрСведений.ДанныеОСотрудниках.СрезПоследних(&Период, Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияСотрудника.ПринятНаРаботу)) КАК ДанныеОСотрудникахСрезПоследних");
    Запрос.УстановитьПараметр("Период", Объект.Дата);                     
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        НовСтрока = Объект.НачислениеЗарплат.Добавить();
        ЗаполнитьЗначенияСвойств(НовСтрока, Выборка);       
    КонецЦикла;
КонецПроцедуры
Здесь мы получаем из виртуальной таблицы СрезПоследних регистра данные об актуальных сотрудниках и их ставки.

2. Документы Начисление и Выплаты и регистр накопления: вы сделали два ресурса регистра накопления. И делаете Приход и Расход в разные ресурсы. Т.е. что у вас получится в итоге: на одном ресурсе сумма будет бесконечно расти, на другом бесконечно уходить в минус. Надо было создать один ресурс - Сумма. И по нему делать и Приход, и Расход. В Этом и суть регистра накопления Остатки. Как вы тогда получите в отчете Кон. остаток? (вы его кстати и не получаете)

3. По заданию:
Реализовать возможность выплаты зарплаты сотрудникам. В документе должна быть функция заполнить по невыплаченной зарплате сотрудников.
Т.е. у вас должна быть табличная часть в документе, как и в Начислении зарплаты(я сделала реквизиты - ФИО, СуммаНачисления, СуммаВыплаты). Далее для заполнения табличной части: создайте кнопку в форме документа Выплата зарплаты. И припишите следующий код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере()
    Объект.ВыплатаЗарплат.Очистить();
    Запрос = Новый Запрос("ВЫБРАТЬ
                          | ВзаиморасчётыССотрудникамиОстатки.ФИО,
                          | ВзаиморасчётыССотрудникамиОстатки.СуммаОстаток КАК СуммаНачисления
                          |ИЗ
                          | РегистрНакопления.ВзаиморасчётыССотрудниками.Остатки(&Период, ) КАК ВзаиморасчётыССотрудникамиОстатки");
    Запрос.УстановитьПараметр("Период", Объект.Дата);                     
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        НовСтрока = Объект.ВыплатаЗарплат.Добавить();
        ЗаполнитьЗначенияСвойств(НовСтрока, Выборка);   
        НовСтрока.СуммаВыплаты = НовСтрока.СуммаНачисления; //заполним одинаково, но сумму выплаты смогут менять вручную
    КонецЦикла;
    
КонецПроцедуры
В движения надо записывать именно СуммуВыплаты из ТЧ.

Про отчет сказала выше - нет Кон. Остатка. Плюс включите возможность изменения периода отбора записей: в СКД на вкладке Настройки, ниже Параметры - на дате Начало периода, правой кнопкой мыши - Свойства элемента пользовательских настроек - Включить в состав пользовательских настроек.
1
25.03.2016, 18:02
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.03.2016, 18:02

Отчет в БД
Здраствуйте уважаемые программисты! Помогите сделать отчет в БД Access. Кое что написал сам, но...

Отчет
Приветик всем! Помогите плиз, у мменя есть база данных Access и мне нужно вывести отчет по...

Отчет В 1с 7.7
в базе есть документы "инвентаризацияТМЦ" сделанных по группам товаров нужно получить отчет с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru