Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
1

1C 8 УПП обычные формы отразить табличное поле без привязки к данным

29.03.2016, 09:06. Просмотров 1212. Ответов 15
Метки нет (Все метки)

1C 8 УПП обычные формы отразить табличное поле без привязки к данным.
Надо просто просмотреть результаты запроса (он создается при изменении строки ТП Документа ) в отдельной таблице без создания табличного поля документа. Как лучше?
Дело в том что когда я пишу в существующее ТП документа потом вечно вылетает сообщение об сохранении данных
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.03.2016, 09:06
Ответы с готовыми решениями:

Форму списка Заказов разбить на 4-ре списка по данным из регистра сведений (8.2, обычные формы)
Доброго времени суток, Форумчане! после решения данной задачи я сильно...

Табличное Поле
Всем привет! Недавно начал изучать 1С 8.1 Программирование и столкнулся пока...

Табличное Поле
Всем привет! Недавно начал изучать 1С 8.1 Программирование и столкнулся пока...

Отчет СКД и табличное поле
Создаю отчет с помощью СКД. Как мне вывести результат в табличное поле? Не в...

Вставить значение в табличное поле 8
Если для колонки ТП Поле выбора в качестве элемента управления...

15
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
29.03.2016, 09:45 2
Цитата Сообщение от alexandr_f Посмотреть сообщение
Надо просто просмотреть результаты запроса
Результат запроса можно посмотреть в отладчике:
1C
1
Запрос.Выполнить().Выгрузить();
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
29.03.2016, 10:17  [ТС] 3
Простите, может непонятно написал.
На форме документа надо отразить выборку из зависимого (неподчиненного) справочника (согласно 1 записи ) без создания ТЧ документа - просто просмотр , типа ЭлементыФормы или другое
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
29.03.2016, 11:01 4
alexandr_f, чем каждый раз перезаполнять ТЧ, лучше создайте дин список(можно как реквизит формы, а не документа), заполняйте его, а при активизации строки делайте отбор.
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
30.03.2016, 09:18  [ТС] 5
Простите нуба
Есть 2 ТЧ
ВредныеФакторы - ТЧ документа
Тип Значения -ДокументТабличнаяЧасть.

ТабличноеПоле1 - реквизит формы типа таблица значений - данные ЭлементыФормы.ВредныеФакторы.ТекущиеДанные
Тип Значения - пусто
Первое заполняется, второе пусто



1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
Процедура ВредныеФакторы(НаборФакторов)
  //НаборФакторов = ЭтотОбъект.Профессии.НаборыВредныхФакторов;     
Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ
|   НаборыВредныхФакторовПереченьФакторов.ПереченьФакторов.НаименованиеПолное КАК Наименование ,
|   НаборыВредныхФакторовПереченьФакторов.ПереченьФакторов.Номер_п_пункта КАК Пункт,
|   НаборыВредныхФакторовПереченьФакторов.ПереченьФакторов.ПериодМесяц КАК Период  ,
|   НаборыВредныхФакторовПереченьФакторов.ПереченьФакторов.ФакторРабота  КАК Фактор
|ИЗ
|   Справочник.НаборыВредныхФакторов.ПереченьФакторов КАК НаборыВредныхФакторовПереченьФакторов
|ГДЕ
|   НаборыВредныхФакторовПереченьФакторов.Ссылка = &НаборФакторов";
 
 
      ЭтотОбъект.ВредныеФакторы.Очистить();
      Запрос.УстановитьПараметр("НаборФакторов",НаборФакторов);
      Результат = Запрос.Выполнить().Выгрузить();
      
    //        Результат = Запрос.Выполнить().Выбрать();
    //ЭтотОбъект.ВредныеФакторы.Загрузить(Результат);    
         //   Пока Результат.Следующий() Цикл
         // НоваяСтрокаВредныеФакторы = ВредныеФакторы.Добавить();
         // НоваяСтрокаВредныеФакторы.ВредныеФакторы=Результат.ПереченьФакторовСсылка;
         // НоваяСтрокаВредныеФакторы.Номер_п_п= Результат.ПереченьФакторовСсылка.Номер_п_пункта;
         // НоваяСтрокаВредныеФакторы.ПериодМесяц=Результат.ПереченьФакторов.ПериодМесяц;
         //
         //         
         //     КонецЦикла;
     Для Каждого ЭлементРезультата из Результат Цикл
        НоваяСтрокаТЧ = ВредныеФакторы.Добавить();
 
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);
 
        
    КонецЦикла;  
    Для Каждого ЭлементРезультата из Результат Цикл
        ЭлементыФормы.ТабличноеПоле1.ДобавитьСтроку();
 
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);
 
        
    КонецЦикла;  
 
     
        
 
КонецПроцедуры
 
 
Процедура ПрофессииПриАктивизацииСтроки(Элемент)
    ТекущаяСтрока = Элемент.ТекущаяСтрока;
    НаборыВредныхФакторов=ТекущаяСтрока.НаборыВредныхФакторов;
    ВредныеФакторы(НаборыВредныхФакторов);
         //СтрокаТабличнойЧасти = ЭлементыФормы.ПолучитьЭлементы();
                // Вставить содержимое обработчика.
КонецПроцедуры
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
30.03.2016, 16:25 6
alexandr_f, в обычной форме добавьте реквизит (см. скрин) типа ТаблицаЗначений, разместите на форме где надо и добавьте нужные колонки. Это будет реквизит формы, а не документа и сохраняться он(если не прописать отдельно) не будет.
0
Миниатюры
1C 8 УПП обычные формы отразить табличное поле без привязки к данным  
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 08:33  [ТС] 7
1C 8 УПП обычные формы отразить табличное поле без привязки к данным
Я создан такое
1C
1
2
3
4
5
6
7
8
        
   Для Каждого ЭлементРезультата из Результат Цикл
        ЭлементыФормы.Факторы.ДобавитьСтроку();
 
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);
 
        
    КонецЦикла;
1C 8 УПП обычные формы отразить табличное поле без привязки к данным

Но Таблица Значений (вторая) - пуста
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 09:48 8
alexandr_f, как-то вы добавляете странно:
1C
1
2
3
4
Для Каждого ЭлементРезультата из Результат Цикл
 НоваяСтрокаТЧ = Факторы.ДобавитьСтроку(); 
 ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);       
КонецЦикла;
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 10:54  [ТС] 9
Так посоветуйте как. Потому что для ТЧ документа мне ничего не надо было делать просто связать с типом
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 11:17 10
alexandr_f, я вам написала код выше, сравните со своим.
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 11:36  [ТС] 11
{Документ.ВводАктаОпределенияКонтингента.Форма.ФормаДокумента.Форма(52)}: Метод объекта не обнаружен (ДобавитьСтроку)
НоваяСтрокаТЧ =Факторы.ДобавитьСтроку();
1C 8 УПП обычные формы отразить табличное поле без привязки к данным
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 11:37 12
alexandr_f, ну да...
1C
1
2
3
4
Для Каждого ЭлементРезультата из Результат Цикл
 НоваяСтрокаТЧ = Факторы.Добавить(); 
 ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ЭлементРезультата);       
КонецЦикла;
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 12:26  [ТС] 13
ТаблицаЗначений Факторы все равно пуста.
0
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 12:53  [ТС] 14
Сама ТаблицаЗначений Факторы заполнена, а на форме не отражается
1C 8 УПП обычные формы отразить табличное поле без привязки к данным

1C 8 УПП обычные формы отразить табличное поле без привязки к данным

Может что-то с привязкой на форме?
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 13:36 15
Лучший ответ Сообщение было отмечено alexandr_f как решение

Решение

alexandr_f, создайте на форме(в конфигураторе) соответствующие столбцы, у вас в таблице колонок нет вообще. Либо можно прописать программное создание колонок.
1
alexandr_f
0 / 0 / 0
Регистрация: 02.01.2013
Сообщений: 40
31.03.2016, 14:18  [ТС] 16
Все получилось. Большое спасибо за долгое терпение
0
31.03.2016, 14:18
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.03.2016, 14:18

Добавление данных в табличное поле
Помогите новичку!!! мне надо добавлять в табличное поле данные к уже...

Командная панель и табличное поле
Всем привет. 8.2 обычное приложение Добавляю мастером на форму табличное поле...

Вставить пустой номер в табличное поле
Подскажите, как вставить пустой номер в табличного поля...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru