Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
juristbrn
2 / 2 / 2
Регистрация: 21.04.2014
Сообщений: 215
1

Открытие формы документа программно

31.03.2016, 14:12. Просмотров 1008. Ответов 4
Метки нет (Все метки)

Делаю так
1C
1
2
3
4
5
 Форма = ОткрытьФорму("Документ.ПриемНаряд.Форма.ФормаДокумента");
 НовыйОбъект = Форма.Объект;
 ЗаполнитьЗначенияСвойств(НовыйОбъект, Данные);
 НовыйОбъект.ВремяНачала = Данные.Время;
 НовыйОбъект.ВремяОкончания = НовыйОбъект.ВремяНачала + 30*60;
Но хочу сделать сначала создание документа и потом получение формы. Пробую так:
1C
1
2
3
4
5
6
7
 НовыйДокумент = Документы.ПриемНаряд.СоздатьДокумент();
 Форма =  НовыйДокумент.ПолучитьФорму("Документ.ПриемНаряд.Форма.ФормаДокумента");
 НовыйОбъект = Форма.Объект;
 ЗаполнитьЗначенияСвойств(НовыйОбъект, Данные);
 НовыйОбъект.ВремяНачала = Данные.Время;
 НовыйОбъект.ВремяОкончания = НовыйОбъект.ВремяНачала + 30*60;
 Форма.Открыть();
В таком случае ошибка:
Значение не является значением объектного типа (Объект) НовыйОбъект = Форма.Объект;

Подскажите, как исправить...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.03.2016, 14:12
Ответы с готовыми решениями:

Открытие формы документа с заполнением данных из формы справочника
Здравствуйте! Платформа 1с 8.3, пытаюсь создать базу пациентов.)) Есть...

Поиск нужного документа и открытие формы
Уважаемые пользователи форума, ору вам о помощи - не могли бы вы помочь...

Программно вызвать процедуру при изменении( поля формы тч документа)
Предисловие: Из документа я вызываю процедуру, которая берёт данные из регистра...

Программное создание нового документа и открытие его формы с заполненными реквизитами
Здравствуйте. В собственной конфигурации 1с 8.3 есть справочник...

С формы списка документа изменить данные самого документа 1С 8.2 Управляемое приложение
Есть документ ЗаказКлиента с формой документа и с формой списка (формы...

4
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 14:35 2
juristbrn, созданный документ записываться будет? Можно
1C
1
НовыйОбъект.Записать();
Потом передать ссылку на клиент и там:
1C
1
ОткрытьЗначение(СсылкаНаНовыйДок);
Добавлено через 2 минуты
juristbrn,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура КнопкаВызоваФормы(Команда)
 СсылкаНаНовыйДок = СоздатьНовыйДокНаСервере();
 ОткрытьЗначение(СсылкаНаНовыйДок );
КонецПроцедуры
 
&НаСервере
Функция СоздатьНовыйДокНаСервере()
 НовыйДокумент = Документы.ПриемНаряд.СоздатьДокумент();
 //ЗаполнитьЗначенияСвойств(НовыйДокумент, Данные); //не знаю, что такое Данные правда...
 НовыйДокумент.ВремяНачала = Данные.Время;
 НовыйДокумент.ВремяОкончания = НовыйДокумент.ВремяНачала + 30*60;
 НовыйДокумент.Записать();
 Возврат НовыйДокумент.Ссылка;
КонецФункции
1
juristbrn
2 / 2 / 2
Регистрация: 21.04.2014
Сообщений: 215
31.03.2016, 14:56  [ТС] 3
GreenkO, а если не записывать ?
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
31.03.2016, 15:09 4
juristbrn, тогда можно так:
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура КнопкаВызоваФормы(Команда)
Форма = ПолучитьФорму("Документ.ПриемНаряд.Форма.ФормаДокумента");
 НовыйОбъект = Форма.Объект;
 //ЗаполнитьЗначенияСвойств(НовыйОбъект, Данные);
 НовыйОбъект.ВремяНачала = Данные.Время;
 НовыйОбъект.ВремяОкончания = НовыйОбъект.ВремяНачала + 30*60;
 Форма.Открыть();
КонецПроцедуры
0
Nenaviju1C
43 / 43 / 6
Регистрация: 17.03.2016
Сообщений: 117
31.03.2016, 17:36 5
Используй синтаксис 8.3 а не 8.1

Как оно должно быть в 8.3:
1C
1
2
3
    ПараметрыФормы = Новый Структура("ЗакрыватьПриЗакрытииВладельца", Истина);
    ПараметрыФормы.Вставить("ЗначенияЗаполнения", Новый Структура("ВремяНачала,ВремяОкончания", Данные.Время, НовыйОбъект.ВремяНачала + 30*60));
    ОткрытьФорму("Документ.ПриемНаряд.ФормаОбъекта", ПараметрыФормы, ЭтаФорма, КлючУникальности);
0
31.03.2016, 17:36
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.03.2016, 17:36

Создание и запись документа программно
День добрый, с недавних пор работаю прог 1с и некоторые задачи реализовать...

Установить программно время документа
Доброго времени суток! Такой вопрос назрел - никак не получается создать...

Открытие формы бизнес-процесса из формы списка
Имеется форма списка задачи (скрин ниже), как сделать, чтобы при двойном клике...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru