Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
harak21
0 / 0 / 0
Регистрация: 01.12.2014
Сообщений: 5
1

Заполнение табличной части одного документа данными из ТЧ другого

07.04.2016, 16:41. Просмотров 951. Ответов 2
Метки нет (Все метки)

Здравствуйте. Есть 2 документа:
1) "Выдача книги" с табличной частью "Список" с реквизитами "Название", "Количество".
2) "Возврат книги" с реквизитом "Читатель" (ДокументСсылка.ВыдачаКниги) и идентичной табличной частью.
Мне нужно, чтобы при выборе в документе "возврат книги" значения реквизита "Читатель" автоматически заполнялась табличная часть. Вот код, который я написал.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура ДокументПриИзменении(Элемент)
    ДокументПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ДокументПриИзмененииНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ВыдачаКниги.Список.(
                   |        Название,
                   |        Количество
                   |    )
                   |ИЗ
                   |    Документ.ВыдачаКниги КАК ВыдачаКниги
                   |ГДЕ
                   |    ВыдачаКниги.Ссылка = &Документ";
    Запрос.УстановитьПараметр("Документ",Объект.Документ);
    Объект.Список.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры
Я новичек в 1С, поэтому не понимаю, почему приведенный выше код не работает. Вместо заполнения всей табличной части, мне выдает лишь цифру 1 в номере строки. Объясните пожалуйста, в чем ошибка?

Добавлено через 1 час 14 минут
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
&НаКлиенте
Процедура ДокументПриИзменении(Элемент)
    ДокументПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ДокументПриИзмененииНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ВыдачаКниги.Список.(
                   |        Название,
                   |        Количество
                   |    )
                   |ИЗ
                   |    Документ.ВыдачаКниги КАК ВыдачаКниги
                   |ГДЕ
                   |    ВыдачаКниги.Ссылка = &Документ";
    Запрос.УстановитьПараметр("Документ",Объект.Документ);
 
    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        НоваяСтрока = Объект.Список.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрока,ВыборкаДетальныеЗаписи);
    КонецЦикла;
        
КонецПроцедуры
Этот вариант тоже не работает.

Добавлено через 32 минуты
Благодарю, решение найдено
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.04.2016, 16:41
Ответы с готовыми решениями:

Заполнение табличной части одного документа на основании другого.
Мне необходимо чтобы в Документе :ЗаказНаПроизводство в Табличной части: Товар отражались данные...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Заполнение табличной части документа данными из справочника
Добрый день! Очень нужна ваша помощь ! Есть справочник Должности (на каждую должность список спец...

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать. ...

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа "Индивидуальный заказ" и...

2
te_morituri
22 / 22 / 4
Регистрация: 17.10.2009
Сообщений: 281
10.04.2016, 19:05 2
если нашли решение, пропишите его, пожалуйста)
0
harak21
0 / 0 / 0
Регистрация: 01.12.2014
Сообщений: 5
10.04.2016, 20:43  [ТС] 3
честно говоря, я решил просто создавать документ "Возврат книги" на основе документа "Выдача книги"
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.04.2016, 20:43

Заполнение табличной части документа данными из нескольких документов
Здравствуйте! Столкнулась с такой проблемой. Имеется 2 документа: "Акт" и "Ведомость". Документ...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru