Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
lostuk
2 / 2 / 4
Регистрация: 04.12.2013
Сообщений: 45
1

Из одного документа получить данные табличной части другого документа

10.04.2016, 09:18. Просмотров 1258. Ответов 1
Метки нет (Все метки)

Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать.
Вопрос такой. Есть документ "СписокЗаказов" Название: Screenshot_71.jpg
Просмотров: 39

Размер: 14.2 Кб и "ПутевойЛист" Название: Screenshot_1.jpg
Просмотров: 39

Размер: 10.5 Кб.


Надо что б в документе "ПутевойЛист" при выборе реквизита "Заказ" заполнялась табличная часть данными из документа "СписокЗаказов".
Можно ли это реализовать?
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.04.2016, 09:18
Ответы с готовыми решениями:

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа "Индивидуальный заказ" и...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Заполнение табличной части одного документа данными из ТЧ другого
Здравствуйте. Есть 2 документа: 1) "Выдача книги" с табличной частью "Список" с реквизитами...

Заполнение табличной части одного документа на основании другого.
Мне необходимо чтобы в Документе :ЗаказНаПроизводство в Табличной части: Товар отражались данные...

Как получить данные из табличной части документа
Есть Документ Поступление Товаров с табличной частью Товары и в ней есть реквизиты Номенклатура и...

1
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
10.04.2016, 10:30 2
Лучший ответ Сообщение было отмечено lostuk как решение

Решение

lostuk, можно. В форме документа "Путевой лист" на событие поля "Заказ" ПриИзменении:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура ЗаказПриИзменении(Элемент)
    ЗаказПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаказПриИзмененииНаСервере()
 Объект.ТЧПЛ.Очистить();
 Для Каждого ТекСтрока Из Объект.Заказ.ТЧСЗ Цикл
  НовСтрока = Объект.ТЧПЛ.Добавить();
  ЗаполнитьЗначенияСвойств(НовСтрока, Текстрока);
  НовСтрока.Клиент = Объект.Заказ.Клиент;
  //как у вас будет заполняться Номер и Район - смотрите сами
 КонецЦикла;
КонецПроцедуры
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.04.2016, 10:30

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Вывод на печать табличной части одного документа
Ребята, выручайте. Понимаю, что ошибка пустяковая, но я ее не вижу((((((((((((((( Выводит на...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru