Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
juristbrn
2 / 2 / 2
Регистрация: 21.04.2014
Сообщений: 215
1

Не создается движение расход в ОстаткахНоменклатуры

16.04.2016, 11:06. Просмотров 335. Ответов 1
Метки нет (Все метки)

Обработка проведения

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
Процедура ОбработкаПроведения(Отказ, Режим)
    
      Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ЗаказПоставщикуМатериал.Номенклатура,
                   |    СУММА(ЗаказПоставщикуМатериал.Количество) КАК Количество
                   |ПОМЕСТИТЬ ДокТч
                   |ИЗ
                   |    Документ.ЗаказПоставщику.Материал КАК ЗаказПоставщикуМатериал
                   |ГДЕ
                   |    ЗаказПоставщикуМатериал.Ссылка = &Ссылка
                   |
                   |СГРУППИРОВАТЬ ПО
                   |    ЗаказПоставщикуМатериал.Номенклатура
                   |;
                   |
                   |////////////////////////////////////////////////////////////////////////////////
                   |ВЫБРАТЬ
                   |    ДокТч.Номенклатура,
                   |    ДокТч.Количество
                   |ИЗ
                   |    ДокТч КАК ДокТч";
                   
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
    РезультатЗапроса = Запрос.Выполнить();
        
    Движения.ОстаткиНоменклатуры.Записывать = Истина;
    
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        Движение = Движения.ОстаткиНоменклатуры.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.Номенклатура = Выборка.Номенклатура;
        Движение.Количество = Выборка.Количество;
    КонецЦикла;
    Движения.Записать();    
 
    Запрос.Текст = "ВЫБРАТЬ
    |   Номенклатура,
    |   КоличествоОстаток КАК Остаток
    |ИЗ
    |   РегистрНакопления.ОстаткиНоменклатуры.Остатки(
    |
    | ,
    |Номенклатура В
    |                       (ВЫБРАТЬ
    |                           ДокТЧ.Номенклатура
    |                       ИЗ
    |                           ДокТЧ КАК ДокТЧ))
    |ГДЕ
    |   КоличествоОстаток < 0";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не хватает товара " + Выборка.Номенклатура + ", после проведения документа остаток составит " + Выборка.Остаток;
            Сообщение.Сообщить(); 
            Отказ = Истина;      
    КонецЦикла;
Не могу найти ошибку
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2016, 11:06
Ответы с готовыми решениями:

Не создается движение документа
Почему у меня не создается движение документа ОказаниеУслуги по 2 регистрам, а тока по одному? Не...

При нажатии на кнопку файл не создается на диске, а он создается только после сворачивания или закрытия окна...
Знакомлюсь с графическим интерфейсом Java Swing. Появилась такая проблема: при нажатии на кнопку...

Если внутри функции создается объект с помощью gcnew, он создается один раз или при каждом вызове?
Обработчик по нажатию кнопки Visual C++ 2010 private: System::Void but1_Click(System::Object^...

Движение планеты в системе двойной звезды или движение трех тел
программа должна выводить координаты движения звезд и планеты в файл (рисую в gnuplot). ...

Возможно ли сделать движение зрачков, реагирующее на движение какого-либо объекта
Вообщем благодаря модеру удалось разукрасить картинку,за что ему спасибо. Нужна анимация для нее....

1
GreenkA
Форумчанин
Эксперт 1С
3004 / 1925 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
16.04.2016, 13:34 2
juristbrn, может не хватает товара и срабатывает этот код?
1C
1
2
3
4
5
6
Пока Выборка.Следующий() Цикл
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не хватает товара " + Выборка.Номенклатура + ", после проведения документа остаток составит " + Выборка.Остаток;
            Сообщение.Сообщить(); 
            Отказ = Истина;     
    КонецЦикла;
Второй вариант: вы обновляли форму записей регистра проведения после проведения? (F5)
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.04.2016, 13:34

Вращательное движение (движение бусины по спице перпендикулярно оси вращения)
В учебниках хорошо рассмотренно движение материальной точки при круговом вращении, однако не...

Сформировать меню: 1) свободное движение объекта 2)движение с клавиатуры
Сформировать на экране меню, состоящее из следующих пунктов: 1. Движение вдоль периметра экрана....

Движение спутника. Движение точки по эллипсу в c++ builder
Здравствуйте, есть код программы, который строит движение точки по эллипсу. Для этого...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.