Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
Starnics
0 / 0 / 0
Регистрация: 03.05.2016
Сообщений: 2
1

Поиск символа в строке

03.05.2016, 13:18. Просмотров 609. Ответов 4
Метки нет (Все метки)

Подскажите пожалуйста есть задача строка "араоролвоарла" ( например) задача : программа должна вывести номер строки "а" не общее количество символов "а",а именно , номер порядка расположения символа "а" во всей строке.( 1,3,10,13 ) в строке.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.05.2016, 13:18
Ответы с готовыми решениями:

Поиск символа в строке
Передо мной стояла задача определить на каком языке текст, Сделал следующим образом в цикле...

Поиск символов в строке
Всем привет. имеются строки вида: 1. 72-574 L3,0 ШАЙБА РЕГУЛИРОВОЧНАЯ 2. 800.00.1925.0287...

Операции в строке: поиск, замена, удаление символа в строке
Доброго здравия! В ассемблере совсем новичок, поэтому прошу помощи. Программа должна получать...

Поиск символа в строке. Как осуществить поиск в обратном направлении
Всем доброго времени суток. Вопрос такой: как осуществить поиск в обратном направлении, т.е. я в...

Поиск символа в строке
Здравствуйте. Мне необходимо проверить выделенный фрагмент текста на наличие в конце точки. Если...

4
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
03.05.2016, 13:31 2
Starnics,
1C
1
2
3
4
5
6
7
СтрокаПоиска ="арлпвыооа";
СимволПоиска ="а";
Пока Найти(СтрокаПоиска, СимволПоиска) >0 Цикл
 Позиция = Найти(СтрокаПоиска,СимволПоиска); 
 Сообщить(Позиция);
 СтрокаПоиска = Сред(СтрокаПоиска,Позиция+1);
КонецЦикла;
1
Starnics
0 / 0 / 0
Регистрация: 03.05.2016
Сообщений: 2
03.05.2016, 13:34  [ТС] 3
Большое спасибо!!
0
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
03.05.2016, 13:53 4
Starnics, вообще лучше при отсекании строки прибавлять к позиции не единицу, а длину подстроки поиска:
1C
1
2
3
4
5
6
7
СтрокаПоиска ="арлпвыооа";
СимволПоиска ="а";
Пока Найти(СтрокаПоиска, СимволПоиска) >0 Цикл
 Позиция = Найти(СтрокаПоиска,СимволПоиска); 
 Сообщить(Позиция);
 СтрокаПоиска = Сред(СтрокаПоиска,Позиция+СтрДлина(СимволПоиска));
КонецЦикла;
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
04.05.2016, 16:09 5
Есть еще вариант с регулярными выражениями. Посложней конечно, но мне например больше нравится
1C
1
2
3
4
5
6
7
8
9
10
RegExp = Новый COMОбъект("VBScript.RegExp"); 
    RegExp.Pattern = "а"; 
    RegExp.Global = Истина; 
    ИсходнаяСтрока = "араоролвоарла"; 
    Matches = RegExp.Execute(ИсходнаяСтрока); 
    Для Счетчик = 0 По Matches.Count - 1 Цикл 
        Match = Matches.Item(Счетчик); 
        Результат = Match.FirstIndex; 
        Сообщить(Результат);
    КонецЦикла;
0
04.05.2016, 16:09
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.05.2016, 16:09

Поиск символа в строке
Предположим я беру строчку вот так: Memo1->Lines->Strings; Как сделать поиск по этой строке, и...

Поиск символа в строке
Доброго времени суток, форумчане. Подскажите как сделать примерно такой алгоритм: Нужно выполнить...

Поиск символа в строке
Программа принимает аргумент из командной строки и выводит его на экран. Перед тем как положить на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.