Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
danya24rus
2 / 2 / 0
Регистрация: 18.01.2013
Сообщений: 81
1

Проверка на уникальность реквизита при вводе в форме.

04.05.2016, 13:10. Просмотров 1127. Ответов 2
Метки нет (Все метки)

Здравствуйте. Есть справочник "Рабочие места" в который помимо остального входит реквизит "ИПАдрес". Вопрос такой: Как при вводе в форме IP адреса сделать проверку на уникальность и выдать ошибку, если введенный номер не уникальный?

Добавлено через 3 часа 43 минуты
//upd

Добавлено через 1 час 20 минут
Можно сделать по-другому. Вот я сделал справочник "ИПАдрес1" в нем хранятся ип адреса, причем хранятся в Коде, повторяться они не могут. Но как теперь сделать так, чтобы при использовании в справочнике "РабочиеМеста" ИПАдрес использовался единожды? То есть если мы его уже использовали, то в другой записи мы его использовать уже не можем, пока не удалим из того места, где мы использовали.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.05.2016, 13:10
Ответы с готовыми решениями:

Проверка реквизита при проведении документа
Добрый день. Есть документ заявка на патент, в документе есть реквизит ключевые слова. Нужно...

Сохранение полученного кода в базе данных и каждый раз при вводе проверять его на уникальность
Вообщем я сейчас делаю сайт. Мне надо подключить оплату. Оплата у меня через активационные коды....

VB Проверка на уникальность, при добавлении новой записи
Всех приветствую. Столкнулся с небольшой проблемой проверки на уникальность (поле "Номер" ) при...

Проверка на уникальность значения при редактировании (access+delphi)
Создать новую запись с проверкой разобрался, а как отредактировать. Добавляю так: begin ...

Проверка на уникальность поля, при добавлении новой записи
Помогите, плиз. Есть форма добавления записей в таблицу. Есть некое уникальное поле, при...

2
Yanush
162 / 158 / 62
Регистрация: 28.09.2013
Сообщений: 293
Завершенные тесты: 1
04.05.2016, 20:25 2
В синтаксисе 7-ки не секу, поэтому на словах простой вариант.
Нужно:
1. Организовать ввод адреса таким образом, чтобы исключить всевозможные непонятные записи - т.е. строго по форме и без лишнего мусора.
2. Построить запрос к этому справочнику, где искать адрес равный введенному (что-то наподобии "выбрать ИПАдрес из справочник где ИПАдрес = &ВведенныйАдрес"). Если в результате выполнения запроса будет пусто то запись уникальна (ну а 1 пункт обеспечит гарантию точной проверки).
1
danya24rus
2 / 2 / 0
Регистрация: 18.01.2013
Сообщений: 81
10.05.2016, 06:21  [ТС] 3
Yanush, В общем сделал так, не знаю на сколько верно, но в результате достиг того, чего хотел. Действовал только по пункту №2, 1ый сильно не требуется, если напишу - сюда выложу.
В общем в справочнике в файле "РабочиеМестаЭлемент" пишем функцию:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Функция мПроверитьУникальностьИПАдреса()
    лСпрРабочиеМеста = СоздатьОбъект("Справочник.РабочиеМеста");
    Если лСпрРабочиеМеста.НайтиПоРеквизиту("ИПАдрес1", ИПАдрес1, 1) = 1 Тогда
        Если лСпрРабочиеМеста.ТекущийЭлемент() <> ТекущийЭлемент() Тогда
            лСотрудник = лСпрРабочиеМеста.Сотрудник.Получить(ТекущаяДата());
            Если ПустоеЗначение(лСотрудник) = 0 Тогда
                лСотрудник = " (" + лСотрудник + ")";
            КонецЕсли;
            Предупреждение("Ошибка: IP Адрес: " + ИПАдрес1 + " - уже используется на рабочем месте " 
                + лСпрРабочиеМеста.Наименование + лСотрудник + "
                |Либо отключите проверку уникальности по IP адресу, либо введите другой IP Адрес", 20);
            Возврат 0;
        КонецЕсли;
    КонецЕсли;
    Возврат 1;
КонецФункции // мПроверитьУникальностьИПАдреса
И в процедуру ПриЗаписи добавляем
1C
1
2
3
4
5
6
7
Если  (ПустоеЗначение(ИПАдрес1) = 0)
Тогда
        Если мПроверитьУникальностьИПАдреса() = 0 Тогда
            СтатусВозврата(0);
            Возврат;
        КонецЕсли;
    КонецЕсли;
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.05.2016, 06:21

Проверка чисел при вводе
Здравсвуйте. Помогите пожалуйста с кодом. Нужно с клавиатур вводить числа в масив, их надо...

Предварительная проверка при вводе
Ввод информации производится вот в такую форму: &lt;form method=&quot;POST&quot; action=&quot;w-6.php&quot;&gt; &lt;input...

Проверка кода и советы по его улучшению. Генерация случайных чисел и проверка на уникальность
Привет народ! Занимаюсь изучением Java, захотелось реализовать выборку случайных чисел для лотереи....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.