Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Lidia83
0 / 0 / 0
Регистрация: 28.06.2015
Сообщений: 9
1

Сеть розничной торговли

08.05.2016, 15:05. Просмотров 404. Ответов 1
Метки нет (Все метки)

У меня диплом "Сеть розничной торговли" в 1С. Продуктовый. Такой вопрос. Есть справочник филиалы. В каждом документе (приходная накладная, продажи) указывать реквизит филиал или это можно организовать, чтобы при входе сразу выбрать филиал, и потом только с документами этого филиала работать?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.05.2016, 15:05
Ответы с готовыми решениями:

Автоматизация розничной торговли
Помогите пожалуйста! Мне предлагают участие в проекте по автоматизации розничного магазина,...

Найти процент отклонения розничной цены от закупочной
Как правильно найти процент отклонения розниичной цены закупочной? Часть из запроса, как пытался...

Автоматизация торговли на 1с
Доброго времени суток. Недавно начал заниматься автоматизацией торговли на прогах 1с, Штрих-М....

Управление торговли переход с 8.1 на 8.2
Релиз управление торговли 8.1 - 10,3,13,2, 8.2 – 11.0.5.4. В ПФХ управление торговли версии 8.1...

Разделение базы "Торговли и Склад"
Добрый день. Есть необходимость разделить одну dbf базу Торговли и склада на две по фирмам...

1
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
08.05.2016, 17:22 2
Lidia83, как вариант:
Можно создать справочник "Пользователи", там реквизит - "Филиал"(тип СправочникСсылка.Филиалы). Заполнить справочник "Пользователи" одноименными элементами с пользователями БД.
Далее создать "Параметр сеанса" - "ТекущийПользователь"(тип СправочникСсылка.Пользователи).
В модуле сеанса прописать:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Процедура УстановкаПараметровСеанса()
    ИмяПользователя = ИмяПользователя();    
    Если ПустаяСтрока(ИмяПользователя) Тогда
        // пользователь не авторизовался
        ИмяПользователя = "НеАвторизован";      
    КонецЕсли;  
    
    ТекущийПользователь = Справочники.Пользователи.ПустаяСсылка();
    Если НЕ ПустаяСтрока(ИмяПользователя) Тогда
        ТекущийПользователь = Справочники.Пользователи.НайтиПоКоду(ИмяПользователя);
    КонецЕсли;      
    ПараметрыСеанса.ТекущийПользователь = ТекущийПользователь;  
КонецПроцедуры // УстановкаПараметровСеанса
И далее уже для каждой формы списка документа можно задать отбор по значению - "ПараметрыСеанса.ТекущийПользователь.Филиал". При создании нового документа можно "Филиал" также автоматом заполнять из этих данных.

Таким образом: вы задаете филиал для конкретного пользователя и все
1
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.05.2016, 17:22

Организовать Учет Торговли Комиссионных Товаров
Задача: организовать учет торговли комиссионным товаром. Используемые счета бух. учета: Счет 10 -...

Разработать конфигурацию с "нуля". Компания занимается розничной торговлей
Приветствую. Ребята, устраиваюсь на работу программистом 1С, и для этого прислали вот такую...

Проверка данных из XML файла при переносе информации из торговли в бухгалтерию
Добрый день. Такая проблема возникла - с помощью обработчика мы выполняем выгрузку данных из...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.