Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
onlyko
0 / 0 / 0
Регистрация: 27.08.2015
Сообщений: 5
1

Обработка формы списка регистра сведений и заполнение значений в документ

08.05.2016, 17:19. Просмотров 910. Ответов 0
Метки нет (Все метки)

Здравствуйте! Столкнулась с такой проблемой: имеется документ "Запись на занятия" с реквизитами: дата, время, клиент, стиль, тренер. При нажатии кнопки открывается форма списка с отбором регистра сведений "Расписание занятий" с аналогичными реквизитами. При выборе строки из регистра необходимо заполнение ее значения в документ. Однако у меня не работает, в обработку выбора не заходит. Реализовываю следующим образом.

В форме документа
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте 
Процедура ВыбратьРасписание(Команда)
     Отбор = Новый Структура("Дата", Объект.ДатаЗанятия);
     ПараметрыФормы = Новый Структура;
     ПараметрыФормы.Вставить("РежимВыбора", Истина);
     ПараметрыФормы.Вставить("Отбор", Отбор);
     ОткрытьФормуМодально("РегистрСведений.РасписаниеЗанятий.ФормаСписка", ПараметрыФормы, ЭтаФорма);    
        
КонецПроцедуры
 
 
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    
    ДанныеСтроки=Новый Структура("Тренер, Стиль, Время");
    ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВыбранноеЗначение);
    ЗаполнитьЗначенияСвойств(Объект, ДанныеСтроки);
    Модифицированность=Истина;
 
КонецПроцедуры
В форме списка регистра сведений
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаКлиенте 
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
    Стр=Элементы.Список.ТекущиеДанные;
    
    СтандартнаяОбработка = Ложь;
    СтруктураРезультат=Новый Структура;
    СтруктураРезультат.Вставить("Тренер", Стр.Тренер);
    СтруктураРезультат.Вставить("Стиль", Стр.Стиль);
    СтруктураРезультат.Вставить("ВремяНачала", Стр.ВремяНачала);
    ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);
    ОповеститьОВыборе(СтруктураРезультат);
    
КонецПроцедуры
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.05.2016, 17:19
Ответы с готовыми решениями:

Сортитровка Формы списка регистра сведений
Здравствуйте. Управляемые формы. Регистр сведений. Возможно ли отсортировать в ФормеСписок по...

Заполнение регистра сведений
Добрый день. Есть документ "Поступление материалов", информация с которого должна автоматически...

Форму списка Заказов разбить на 4-ре списка по данным из регистра сведений (8.2, обычные формы)
Доброго времени суток, Форумчане! после решения данной задачи я сильно нагрузил систему, лагать...

вывод количества рабочих часов из регистра сведений в документ
помогите пожалуйста, очень надо как в регистре сведений График работы подсчитать сумму колонки...

Как вытащить Цену из Регистра сведений в документ Реализация Товара
Пишу: Процедура ТоварыНоменклатураПриИзменении(Элемент) ЦенаОтбор = Новый Структура;...

0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.05.2016, 17:19

Подстановка цены в документ из регистра сведений через табличную модель
Пытаюсь получить из регистра цену на выбираемый в табличной части товар по текущему контрагенту....

Заполнение реквизита справочника из регистра сведений
Есть справочник номенклатура с реквизитом штрихкод и есть регистр сведений (измерение штрихкод,...

Автоматическое заполнение документа из регистра сведений
Здравствуйте. Проблема с заполнением документа. В нем много полей в ТЧ, но по заданию в ручную...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.