Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
Mavrick
0 / 0 / 0
Регистрация: 26.11.2013
Сообщений: 69
1

Открытие формы бизнес-процесса из формы списка

10.05.2016, 17:59. Просмотров 1415. Ответов 3
Метки нет (Все метки)

Имеется форма списка задачи (скрин ниже), как сделать, чтобы при двойном клике открывалась форма объекта текущего бизнес-процесса? Пытался вот так:
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура СписокЗадачиВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    СсылкаНаЭлементСправочника = Элементы.СписокЗадачи.ТекущаяСтрока;   
    ПараметрыФормы = Новый Структура("Ключ", СсылкаНаЭлементСправочника);
    ОткрытьФорму("БизнесПроцесс.РегистрацияПодписки.Форма.ФормаБизнесПроцессаОсновная",ПараметрыФормы);
    
КонецПроцедуры
0
Миниатюры
Открытие формы бизнес-процесса из формы списка  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.05.2016, 17:59
Ответы с готовыми решениями:

Открытие формы документа с заполнением данных из формы справочника
Здравствуйте! Платформа 1с 8.3, пытаюсь создать базу пациентов.)) Есть Справочник с формой...

Форму списка Заказов разбить на 4-ре списка по данным из регистра сведений (8.2, обычные формы)
Доброго времени суток, Форумчане! после решения данной задачи я сильно нагрузил систему, лагать...

Открытие формы документа программно
Делаю так Форма = ОткрытьФорму("Документ.ПриемНаряд.Форма.ФормаДокумента"); НовыйОбъект =...

7.7 Открытие формы отчета с параметрами
Добрый день! Подскажите, пожалуйста, как определить, какое значение передается в "Форма.Параметр"?...

Открытие формы документа по ответу
Доброго времени. Столкнулся с такой задачей : необходимо открыть некий документ если на вопрос в...

3
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
10.05.2016, 18:06 2
Mavrick, можно через
1C
1
    ОткрытьЗначение(ВыбраннаяСтрока.БизнезПроцесс);
1
Mavrick
0 / 0 / 0
Регистрация: 26.11.2013
Сообщений: 69
10.05.2016, 18:26  [ТС] 3
GreenkA, Поле объекта не обнаружено БизнесПроцесс. Может обработчик события не тот?

Добавлено через 7 минут
Помогло так:
1C
1
ОткрытьЗначение(Элемент.ТекущиеДанные.БизнесПроцесс);
0
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
10.05.2016, 18:29 4
Mavrick, надо на сервере получать:
1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ТекБизнесПроцесс = ПолучитьБизнесПроцессСервер(ВыбраннаяСтрока);
    ОткрытьЗначение(ТекБизнесПроцесс);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьБизнесПроцессСервер(Задача)
    Возврат Задача.БизнесПроцесс;
КонецФункции
0
10.05.2016, 18:29
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.05.2016, 18:29

Открытие нескольких экземпляров одной формы
Необходимо на основании счета-заказа открыть несколько форм наряда одного типа. Возможно ли это в...

Открытие формы перед печатью документа
Нужно перед печатью документа (Картинка 1) открывать формочку (Картинка 2). Форма хранится в...

Открытие формы выбранного документа на редактирование
Здравствуйте. В собственной конфигурации есть документ "НазначенияСотрудникам", отражающие работы...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.