Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
1

Поиск в ексель

12.05.2016, 14:35. Просмотров 1227. Ответов 14
Метки нет (Все метки)

Добрый день! Встала такая задача, есть два файл xls назовем их файл1 и файл2 с колонками Наименование и Сумма. Нужно найти одинаковые наименования в файлах, при нахождении подставить данные с файл1 в файл2. Я решил выгрузить данные с файла1 в Таблицу значения, потом поиском найти одинаковые наименования в файл2 и вставить Сумму.
Вот у меня встала проблема как в файле2 найти одинаковое наименование и вставить сумму.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка"),"Наименование");
    ТЗ.Колонки.Добавить("Сумма",Новый ОписаниеТипов("Число"),"Сумма");
    
  Если ПустаяСтрока(ИмяФайла) Тогда
    Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
    Возврат;
  КонецЕсли;
 
  Попытка
    // Загрузка Microsoft Excel
    Состояние("Загрузка Microsoft Excel...");
    ExcelПриложение = Новый COMОбъект("Excel.Application");
  Исключение
    Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    Возврат;
  КонецПопытки;
 
  Попытка
    // Открытие файла Microsoft Excel
    Состояние("Открытие файла Microsoft Excel...");
    ExcelФайл = ExcelПриложение.WorkBooks.Open(ИмяФайла);
  Исключение
    Сообщить("Ошибка открытия файла Microsoft Excel." + ИмяФайла + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
  КонецПопытки;
 
  Попытка
    // Обработка файла Microsoft Excel
    Состояние("Обработка файла Microsoft Excel...");
    // Читаем данные первого листа книги
    ExcelЛист = ExcelФайл.Sheets(1);
 
    // Определить количество строк и колонок выбранного листа книги Excel
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
 
  Исключение
    Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    // Закрыть COM соединение для экономии памяти
    ExcelПриложение.Quit();
КонецПопытки;
 
// Последовательное чтение строк с выбранного листа
  Для Строка = 11 По ExcelПоследняяСтрока Цикл
 
    // Обработка нажатия Ctrl + Break
    ОбработкаПрерыванияПользователя();
 
    // Добавить данные в табличную часть экранной формы
    Стр=ТЗ.Добавить();
    Попытка
      Стр.Наименование = ExcelЛист.Cells(Строка, 1).Value;
      Стр.Сумма = ExcelЛист.Cells(Строка, 6).Value;
 
    Исключение
      // Не редко происходит ошибка конвертации отдельной ячейки документа
      Сообщить("Ошибка чтения строки файла Microsoft Excel." + Строка + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    КонецПопытки;
    // Отобразить информацию о ходе выполнения обработки
    Состояние("Обработка файла Microsoft Excel : "
      + "строка " + Строка + " из " + ExcelПоследняяСтрока);
 
  КонецЦикла;
 
  // Закрыть COM соединение для экономии памяти
  ExcelПриложение.Quit();
  
  Для Каждого ЭлементТЗ из ТЗ Цикл
      
      Наименование1С = ЭлементТЗ.Наименование;
      
  КонецЦикла;
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.05.2016, 14:35
Ответы с готовыми решениями:

конфликт 1с-ексель
Обработка формирует в 1с (dbf-база) файл, сохраняет его в формате xls, потом открывает в екселе и...

Макет ActiveDocument Ексель
Доброго времени суток Уважаемы форумчане нужна ваща помощь в решении следующего вопроса Создал...

Выгрузка текста в ексель
Ребят я вот создал кнопку, на ней код который открывает ексель... //...

Печатная форма в ексель
Такая проблема, при "Сохранить Как..." в формате ячейки екселя дата не записывается в ексель...

закрыть документ ексель
Такая проблема, отчета открывает документ эксель делает в нем кое-какие изменения, как при выходе...

14
Insoulrock
1 / 1 / 0
Регистрация: 12.05.2016
Сообщений: 6
12.05.2016, 15:12 2
Первый считал в таблицу, открывай второй файл и построчно пробегайся по нему, ища такое наименование в таблице через "НайтиСтроки".
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 15:17  [ТС] 3
Insoulrock, Вот как пробежать в файле по строкам? Вот я его открыл как дальше?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка"),"Наименование");
    ТЗ.Колонки.Добавить("Сумма",Новый ОписаниеТипов("Число"),"Сумма");
    
  Если ПустаяСтрока(ИмяФайла) Тогда
    Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
    Возврат;
  КонецЕсли;
 
  Попытка
    // Загрузка Microsoft Excel
    Состояние("Загрузка Microsoft Excel...");
    ExcelПриложение = Новый COMОбъект("Excel.Application");
  Исключение
    Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    Возврат;
  КонецПопытки;
 
  Попытка
    // Открытие файла Microsoft Excel
    Состояние("Открытие файла Microsoft Excel...");
    ExcelФайл = ExcelПриложение.WorkBooks.Open(ИмяФайла);
  Исключение
    Сообщить("Ошибка открытия файла Microsoft Excel." + ИмяФайла + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
  КонецПопытки;
 
  Попытка
    // Обработка файла Microsoft Excel
    Состояние("Обработка файла Microsoft Excel...");
    // Читаем данные первого листа книги
    ExcelЛист = ExcelФайл.Sheets(1);
 
    // Определить количество строк и колонок выбранного листа книги Excel
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
 
  Исключение
    Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    // Закрыть COM соединение для экономии памяти
    ExcelПриложение.Quit();
КонецПопытки;
 
// Последовательное чтение строк с выбранного листа
  Для Строка = 11 По ExcelПоследняяСтрока Цикл
 
    // Обработка нажатия Ctrl + Break
    ОбработкаПрерыванияПользователя();
 
    // Добавить данные в табличную часть экранной формы
    Стр=ТЗ.Добавить();
    Попытка
      Стр.Наименование = ExcelЛист.Cells(Строка, 1).Value;
      Стр.Сумма = ExcelЛист.Cells(Строка, 6).Value;
 
    Исключение
      // Не редко происходит ошибка конвертации отдельной ячейки документа
      Сообщить("Ошибка чтения строки файла Microsoft Excel." + Строка + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    КонецПопытки;
    // Отобразить информацию о ходе выполнения обработки
    Состояние("Обработка файла Microsoft Excel : "
      + "строка " + Строка + " из " + ExcelПоследняяСтрока);
 
  КонецЦикла;
 
  // Закрыть COM соединение для экономии памяти
  ExcelПриложение.Quit();
  
  
    Если ПустаяСтрока(Файл) Тогда
    Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
    Возврат;
  КонецЕсли;
 
  Попытка
    // Загрузка Microsoft Excel
    Состояние("Загрузка Microsoft Excel...");
    ДокExcel = Новый COMОбъект("Excel.Application");
  Исключение
    Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    Возврат;
  КонецПопытки;
 
  Попытка
    // Открытие файла Microsoft Excel
    Состояние("Открытие файла Microsoft Excel...");
    РабочаяКнига  = ДокExcel.WorkBooks.Open(Файл);
  Исключение
    Сообщить("Ошибка открытия файла Microsoft Excel." + Файл + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
КонецПопытки;
 
 Попытка
    // Обработка файла Microsoft Excel
    Состояние("Обработка файла Microsoft Excel...");
    // Читаем данные первого листа книги
    ЛистДок = ДокExcel.Sheets(1);
 
    // Определить количество строк и колонок выбранного листа книги Excel
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ЛистДок.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ЛистДок.Cells.SpecialCells(xlCellTypeLastCell).Column;
 
  Исключение
    Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    // Закрыть COM соединение для экономии памяти
    ДокExcel.Quit();
КонецПопытки;
 
// Последовательное чтение строк с выбранного листа
  Для Строка = 14 По ExcelПоследняяСтрока Цикл
 
    // Обработка нажатия Ctrl + Break
    ОбработкаПрерыванияПользователя();
 
    // Добавить данные в табличную часть экранной формы
    Попытка
      Наименование = ЛистДок.Cells(Строка, 9).Value;
 
    Исключение
      // Не редко происходит ошибка конвертации отдельной ячейки документа
      Сообщить("Ошибка чтения строки файла Microsoft Excel." + Строка + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    КонецПопытки;
    // Отобразить информацию о ходе выполнения обработки
    Состояние("Обработка файла Microsoft Excel : "
      + "строка " + Строка + " из " + ExcelПоследняяСтрока);
      
      Для Каждого СтрокаТЗ из ТЗ Цикл
          //ЧТО ТУТ???
    КонецЦикла;   
 
  КонецЦикла;
 
  // Закрыть COM соединение для экономии памяти
  ДокExcel.Quit();
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 15:23 4
Лучший ответ Сообщение было отмечено Ermak27 как решение

Решение

Думаю что вместо
1C
1
2
3
 Для Каждого СтрокаТЗ из ТЗ Цикл
          //ЧТО ТУТ???
    КонецЦикла;
Нужно добавить
1C
1
2
3
4
5
6
7
8
9
Для Строка = 11 По ExcelПоследняяСтрока Цикл
        Отбор = Новый Структура;
        Отбор.Вставить("Наименование", ExcelЛист.Cells(Строка, 1).Value); 
        НайденнаяСтрока = ТЗ.НайтиСтроки(Отбор);
        Если НайденнаяСтрока.Количество() > 0 Тогда
            ExcelЛист.Cells(Строка, 6).Value =  НайденнаяСтрока.Сумма;
        КонецЕсли;
        
    КонецЦикла;
1
12.05.2016, 15:23
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 15:31  [ТС] 5
SpiRUS, сделал так

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
// Последовательное чтение строк с выбранного листа
  Для Строка = 14 По ExcelПоследняяСтрока Цикл
        Отбор = Новый Структура;
        Отбор.Вставить("Наименование", ЛистДок.Cells(Строка, 9).Value); 
        НайденнаяСтрока = ТЗ.НайтиСтроки(Отбор);
        Если НайденнаяСтрока.Количество() > 0 Тогда
            Для Каждого СтрокаТЗ из ТЗ Цикл
            ЛистДок.Cells(Строка, 16).Value =  СтрокаТЗ.Сумма;
            КонецЦикла;
        КонецЕсли;  
  КонецЦикла;
 
  // Закрыть COM соединение для экономии памяти
  ДокExcel.Quit();
не записывает в файл

Добавлено через 32 секунды
и не закрывает файл, приходится через диспетчер задач закрывать
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 15:41 6
Ermak27, Если не ошибаюсь сохранить эксель файл
1C
1
ДокExcel.SaveAs(Путь);
А закрывать вроде нужно книгу, а не ком объект
1
Insoulrock
1 / 1 / 0
Регистрация: 12.05.2016
Сообщений: 6
12.05.2016, 15:45 7
Ага, еще вот это прикрути. Чтоб без вопросов.
Workbooks.Application.DisplayAlerts = Ложь;
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 15:58  [ТС] 8
SpiRUS, Почему то СтрокаТЗ.Сумма попадает самая последняя в ТЗ а должна попадать которая по Наименованию. Например если Наименование "Картошка" Сумма "100" тогда и должна быть сумма "100"

Добавлено через 29 секунд
Insoulrock, это в самый конец? и что это обозначает?
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 16:05 9
Ermak27, так а зачем тут этот цикл
1C
1
2
3
Для Каждого СтрокаТЗ из ТЗ Цикл
            ЛистДок.Cells(Строка, 16).Value =  СтрокаТЗ.Сумма;
            КонецЦикла;
убрать его и все должно работать
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 16:08  [ТС] 10
SpiRUS, это цикл чтобы брать значение с ТЗ и подставлять его. А как вы предлагаете?
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 16:11 11
Ermak27,
1C
1
2
3
   Отбор = Новый Структура;
        Отбор.Вставить("Наименование", ЛистДок.Cells(Строка, 9).Value); 
        НайденнаяСтрока = ТЗ.НайтиСтроки(Отбор);
Отбор и находит вам вашу картошку.
Получается что для каждой строки Екселя мы находим значение в ТЗ. И если мы его находим то с помощью строчки
1C
1
ExcelЛист.Cells(Строка, 6).Value =  НайденнаяСтрока.Сумма;
мы подставляем сумму найденной строки ТЗ
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 16:13  [ТС] 12
SpiRUS, В том то и дело что он нечего не подставляет почему то, вот весь код

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка"),"Наименование");
    ТЗ.Колонки.Добавить("Сумма",Новый ОписаниеТипов("Число"),"Сумма");
    
  Если ПустаяСтрока(ИмяФайла) Тогда
    Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
    Возврат;
  КонецЕсли;
 
  Попытка
    // Загрузка Microsoft Excel
    Состояние("Загрузка Microsoft Excel...");
    ExcelПриложение = Новый COMОбъект("Excel.Application");
  Исключение
    Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    Возврат;
  КонецПопытки;
 
  Попытка
    // Открытие файла Microsoft Excel
    Состояние("Открытие файла Microsoft Excel...");
    ExcelФайл = ExcelПриложение.WorkBooks.Open(ИмяФайла);
  Исключение
    Сообщить("Ошибка открытия файла Microsoft Excel." + ИмяФайла + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
  КонецПопытки;
 
  Попытка
    // Обработка файла Microsoft Excel
    Состояние("Обработка файла Microsoft Excel...");
    // Читаем данные первого листа книги
    ExcelЛист = ExcelФайл.Sheets(1);
 
    // Определить количество строк и колонок выбранного листа книги Excel
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
 
  Исключение
    Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    // Закрыть COM соединение для экономии памяти
    ExcelПриложение.Quit();
КонецПопытки;
 
// Последовательное чтение строк с выбранного листа
  Для Строка = 11 По ExcelПоследняяСтрока Цикл
 
    // Обработка нажатия Ctrl + Break
    ОбработкаПрерыванияПользователя();
 
    // Добавить данные в табличную часть экранной формы
    Стр=ТЗ.Добавить();
    Попытка
      Стр.Наименование = ExcelЛист.Cells(Строка, 1).Value;
      Стр.Сумма = ExcelЛист.Cells(Строка, 6).Value;
 
    Исключение
      // Не редко происходит ошибка конвертации отдельной ячейки документа
      Сообщить("Ошибка чтения строки файла Microsoft Excel." + Строка + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    КонецПопытки;
    // Отобразить информацию о ходе выполнения обработки
    Состояние("Обработка файла Microsoft Excel : "
      + "строка " + Строка + " из " + ExcelПоследняяСтрока);
 
  КонецЦикла;
 
  // Закрыть COM соединение для экономии памяти
  ExcelПриложение.Quit();
  
  
    Если ПустаяСтрока(Файл) Тогда
    Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
    Возврат;
  КонецЕсли;
 
  Попытка
    // Загрузка Microsoft Excel
    Состояние("Загрузка Microsoft Excel...");
    ДокExcel = Новый COMОбъект("Excel.Application");
  Исключение
    Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    Возврат;
  КонецПопытки;
 
  Попытка
    // Открытие файла Microsoft Excel
    Состояние("Открытие файла Microsoft Excel...");
    РабочаяКнига  = ДокExcel.WorkBooks.Open(Файл);
  Исключение
    Сообщить("Ошибка открытия файла Microsoft Excel." + Файл + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
КонецПопытки;
 
 Попытка
    // Обработка файла Microsoft Excel
    Состояние("Обработка файла Microsoft Excel...");
    // Читаем данные первого листа книги
    ЛистДок = ДокExcel.Sheets(1);
 
    // Определить количество строк и колонок выбранного листа книги Excel
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ЛистДок.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ЛистДок.Cells.SpecialCells(xlCellTypeLastCell).Column;
 
  Исключение
    Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    // Закрыть COM соединение для экономии памяти
    ДокExcel.Quit();
КонецПопытки;
 
// Последовательное чтение строк с выбранного листа
  Для Строка = 14 По ExcelПоследняяСтрока Цикл
        Отбор = Новый Структура;
        Отбор.Вставить("Наименование", ЛистДок.Cells(Строка, 9).Value); 
        НайденнаяСтрока = ТЗ.НайтиСтроки(Отбор);
        Если НайденнаяСтрока.Количество() > 0 Тогда
            //Для Каждого СтрокаТЗ из ТЗ Цикл
            //ЛистДок.Cells(Строка, 16).Value =  СтрокаТЗ.Сумма;
            //КонецЦикла;
            ЛистДок.Cells(Строка, 16).Value =  НайденнаяСтрока.Сумма;
        КонецЕсли;  
    КонецЦикла;
    РабочаяКнига.SaveAs(Файл);
   ДокExcel.WorkBooks.Close();
  // Закрыть COM соединение для экономии памяти
  ДокExcel.Workbooks.Application.DisplayAlerts = Ложь;
  ДокExcel.Quit();
Добавлено через 1 минуту
и почему он постоянно спрашивает сохранять да или нет или отмена
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 16:20 13
Лучший ответ Сообщение было отмечено Ermak27 как решение

Решение

1C
1
2
3
4
5
6
7
8
Если НайденнаяСтрока.Количество() > 0 Тогда
        //Для Каждого СтрокаТЗ из ТЗ Цикл
        //ЛистДок.Cells(Строка, 16).Value =  СтрокаТЗ.Сумма;
        //КонецЦикла;
        Для каждого СтрокаТЗ Из НайденныеСтроки Цикл
            ЛистДок.Cells(Строка, 16).Value =  СтрокаТЗ.Сумма;
        КонецЦикла;
    КонецЕсли;
А картошка только раз может встречаться в первом ексель файле?
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,215
12.05.2016, 16:33  [ТС] 14
SpiRUS, да, только один раз и в первом и во втором файле

Добавлено через 2 минуты
SpiRUS, Все большое спасибо!
У меня есть группировка третьего уровня, а можете подсказать как искать только в этой группе?
0
SpiRUS
10 / 10 / 5
Регистрация: 23.06.2015
Сообщений: 74
12.05.2016, 19:00 15
Цитата Сообщение от Ermak27 Посмотреть сообщение
У меня есть группировка третьего уровня, а можете подсказать как искать только в этой группе?
А поподробнее?
0
12.05.2016, 19:00
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.05.2016, 19:00

Сохранение печатной формы в Ексель
Доброго времени суток. Помогите пожалуйста разобраться с проблемкой. При сохранении печатной формы...

Загрузка с Ексель в Таблицу значений
Добрый день всем Подскажите как загрузить данные из ексель в таблицу значений. Облазил весь инет...

Заполнение из ексель табличной части справочника
Добрый день. Подскажите пожалуйста, как заполнить табличную часть справочника из ексель, если...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.