Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
The_RK
3 / 3 / 2
Регистрация: 07.03.2016
Сообщений: 35
1

Сохранение и отображение внесенных записей в табличную часть документа

15.05.2016, 23:17. Просмотров 844. Ответов 5
Метки нет (Все метки)

Всем доброго времени суток! Нужна ваша помощь в перенесении данных из табличной части одного документа в таб. часть другого(Заказ - > Расходная накладная). Суть ситуации такова: мне необходимо, чтобы при выборе заказа в документе "расходная накладная" заполнялась табличная часть. То есть я должен получить всю необходимую по заказу номенклатуру. Но!!!! Несмотря на, то, что перенос был реализован записи не добавляются(или же банально не сохраняются). Конечно, наиболее вероятно, что я просто не осведомлен о существовании метода позволяющего сохранить внесенные записи.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
&НаКлиенте
Процедура ЗаказПриИзменении(Элемент)
        Заказ = Объект.Заказ;
        ТЧТовары = Объект.Товары;
        [B]ТЧ(Заказ, Объект.Ссылка);[/B]
        ТЧУслуги = Объект.Услуги;
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура ТЧ(Заказ, Объект)
    Запрос = Новый Запрос;
    Запрос.Текст =
     ("ВЫБРАТЬ
      | Заказы.Ссылка,
      | ЗаказыТовары.Ссылка КАК Ссылка1,
      | ЗаказыТовары.НомерСтроки,
      | ЗаказыТовары.Товар,
      | ЗаказыТовары.Цена,
      | ЗаказыТовары.Количество,
      | ЗаказыТовары.Сумма
      |ИЗ
      | Документ.Заказы.Товары КАК ЗаказыТовары
      |     ЛЕВОЕ СОЕДИНЕНИЕ Документ.Заказы КАК Заказы
      |     ПО ЗаказыТовары.Ссылка = Заказы.Ссылка
      |ГДЕ
      | Заказы.Ссылка = &Ссылка");
     
     Запрос.УстановитьПараметр("Ссылка", Заказ);
     
     Результат = Запрос.Выполнить();
     
     ВыборкаЗапроса = Результат.Выбрать();
     
     Пока ВыборкаЗапроса.Следующий() Цикл
          СтрокаТовары = Объект.Товары.Добавить();
          СтрокаТовары.Товар = ВыборкаЗапроса.Товар;
      КонецЦикла;
     
КонецПроцедуры
P.S.: Пока что перенос идет только для товаров(без цены, количества и т.д). "Объект.Записать()" не подойдет, поскольку до записи объекта не существует(поправьте, если ошибаюсь) и поэтому функция принимает ссылку.
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.05.2016, 23:17
Ответы с готовыми решениями:

Заполнить табличную часть одного документа из другого документа
здравствуйте! У меня есть документа оплата заказа, в нём есть табличная часть, которая загружается...

Данные из справочника в табличную часть документа
Здравствуйте. Ситуация следующая: Существует справочник "Маршруты" с реквизитами ПунктЗагрузки и...

Из табличной части справочника в табличную часть документа
1С:8.2! Здраствуйте, имеются объекты: 1) справочник "Продукция" реквизиты:"Наименование"(указаны...

Получение реквизита из справочника в табличную часть документа
Помогите пожалуйста! Как только ни пробовала, не могу понять в чем дело.... Есть справочник...

Получение реквизита из справочника в табличную часть документа
Доброе время суток!Скорее всего мой вопрос очень глупый , но прошу помочь. имеем справочник...

5
SHIFT_969
Злой самаритянин
178 / 179 / 94
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
16.05.2016, 09:57 2
Цитата Сообщение от The_RK Посмотреть сообщение
&НаСервереБезКонтекста
По-моему из-за этого. Попробуй просто &НаСервере.
1
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
16.05.2016, 10:07 3
Цитата Сообщение от The_RK Посмотреть сообщение
Конечно, наиболее вероятно, что я просто не осведомлен о существовании метода позволяющего сохранить внесенные записи.
Цитата Сообщение от The_RK Посмотреть сообщение
P.S.: Пока что перенос идет только для товаров(без цены, количества и т.д). "Объект.Записать()" не подойдет, поскольку до записи объекта не существует(поправьте, если ошибаюсь) и поэтому функция принимает ссылку.
очень интересно... Как же иначе вы хотите сохранять записи?) - Только записью документа...Как иначе?)

Цитата Сообщение от SHIFT_969 Посмотреть сообщение
По-моему из-за этого. Попробуй просто &НаСервере.
при вызове функции в параметрах передается Объект, все должно быть норм. Тем более ТС написал, что записи создаются, но не сохраняются. Видимо, просто закрывает документ без сохранения...

Добавлено через 1 минуту
хотя просмотрела, передается Объект.Ссылка надо передавать просто Объект тогда:
1C
1
2
3
4
5
6
7
&НаКлиенте
Процедура ЗаказПриИзменении(Элемент)
        Заказ = Объект.Заказ;
        ТЧТовары = Объект.Товары;
        ТЧ(Заказ, Объект);
        ТЧУслуги = Объект.Услуги;
КонецПроцедуры
1
The_RK
3 / 3 / 2
Регистрация: 07.03.2016
Сообщений: 35
16.05.2016, 15:38  [ТС] 4
SHIFT_969, Тестировал этот вопрос, видимо, проблема не в директиве компиляции.

GreenkA, Если просто передавать объект, то выдает ошибку: "Нельзя изменять поле, содержащее объект данных формы"..... В общем, буду искать, но тем не менее спасибо за отклик!)
0
SHIFT_969
Злой самаритянин
178 / 179 / 94
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
16.05.2016, 15:56 5
Лучший ответ Сообщение было отмечено The_RK как решение

Решение

The_RK, я вообще не понимаю зачем ты что-то там передаешь. В процедуре &НаСервере работай с Объект -ом, не надо его с клиента тащить. Если у тебя процедура без контекста, то Объект недоступен уже.
1
The_RK
3 / 3 / 2
Регистрация: 07.03.2016
Сообщений: 35
16.05.2016, 16:07  [ТС] 6
SHIFT_969, Дело в том, что я по собственной глупости даже не попытался взять объект на сервере. И сейчас я как раз-таки хотел об этом написать(все заработало), но ты меня опередил). В общем, еще раз спасибо!
0
16.05.2016, 16:07
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.05.2016, 16:07

Получение реквизита из справочника в табличную часть документа
Здравствуйте, полный нуб в 1с. Прошу больно не пинать. Вопрос самый простой и глупый. Есть документ...

Как добавить табличную часть документа в условие отбора?
Всем доброго времени суток! Как добавить табличную часть документа в условие отбора? Есть один...

Автозаполнение из табличной части справочника в табличную часть документа
Здравствуйте , помогите пожалуйста с кодом Мне нужно чтобы автоматически заполнялась табличная...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.