Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/8: Рейтинг темы: голосов - 8, средняя оценка - 4.88
Relorik
0 / 0 / 0
Регистрация: 16.05.2016
Сообщений: 29
1

Из табличной части справочника в табличную часть документа

16.05.2016, 18:29. Просмотров 1620. Ответов 5
Метки нет (Все метки)

1С:8.2! Здраствуйте, имеются объекты:
1) справочник "Продукция" реквизиты:"Наименование"(указаны название продуктов)
2) справочник "Договоры" реквизиты "Название ", а табличная часть имеет название "Заказы" и содержит реквизит табличной части "Продукция" - СправочникСсылка.Продукция
3) Документ "ТТН" содержит реквизит "номер ттн" "НазваниеДоговора"-СправочникСсылка.Договоры, табличную часть "Заказ" и реквизиты табличной части "Продукт".
Суть в том что у нас имеется 20 названий продукции в справочнике "Продукция" . При Создании договора в справочнике "Договоры" мы указав любое название договора в его табличной части выбираем из тех 20 продуктов допустим 5 видов которые будем поставлять производителю. Нужно сделать так, чтобы в документе "ТТН" выбрав реквизит "НазваниеДоговора" в его табличной части "Заказы" в реквизите "Продукция" выпадающим списком были указаны только те продукты которые были указаны в табличной части выбранного договора. Помогите пожалуйста.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.05.2016, 18:29
Ответы с готовыми решениями:

Автозаполнение из табличной части справочника в табличную часть документа
Здравствуйте , помогите пожалуйста с кодом Мне нужно чтобы автоматически...

Данные из справочника в табличную часть документа
Здравствуйте. Ситуация следующая: Существует справочник "Маршруты" с...

Получение реквизита из справочника в табличную часть документа
Помогите пожалуйста! Как только ни пробовала, не могу понять в чем дело.......

Получение реквизита из справочника в табличную часть документа
Здравствуйте, полный нуб в 1с. Прошу больно не пинать. Вопрос самый простой и...

Получение реквизита из справочника в табличную часть документа
Доброе время суток!Скорее всего мой вопрос очень глупый , но прошу помочь....

5
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
16.05.2016, 18:32 2
Relorik, на событие поля Продукция НачалоВыбора() пропишите заполнение ДанныеВыбора нужными значениями.
1
Relorik
0 / 0 / 0
Регистрация: 16.05.2016
Сообщений: 29
16.05.2016, 18:49  [ТС] 3
Большое спасибо))

Добавлено через 12 минут
А вот еще, я сделал так что в табличной части каждый раз приходится выбирать название договора чтобы появился список с нужными продуктами, можно ли реквизит табличной части "название договора- "Договор"" перенести в реквизиты документа и чтобы только 1 раз выбирать название договора и в его табличной части данные так же изменялись как если на каждую запись выбирать название договора?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
&НаКлиенте
Процедура ЗаказПродуктНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ТекСтрока = Элемент.Родитель.ТекущиеДанные;
ДанныеВыбора = ПолучитьСписокНаСервере(ТекСтрока.Договор);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьСписокНаСервере(Договор)
ДанныеВыбора = Новый СписокЗначений;
Запрос = Новый Запрос("ВЫБРАТЬ
                      | Продукт.Продукция КАК Причина
                      |ИЗ
                      | Справочник.Договоры.Заказы КАК Продукт
                      |ГДЕ
                      | Продукт.Ссылка = &Договор");
Запрос.УстановитьПараметр("Договор", Договор);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ДанныеВыбора.Добавить(Выборка.Причина); 
КонецЦикла;
Возврат ДанныеВыбора;
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
16.05.2016, 19:25 4
Relorik, можно. Сделайте договор реквизитом шапки документа, а не табличной части.
1
Relorik
0 / 0 / 0
Регистрация: 16.05.2016
Сообщений: 29
16.05.2016, 19:35  [ТС] 5
Я понимаю, но на нее нужно написать обработчик и вот что в него писать я не знаю
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
16.05.2016, 19:47 6
Relorik, почти то же самое...
1C
1
2
3
4
5
&НаКлиенте
Процедура ЗаказПродуктНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ДанныеВыбора = ПолучитьСписокНаСервере(Объект.Договор);
КонецПроцедуры
1
16.05.2016, 19:47
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.05.2016, 19:47

Автозаполнение полей документа, из табличной части справочника
Здравствуйте, столкнулся со следующей проблемой. Необходимо сделать...

Заполнение табличной части документа данными из справочника
Добрый день! Очень нужна ваша помощь ! Есть справочник Должности (на каждую...

Подставить в поле ввода документа, из справочника табличной части
Приветствую, есть Справочник транспортные компании в котом есть 2 табличные...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru