Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
mikkijon
0 / 0 / 0
Регистрация: 29.08.2014
Сообщений: 158
1

Ошибка в табличной части документа

20.05.2016, 09:13. Просмотров 876. Ответов 2
Метки нет (Все метки)

Приветствую Вас многоуважаемые форумчане
После долгого отсутствия мне наконец-то дали заниматься своим любимым делать ломать голову над написанием очередной конфигурации. Так как сроки поджимают решил обратиться к Вам. Так как я уже не знаю где искать в течении месяца искал так по нормальному ничего не нашел.
Задача состоит в следующем
1)Я создал простую конфигурацию в управляемом приложении.
2) Разделе Документ Заправка маркера есть табличная часть над которой я сейчас и работаю.
3) Поле НаименованиеМаркера - это подстановочное поле. при ее измении я написал следующий код
&НаСервере
Функция ЦветМ (Ссылка)
Результат=Справочники.Маркеры.НайтиПоНаименованию(Ссылка);
Возврат Результат.ЦветМаркера;
КонецФункции

&НаКлиенте
Процедура ЗаправкаНаименованиеМаркераПриИзменении(Элемент)
ТабЧасть=Элементы.Заправка.ТекущиеДанные;
ТабЧасть.ЦветМаркера=ЦветМ(ТабЧасть.НаименованиеМаркера);
КонецПроцедуры


4)Но поле ЦветМаркера, вставляется только первая строка из Справочника Маркеры.
В предыдущей конфигурации которую я также написал, все работает без проблем. Из нее я взял код предварительно пересмотрев все настройки. В этой конфигурации все стояло по умолчанию.
Прошу Вас друзья!!!! Помогите пожалуйста
Также высылаю Вам саму конфигурацию
Заранее благодарю Вас
0
Вложения
Тип файла: rar Ошибка в документе.rar (15.2 Кб, 1 просмотров)
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.05.2016, 09:13
Ответы с готовыми решениями:

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...

Ошибка в запросе при попытке получения значения из Табличной части документа
Необходимо получить предыдущую цену продажи по данному Контрагенту, Дате и номенклатуре. В первом...

Ошибка при расчете суммы текущей строки табличной части в управляемой форме документа
Подскажите что не так ? Почему не срабатывает подсчёт? ...

2
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
20.05.2016, 14:39 2
Лучший ответ Сообщение было отмечено mikkijon как решение

Решение

mikkijon, у вас НаименованиеМаркера - ссылка на справочник Маркеры, не надо в функции искать по наименованию, просто сразу передаем значение цвета назад:
1C
1
2
3
4
5
6
7
8
9
10
11
&НаСервере
Функция ЦветМ (Ссылка)
  //Результат=Справочники.Маркеры.НайтиПоНаименованию(Ссылка);
  Возврат Ссылка.ЦветМаркера;
КонецФункции
 
&НаКлиенте
Процедура ЗаправкаНаименованиеМаркераПриИзменении(Элемент)
    ТабЧасть=Элементы.Заправка.ТекущиеДанные;
    ТабЧасть.ЦветМаркера=ЦветМ(ТабЧасть.НаименованиеМаркера);
КонецПроцедуры
1
mikkijon
0 / 0 / 0
Регистрация: 29.08.2014
Сообщений: 158
20.05.2016, 15:30  [ТС] 3
Огромное Спасибо GreenkA, глубоко признателен Вам
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.05.2016, 15:30

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать. ...

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа "Индивидуальный заказ" и...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru