Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
1

Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого

28.05.2016, 18:09. Просмотров 1384. Ответов 10
Метки нет (Все метки)

Добрый день, очень сильно нужна помощь....

Есть справочник "ВидыУслуг", реквизит "Тариф"

Есть справочник "ЛицевыеСчета", и табличная часть "Услуги" с реквизитом "Тариф"

Как получить значение реквизита "ВидыУслуг" справочника "ЛицевыеСчета" и перенести их в реквизит "Тариф" табличной части "Услуги" другого справочника "ЛицевыеСчета"?

если ссылаться просто на справочник то совсем не то...
через отбор вообще пусто...

Прошу в поиск не посылать, т.к. своими усилиями перепробовала все что только можно... Успехов 0.

платформа 8.2

Буду очень рада любой помощи....
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.05.2016, 18:09
Ответы с готовыми решениями:

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа "Индивидуальный заказ" и...

Как сделать ссылку реквизита табличной части справочника
Я недавний пользователь 1с. И я решил сделать на нём диплом (Библиотека). В процессе возник вопрос...

Данные реквизита из справочника перенести в реквизит документа
Есть справочник Автомобиль и в нем реквизит ГодВыпуска, нужно чтобы в документе при выборе...

Как вывести поле из строки табличной части справочника в реквизит документа?
Есть справочник ФизЛица с таблчной частью образование и документ Учет с реквизитом-образование (не...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

10
alex1248
122 / 66 / 26
Регистрация: 08.03.2016
Сообщений: 173
28.05.2016, 18:32 2
Как-то сложно у вас, скорее всего - не оправданно.
Услуги в ТЧ спр ЛицСчета - разве не элементы спр ВидыУслуг?

Да, и тариф оптимально хранить в РС, периодическом, он же может изменяться, скорее всего.
0
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
28.05.2016, 18:48  [ТС] 3
Услуги в ТЧ спр ЛицСчета - разве не элементы спр ВидыУслуг?
Нет, это разные справочники

Возможно и сложно, по другому к сожалению не вижу...

В любом случае во всех местах упираюсь в эти действия...

Поэтому нужно освоить что куда и как, а дальше уже если что отталкиваться.
0
alex1248
122 / 66 / 26
Регистрация: 08.03.2016
Сообщений: 173
28.05.2016, 18:55 4
Цитата Сообщение от pippipi Посмотреть сообщение
Нет, это разные справочники
Тогда поясните, какая связь между видами услуг и собственно услугами (тем более, что и у тех, и у других есть тариф).
И создайте для услуг новый справочник, оттуда и будете выбирать их в ТЧ справочника ЛицевыеСчета.
0
28.05.2016, 18:55
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
28.05.2016, 19:08  [ТС] 5
Тогда поясните, какая связь между видами услуг и собственно услугами (тем более, что и у тех, и у других есть тариф).
И создайте для услуг новый справочник, оттуда и будете выбирать их в ТЧ справочника ЛицевыеСчета.
Прикрепила скрины. И один из вариантов как перенести... но не правильный.. а ошибку не вижу...((

Просто в дальнейшем эти данные нужны будут, для расчетов, и так же они должны будут отображаться в квитанции. На форме печати.
0
Миниатюры
Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого   Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого   Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого  

alex1248
122 / 66 / 26
Регистрация: 08.03.2016
Сообщений: 173
28.05.2016, 19:18 6
Так не делается. Всё поместили в один справочник.
В общем, вот так:
Справочник Услуги,
Справочник ЛицевыеСчета,
Справочник Клиенты,
РС Тарифы, периодический (наверное, с периодом Месяц),
Документ НачислениеПлатежей.
В документе в шапке ЛицевойСчет (с данными клиента); естественно, дата; а также номер, не несущий особого смысла. В ТЧ список услуг (можно заполнять как вручную, так и организовать автоматическое заполнение при создании документа). Можно также услуги указывать в спр ЛицевыеСчета, а в документ опять же подтягивать автоматически по лицевому счету.
Тариф подтягивается из РС по услуге и дате.
0
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
28.05.2016, 19:29  [ТС] 7
alex1248, попробую конечно переделать. Но у меня же не один справочник, а 15, просто данные подтягиваются. Это разве неверно?

И вопрос так и остается в воздухе...
Может вы ведите ошибку в моем коде?
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура УслугиПриИзменении(Элемент)
  ТекСтрока = Элементы.Услуги.ТекущиеДанные;
  ТекСтрока.Тариф = ПолучитьЗначениеРеквизитаНаСервере(ТекСтрока.Тариф,"Тариф");
КонецПроцедуры
   &НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаНаСервере(ВидыУслуг, Тариф)
  Возврат ВидыУслуг[Тариф];
КонецФункции
0
alex1248
122 / 66 / 26
Регистрация: 08.03.2016
Сообщений: 173
28.05.2016, 19:42 8
Цитата Сообщение от pippipi Посмотреть сообщение
Это разве неверно?
Очень неверно, что вы документ заменили справочником - честно, вообще никуда не годится, не представляю, как, например, вы будете формировать отчеты.

По поводу кода. Не понятно, что вы вообще хотите получить. Вот что вы писали сначала
Цитата Сообщение от pippipi Посмотреть сообщение
значение реквизита "ВидыУслуг" справочника "ЛицевыеСчета" и перенести их в реквизит "Тариф" табличной части "Услуги" другого справочника "ЛицевыеСчета"
Что значит - другого справочника ЛицевыеСчета? Вы имеете ввиду другой элемент справочника? Какой именно?

ИМХО, переделать проще, чем потом мучаться с тем, что может получиться.
0
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
28.05.2016, 20:15  [ТС] 9
alex1248,
ой... что то я совсем неправильно выразилась, прошу прощения...)Необходимо получить значение реквизита "Тариф" из справочника "ВидыУслуг" и поместить это значение в Справочник "ЛицевыеСчета" ТЧ "Услуги" реквизита "Тариф".
Это возможно?)


Очень неверно, что вы документ заменили справочником - честно, вообще никуда не годится, не представляю, как, например, вы будете формировать отчеты.
Очень стыдно...)) Будем учиться на ходу)))и хочется верить то что обойдусь без отчетов...)
0
alex1248
122 / 66 / 26
Регистрация: 08.03.2016
Сообщений: 173
28.05.2016, 21:04 10
Лучший ответ Сообщение было отмечено pippipi как решение

Решение

Код
&НаКлиенте 
Процедура УслугиПриИзменении(Элемент) 
ТекСтрока = Элементы.Услуги.ТекущиеДанные; 
ТекСтрока.Тариф = ПолучитьЗначениеРеквизитаНаСервере(ТекСтрока.ВидУслуги); 
КонецПроцедуры 
&НаСервереБезКонтекста Функция ПолучитьЗначениеРеквизитаНаСервере(Услуга) 
Возврат Услуга.Тариф; 
КонецФункции
Может быть так.

Добавлено через 2 минуты
Это если реквизит ВидУслуги ТЧ Услуги спр ЛицевыеСчета имеет тип спр ВидыУслуг.
1
pippipi
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 7
28.05.2016, 21:13  [ТС] 11
alex1248, Дааааа!)))) Спасибо огрооомное)))))) после стольких мучений!!))))) Волшебник))))
Именно то чего я так то, чего я так долго добивалась!)))))
0
28.05.2016, 21:13
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.05.2016, 21:13

Ссылка На Реквизит Табличной Части Справочника?
Здравствуйте, дорогие коллеги! Вопрос у меня такой - возможно ли в колонку ТаблицыЗначений записать...

Ссылка на реквизит табличной части справочника?
Здравствуйте, дорогие коллеги! Вопрос у меня такой - возможно ли в колонку ТаблицыЗначений записать...

Отображение не стандартного реквизита справочника в табличной части документа
Здравствуйте. Столкнулся с проблемой в собственной конфе на 1с 8.3.5. Есть 2 справочника ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru