Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
Modoll
0 / 0 / 0
Регистрация: 14.06.2016
Сообщений: 2
1

Заполнение реквизитов справочника Номенклатура программно в 1С

14.06.2016, 09:55. Просмотров 1079. Ответов 1
Метки нет (Все метки)

Здравствуйте. Помогите решить задачку. Необходимо заполнить реквизит Брэнд в справочнике Номенклатура из Excel.
1. Создала обработку в которую загружаются данные из Excel.
2. Создала кнопку Проверить, с помощью которой происходит сверка данных по коду (PLU) из справочника Номенклатура с данными из Excel.
3. Необходимо при нажатии кнопки Записать, заполнить в справочнике Номенклатура реквизит Бренд из обработки. Вот с этим у меня проблема!!!!





1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
Процедура ЗагрузитьБрэнд()
    
    Для Каждого Элемент Из Товары Цикл
        СпрНом = Справочники.Номенклатура;
        Условие = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));
           Если(Условие = Неопределено) Тогда 
            Сообщить("Не найдена номенклатура с кодом: " + Элемент.Штрихкод,СтатусСообщения.ОченьВажное);
        Иначе    
            НоменкОбъект = Условие.ПолучитьОбъект();
            
            НоменкОбъект.Брэнд = Товары.Брэнд;
            Попытка
                НоменкОбъект.Записать();
            Исключение
                Сообщить(ОписаниеОшибки());
            КонецПопытки;
        КонецЕсли;    
    КонецЦикла;
    
    Попытка
        Обработка = Обработки.РегламентныеЗагрузкаНоменклатуры.Создать();
        Обработка.ОчиститьУзлыНоменклатуры();
    Исключение
    КонецПопытки;
    
    Предупреждение("Загружено"); 
    
Конецпроцедуры
 
Функция НоменклатураПоКоду(Код)
    Попытка
    Номенклатура = НайтиНоменклатуруПоPLU(Число(Код));
Исключение
    КонецПопытки;
    Если Номенклатура = Неопределено Тогда
        Номенклатура = НайтиНоменклатуруПоШК(СтрЗаменить(Код," ",""));
    КонецЕсли;
    
    Возврат Номенклатура;
    
КонецФункции
 
Функция НайтиНоменклатуруПоPLU(КодPLU)
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    КодыТоваровPLU.Номенклатура
                   |ИЗ
                   |    РегистрСведений.КодыТоваровPLU КАК КодыТоваровPLU
                   |ГДЕ
                   |    КодыТоваровPLU.Код = &Код";
    Запрос.УстановитьПараметр("Код",КодPLU);
                              
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда        
        Возврат Выборка.Номенклатура.Ссылка;
    КонецЕсли;
    
    Возврат Неопределено;
    
КонецФункции
 
Функция НайтиНоменклатуруПоШК(Код)
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    Штрихкоды.Владелец КАК Номенклатура
                   |ИЗ
                   |    РегистрСведений.Штрихкоды КАК Штрихкоды
                   |ГДЕ
                   |    Штрихкоды.Штрихкод = &Код";
    Запрос.УстановитьПараметр("Код",Код);
                              
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда        
        Возврат Выборка.Номенклатура.Ссылка;
    КонецЕсли;
    
    Возврат Неопределено;
    
КонецФункции
Заполнение реквизитов справочника Номенклатура  программно в 1С

Заполнение реквизитов справочника Номенклатура  программно в 1С



ссылка на обработчик:
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.06.2016, 09:55
Ответы с готовыми решениями:

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке
Здравствуйте. В собственной конфигурации есть документ "Объектныйграфик" с...

Заполнение реквизитов строки ТЧ документа заченями реквизитов выбранного элемента
Здравствуйте. Запнулся вроде бы на простой задаче - забыл как делается... Суть...

Организация справочника номенклатура
У меня есть справочник Номенклатура. Есть справочник Склад товаров.В нём уже...

Печать реквизитов в документе из справочника
Добрый день.Может кто подскажет как можно распечатать документ если в нем...

Поиск соответствия реквизитов справочника
Доброго дня, у меня такая проблема разрабатываю примитивную (информационную...

1
Modoll
0 / 0 / 0
Регистрация: 14.06.2016
Сообщений: 2
14.06.2016, 09:57  [ТС] 2
https://drive.google.com/open?id=0BzHzLYChPnXQQzFLYnRfWFpIVG8
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.06.2016, 09:57

Данные реквизитов из другого справочника в таблице
Приветствую. Глобальная затея: сделать оценочный табель Имеется: Справочник...

Изменение реквизитов справочника при проведении документа
Доброго времени суток! Прошу помочь, нужно изменить реквизиты элементов...

Автоматическая замена табличных реквизитов, ссылающихся на реквизиты справочника
Имеем таблицу в документе с реквизитом "товар", ссылающимся на "товар" в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru