Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
vino0s
9 / 9 / 8
Регистрация: 26.03.2014
Сообщений: 353
1

Запрос ОСВ выборка по коду статьи затрат

14.06.2016, 15:55. Просмотров 592. Ответов 3
Метки нет (Все метки)

1С:Подрядчик строительства 4.0. Управление финансами, редакция 2.0 (2.0.65.15)

Как сформировать запрос оборотно-сальдовой ведомости по 20 счету:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
    ВыборкаСчетов = ПланыСчетов.Хозрасчетный.Выбрать();
    
    Пока ВыборкаСчетов.Следующий() Цикл
        Если ВыборкаСчетов.Код = "20" Тогда
            Счет = ВыборкаСчетов.Ссылка;
        КонецЕсли;
    КонецЦикла;
 
                Запрос1 = Новый Запрос;
                Запрос1.УстановитьПараметр("ДатаНач",НачалоДня(НачПериода));
                Запрос1.УстановитьПараметр("ДатаКон",НачалоДня(КонПериода));
                Запрос1.УстановитьПараметр("Счет",  Счет);
                Запрос1.Текст = "ВЫБРАТЬ
                                |   ОсновнойОстаткиИОбороты.СуммаКонечныйОстаток
                                |ИЗ
                                |   РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&ДатаНач, &ДатаКон, , , , ,) КАК ОсновнойОстаткиИОбороты"; //В какое место вписать &Счет?
                Выборка1 = Запрос1.Выполнить().Выбрать();
                
                Пока Выборка1.Следующий() Цикл
                        дебет = Выборка1.СуммаКонечныйОстаток;
                КонецЦикла;
Также мне надо затем получить дебет строк которые касались СтатьиЗатрат.Код = "000000012"?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.06.2016, 15:55
Ответы с готовыми решениями:

Отчёт ОСВ
Здравствуйте. Дело в том что я в конфигураторе пытаюсь сформировать отчет....

ОСВ по счёту
Добрый день! Подскажите, пожалуйста, где при формировании оборотки...

Отчет ОСВ по счету
Добрий день! Мне нужно в 1с 7.7 Бухг. учет для Украини в отчете ОСВ по счету...

Проблемы с выводом отчета ОСВ
Ребята подскажите пожалуйста. Формирую ОСВ, периоды выставлены верно, а вместо...

Переделать типовую ОСВ по счёту
Доброго времени суток господа программисты ! Вопрос такой: как переделать...

3
vino0s
9 / 9 / 8
Регистрация: 26.03.2014
Сообщений: 353
15.06.2016, 08:07  [ТС] 2
Прикреплю обработку
0
Вложения
Тип файла: 7z Формы.7z (19.2 Кб, 2 просмотров)
vino0s
9 / 9 / 8
Регистрация: 26.03.2014
Сообщений: 353
15.06.2016, 08:09  [ТС] 3
Вопрос можно сказать в том чем заполняется РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты() в скобках и в каком порядке.
Я так понял надо субконто получить, но какой 1 или 2 или 3, чтоб попасть на статьизатрат.код?
0
Trit5
24 / 24 / 2
Регистрация: 11.09.2013
Сообщений: 93
15.06.2016, 09:01 4
Попробуй через консоль запросов вытащить все субконто.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.06.2016, 09:01

Отчет переработать (в ОСВ поле регистратора)
Доброго времени суток всем. Так как я только начинаю осваивать 1с8 в плане...

Запрос и выборка, не понятно как делать
не понятно как делать запрос и выборку с перебором ответственных и как это...

Выборка статьи из html страницы
Подскажите из всей html-страницы (например: http://ru.wikipedia.org/wiki/Липецк...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru