Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
molly_sue
1 / 1 / 1
Регистрация: 01.04.2015
Сообщений: 41
1

Выбор наибольшего и наименьшего значения из колонки табличной части документа

14.06.2016, 19:42. Просмотров 1023. Ответов 2
Метки нет (Все метки)

Добрый вечер.
Как можно найти наибольшее и наименьшее значение в колонке табличной части (на рисунке указан столбец).
После с этими значениями произвести вычисление (на 2-ом рисунке) и записать в подвал табличной части.
Помогите пожалуйста с решением данной проблемы.
0
Миниатюры
Выбор наибольшего и наименьшего значения из колонки табличной части документа   Выбор наибольшего и наименьшего значения из колонки табличной части документа  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.06.2016, 19:42
Ответы с готовыми решениями:

Выбор данных для формы документа из табличной части справочника
Всем доброго времени суток! Ситуация. Есть справочник клиентов, в котором есть табличная часть с...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...

Заполнение табличной части одного документа из табличной части этого же документа
Здравсвуйте. 1С 8.2. Есть документ в этом документе 2 табличные части В 1 табличной части...

2
irifka2012
60 / 30 / 5
Регистрация: 22.05.2012
Сообщений: 102
15.06.2016, 13:08 2
Лучший ответ Сообщение было отмечено molly_sue как решение

Решение

Структура документа во вложении

Код примерно такой

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
&НаСервере
Процедура РассчитатьНаСервере()
    
    Об = РеквизитФормыВЗначение("Объект");
    Таблица = Об.ТЧ;
//ищем макс элемент ++++
    МаксЭлем = Неопределено;
    Для Каждого ЭлТч из Таблица Цикл
        Если МаксЭлем = Неопределено Тогда 
            МаксЭлем = ЭлТч.Реквизит2;
        ИначеЕсли МаксЭлем < ЭлТч.Реквизит2 Тогда 
            МаксЭлем = ЭлТч.Реквизит2
        КонецЕсли;
    КонецЦикла;
//------------
// записываем его в подвал +++
    Элементы.ТЧРеквизит2.ТекстПодвала = МаксЭлем;
// ------------
//считаем элемент по формуле +++    
    Для Каждого стрТч из Таблица Цикл
        СтрТч.Реквизит1 =  стрТч.Реквизит3 / МаксЭлем;
    КонецЦикла;
//---------------
    ЗначениеВРеквизитФормы(Об,"Объект");
 
КонецПроцедуры
 
&НаКлиенте
Процедура Рассчитать(Команда)
    РассчитатьНаСервере();
КонецПроцедуры
1
Миниатюры
Выбор наибольшего и наименьшего значения из колонки табличной части документа  
molly_sue
1 / 1 / 1
Регистрация: 01.04.2015
Сообщений: 41
15.06.2016, 17:23  [ТС] 3
Добавлено через 21 минуту
irifka2012, как я поняла, вы ищете максимальное значение в колонке и делите его на реквизит 3?

Добавлено через 1 час 11 минут
irifka2012, Спасибо вам огромное, нашла минимум в этой же колонке и исходя решению записала в подвал нужное значение, реквизиты были для проверки))
0
Миниатюры
Выбор наибольшего и наименьшего значения из колонки табличной части документа  
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.06.2016, 17:23

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа имеют табличные части -...

Ошибка в запросе при попытке получения значения из Табличной части документа
Необходимо получить предыдущую цену продажи по данному Контрагенту, Дате и номенклатуре. В первом...

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать. ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru