Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
Liya1203
1 / 1 / 1
Регистрация: 22.10.2011
Сообщений: 55
1

Выбор данных из табличной части

21.06.2016, 13:03. Просмотров 933. Ответов 2
Метки нет (Все метки)

Добрый день! Имеется Справочник "Типовые элементы", который содержит 2 табличные части: "Виды Работ" и "Материалы". В ТЧ "Виды работ" имеются реквизиты: Код работы, Название. В ТЧ "Материалы" имеются реквизиты: Наименование материала, Код материала, Код работы. Как сделать так, чтобы в поле "Код работы" ТЧ Материалы можно было бы выбрать только те коды, которые имеются в ТЧ Виды работ?
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.06.2016, 13:03
Ответы с готовыми решениями:

Выбор данных для формы документа из табличной части справочника
Всем доброго времени суток! Ситуация. Есть справочник клиентов, в котором есть табличная часть с...

Выбор строки из табличной части
Подскажите пожалуйста, как из табличной части выбрать строку где бы значение было максимальным в...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

2
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
21.06.2016, 14:06 2
Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Liya1203, опишите событие поля НачалоВыбора(), заполнив ДанныеВыбора нужными значениями из ТЧ.
1
Liya1203
1 / 1 / 1
Регистрация: 22.10.2011
Сообщений: 55
21.06.2016, 15:25  [ТС] 3
Сделала следующее. При выборе кода работы никаких действий не происходит. В чем может быть ошибка?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
&НаКлиенте
Процедура Материалы1ВидРаботНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ТекСтрока = Элемент.Родитель.ТекущиеДанные;
ДанныеВыбора = ПолучитьСписокНаСервере(ТекСтрока.КодВидаРабот);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьСписокНаСервере(КодВидаРабот)
ДанныеВыбора = Новый СписокЗначений;
Запрос = Новый Запрос("ВЫБРАТЬ 
                      | ТиповыеТехнологическиеЭлементыВидыРабот.КодВидаРабот КАК Код
                      |ИЗ
                      | Справочник.ТиповыеТехнологическиеЭлементы.ВидыРабот КАК ТиповыеТехнологическиеЭлементыВидыРабот
                      |ГДЕ
                      | ТиповыеТехнологическиеЭлементыВидыРабот.КодВидаРабот = &КодВидаРабот");
Запрос.УстановитьПараметр("КодВидаРабот", КодВидаРабот);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ДанныеВыбора.Добавить(Выборка.Код); 
КонецЦикла;
Возврат ДанныеВыбора; 
КонецФункции
Добавлено через 16 минут
Ошибку нашла, все получилось
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура Материалы1ВидРаботНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ТекСтрока = Элемент.Родитель.ТекущиеДанные;
ДанныеВыбора = ПолучитьСписокНаСервере();
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьСписокНаСервере()
ДанныеВыбора = Новый СписокЗначений;
Запрос = Новый Запрос("ВЫБРАТЬ РАЗЛИЧНЫЕ
                      | ТиповыеТехнологическиеЭлементыВидыРабот.КодВидаРабот КАК Код
                      |ИЗ
                      | Справочник.ТиповыеТехнологическиеЭлементы.ВидыРабот КАК ТиповыеТехнологическиеЭлементыВидыРабот");
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ДанныеВыбора.Добавить(Выборка.Код); 
КонецЦикла;
Возврат ДанныеВыбора; 
КонецФункции
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.06.2016, 15:25

Выбор наибольшего и наименьшего значения из колонки табличной части документа
Добрый вечер. Как можно найти наибольшее и наименьшее значение в колонке табличной части (на...

Получение данных из соседней табличной части
Добрый день. Подскажите, пожалуйста. Есть справочник, в котором несколько табличных частей. В...

Вывод данных из справочника при изменении табличной части
Добрый день форумчане! В 1с недавно, многого не понимаю. Нужно написать запрос при изменение...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru