Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
John_Locke
0 / 0 / 0
Регистрация: 07.06.2014
Сообщений: 18
1

Поиск и создание папки в справочнике

22.06.2016, 20:02. Просмотров 392. Ответов 0
Метки нет (Все метки)

Необходимо загрузить данные из файла excel в справочник. Справочник иерархический. В документе excel каждому элементу указано, в какой папке он находится в справочнике. Но, этих папок нет в самом справочнике, поэтому их надо создать. Что я сделал: выгружаю данные из файла в таблицу значений, и далее проверяю, каждый элемент, есть ли он в справочнике. если нет - из таблицы значений беру для элемента беру поле "Родитель" и проверяю , есть ли такая папка в справочнике. Проблема в том, что я не знаю, как правильно это сделать. Можно ли написать так? Написал пробную процедуру, что-то не работает
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Процедура ЗапСпр(Команда)
    сч = 0;
    пока сч<4 Цикл
        РодСпр = Справочники.Номенклатура.НайтиПоНаименованию(,,"123",);
        Если   РодСпр.Ссылка = Справочники.Номенклатура.ПустаяСсылка() Тогда
            Сообщить("!!!");
            НовыйГр = Справочники.Номенклатура.СоздатьГруппу();
            НовыйГр.Наименование = "123";
            НовыйГр.Записать();
            
        КонецЕсли;
         сч=сч+1;
        
    КонецЦикла;
    
КонецПроцедуры
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.06.2016, 20:02
Ответы с готовыми решениями:

Поиск в справочнике
8.1 самописная Вопрос впринципе общего плана... Есть справочник ФИО...

Поиск в справочнике
Приветствую знатоков. Вопрос таков: В 1С7 в реж пользователя открываю...

Создание ссылки в справочнике на элемент документа
Есть справочник. В нем элемент с реквизитом наименование, цена. Есть документ,...

Поиск по эл. адресу контактного лица контрагента в справочнике контрагенты
Здравствуйте спецы. На скрине отображено окно списка контрагентов, где...

RLS. Ограничение на создание и изменение наименования элементов в справочнике
Доброе утро всем, подскажите, как можно ограничить доступ на создание и...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.06.2016, 20:02

Поиск в справочнике
Подскажите,пожалуйста ... чего то туплю в спр1 есть реквизит Подразделение...

V7.Поиск в справочнике по реквизиту
Здраствуйте.. Подскажите как организовать поиск в справочнике по реквизиту....

Создание Групп В Справочнике
нужно создать группу и элементы в справочнике, владельцем которого явл. другой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru