Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
Liya1203
1 / 1 / 1
Регистрация: 22.10.2011
Сообщений: 55
1

Проверка на заполнение реквизита справочника

14.09.2016, 09:28. Просмотров 1062. Ответов 1
Метки нет (Все метки)

Добрый день! Имеется справочник "Коэффициенты перевода" с реквизитами:
Код материала
Наименование материала (СправочникСсылка.Номенклатура)
Коэффициент перевода
А также табличная часть "Материалы" справочника "типовые элементы" с реквизитами:
Код материала
Наименование материала (СправочникСсылка.Номенклатура)
Нормативный расход
Как сделать так чтобы при изменении реквизита "Нормативный расход" осуществлялась проверка на заполнение реквизита "Коэффициент перевода" из справочника "Коэффициенты перевода"? если реквизит не заполнен, то заполнить значение "Нормативный расход" в ТЧ "Материалы" нельзя и выдать соответствующее сообщение.
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.09.2016, 09:28
Ответы с готовыми решениями:

Автоматическое заполнение реквизита из справочника
Имеется договор клиента, в нём реквизит "Организация" который ссылается на справочник и выбираю...

Заполнение реквизита тч документа из справочника
Всем доброго времени суток. Прошу помощи Часто создаваемая тема, но все же. Есть справочник...

При выборе реквизита справочника выводить табличную часть другого справочника
Помогите пожалуйста сделать выборку. Есть справочник с реквизитами сотрудника и табличной частью с...

Получение реквизита из справочника
Знаю, что вопрос очень легкий, и наверняка на него уже есть тысяча ответов, но я с 1C еще не успел...

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке
Здравствуйте. В собственной конфигурации есть документ "Объектныйграфик" с реквизитами: ШифрОбъекта...

1
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
14.09.2016, 09:55 2
Лучший ответ Сообщение было отмечено Liya1203 как решение

Решение

Liya1203, а какой ключ связи у справочника Коэффициенты перевода и ТЧ Материалы? По Коду материала или Номенклатуре? Подумайте... и опишите событие НормативныйРасходПриИзменении(Элемент):
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
&НаКлиенте
Процедура МатериалыНормативныйРасходПриИзменении(Элемент)
 ТекСтрока = Элемент.Родитель.ТекущиеДанные;
 КоэффициентПеревода = ПолучитьЗначениеКоэффициентаСервер(ТекСтрока.НаименованиеМатериала);
 Если КоэффициентПеревода = 0 Тогда
   ТекСтрока.НормативныйРасход = 0;
   Предупреждение(НСтр("ru = 'Не заполнен коэффициент перевода!'"), 10);
 КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначениеКоэффициентаСервер(Номенклатура)
 ТекЭлемент = Справочники.КоэффициентПеревода.НайтиПоРеквизиту("НаименованиеМатериалы", Номенклатура);
 Если Не ТекЭлемент.Пустая() Тогда
  Возврат ТекЭлемент.КоэффициентПеревода;
 Иначе
  Возврат 0;
 КонецЕсли;
КонецФункции
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.09.2016, 09:55

Не сохраняется значение реквизита справочника (8.3 УФ)
Конфигурацию прилагаю. Информация об авторах-->Справочник синонимы авторов -> создать -> Выбрать...

Запрет повторяющихся значений реквизита справочника
Существует справочник Клиенты с реквизитом Телефон. Как можно запретить дублирование данного...

Получение значения реквизита справочника в документ
Добрый день, есть вопрос Как сделать чтобы реквизит табличной части документа получал данные из...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru