Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Niyaz12
3 / 3 / 2
Регистрация: 10.04.2013
Сообщений: 82
#1

Не работает условие выборки

04.10.2016, 01:08. Просмотров 407. Ответов 5
Метки нет (Все метки)

Есть документ, в нем есть поле Преподаватель при открытии записывается Имя пользователя в это поле
а так же при открытии должен заполниться поле выбора из справочника нагрузка где поле преподавателья равен преподавателю в форме, при выборке условие не работает почему то, но без условии все прекрасно выводится
Не работает условие выборки

Часть кода
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура ПриОткрытии(Отказ)
 ЗаполнениеСпискаГрупп(Объект.Препадователь)
КонецПроцедуры
 
&НаСервере
 
Процедура ЗаполнениеСпискаГрупп(Преподаватель)
       Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Преподаватель",  Препадователь);
Запрос.Текст =
    "ВЫБРАТЬ
    |   Нагрузка.Группа
    |ИЗ
    |   Справочник.Нагрузка КАК Нагрузка
    |ГДЕ
    |   Нагрузка.Преподователь = &Преподователь";
 
Элементы.Группа.СписокВыбора.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Группа"));
КонецПроцедуры
1Cv8.zip
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.10.2016, 01:08
Ответы с готовыми решениями:

Не работает условие
здравствуйте! есть простенький запрос, но при формировании отчета по этому...

Не работает условие
Не понимаю почему не срабатывает условие. Должно работать: Создано два...

Условие выборки
Народ, помогите с условием выборки... у меня в таблице есть запись в которой 2...

Условие выборки
Есть две таблицы: юзеры и записи юзеров. В таблице 'записей юзеров' есть поле...

Условие IF в критерии выборки WHERE
Можно ли использовать IF совместно с WHERE? Например, используя хранимую...

5
GreenkA
(◉‿◉)
Эксперт 1С
1965 / 1518 / 474
Регистрация: 25.06.2009
Сообщений: 5,440
04.10.2016, 01:19 #2
Niyaz12, у вас опять проблема с типами: в документе Преподаватель - строка, в справочнике Нагрузка - ссылка на справочник Преподаватели...
0
Niyaz12
3 / 3 / 2
Регистрация: 10.04.2013
Сообщений: 82
04.10.2016, 08:28  [ТС] #3
Цитата Сообщение от GreenkA Посмотреть сообщение
в документе Преподаватель - строка, в справочнике Нагрузка - ссылка на справочник Преподаватели...
А так никак нельзя?)
0
GreenkA
(◉‿◉)
Эксперт 1С
1965 / 1518 / 474
Регистрация: 25.06.2009
Сообщений: 5,440
04.10.2016, 14:56 #4
Niyaz12, нет
0
Niyaz12
3 / 3 / 2
Регистрация: 10.04.2013
Сообщений: 82
04.10.2016, 16:01  [ТС] #5
GreenkA, жаль, так многие выборки конечно хотел сделать, например, вывести данные группы(курс) из справочника группы где наименование группы равен ссылке на справочник группы(как вы сказали)
0
Niyaz12
3 / 3 / 2
Регистрация: 10.04.2013
Сообщений: 82
09.10.2016, 22:33  [ТС] #6
Решил проблему примерно таким образом)
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаСервере
 
Процедура ЗаполнениеСпискаГрупп(Преподаватель)
     ИмяПреподавателя = Строка(Преподаватель);
       Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ИмяПреподавателя", ИмяПреподавателя);
Запрос.Текст =
    "ВЫБРАТЬ
    |   Нагрузка.Группа
    |ИЗ
    |   Справочник.Нагрузка КАК Нагрузка
    |ГДЕ
    |   Нагрузка.Преподователь = &ИмяПреподавателя";
 
Элементы.Группа.СписокВыбора.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Группа"));
КонецПроцедуры
0
09.10.2016, 22:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.10.2016, 22:33

Задать условие выборки
Добрый день уважаемые форумчане! такой вопрос. имеется база. в ней есть...

Условие выборки из символьной строки
Всем привет! Нужен добрый, мудрый совет по условию. В базе mysql есть поле...

Неточно выполняется условие выборки
Добрый день! Делаю запрос: SELECT * FROM news WHERE news_enabled>0...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru