Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
1

Удалить строку в ТЧ

12.10.2016, 17:05. Просмотров 416. Ответов 4
Метки нет (Все метки)

Добрый день! В справочнике есть табличная часть, хочу по условию удалить строку не нужную. Написал код и почему то не работает, понять не могу почему не записывает справочник. В отладчике смотрел все удаляет как надо, начинаю проверять справочник строки не удаленны.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Для Каждого Стр из Таб Цикл  
        ЛСФИО=Справочники.ЛицевыеСчетаАбонентов.НайтиПоКоду(Стр.ЛС);
        Если НЕ ЛСФИО=Справочники.ЛицевыеСчетаАбонентов.ПустаяСсылка() Тогда
            ЛСОб=ЛСФИО.ПолучитьОбъект();
            ФИОЛг=ЛСОб.Льготники.Выгрузить();
            Если ФИОЛг.Количество() > 3 Тогда
                Для Каждого СтрЛГ из ФИОЛг Цикл
                    Если Дата(СтрЛГ.ДатаВыдачи) = Дата("01.01.0001 0:00:00") Тогда
                         ФИОЛг.Удалить(СтрЛГ);
                     КонецЕсли;  
                 КонецЦикла;
            ЛСОб.Записать();
             КонецЕсли;
         КонецЕсли;
     КонецЦикла;
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.10.2016, 17:05
Ответы с готовыми решениями:

Удалить строку из формы списка журнала документов
Не УФ. Вопрос немного глупый. Как удалить строку в форме списка в обработчике...

Как В 1с Удалить Строку Из Созданной Формы Кнопкой?
Создал Справочник2. Создал фому ФормаВыбора На нее наложил кнопку Процедура...

Двунаправленный линейный список строк. Вставить строку, удалить строку и заменить строку
3 двунаправленный линейный список строк.требуется вставить строку после строки...

Ввести строку и слово, удалить все вхождения слова и вывести строку
помогите с лабой! Добавлено через 22 секунды через <stdio.h>

Ввести строку и слово, удалить все вхождения слова и вывести строку
Нужно написать программу только со стандартной библиотекой <stdio.h> Помогите,...

4
GreenkA
Модератор
Эксперт 1С
2276 / 1685 / 501
Регистрация: 25.06.2009
Сообщений: 6,196
12.10.2016, 17:07 2
Ermak27, для удаления строк отходите ТЧ с последней строки к первой, а не наоборот, как у вас.
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
12.10.2016, 18:17  [ТС] 3
GreenkA, можете показать
0
GreenkA
Модератор
Эксперт 1С
2276 / 1685 / 501
Регистрация: 25.06.2009
Сообщений: 6,196
12.10.2016, 19:21 4
Ermak27,
1C
1
2
3
4
5
6
7
8
9
10
//ФИОЛг=ЛСОб.Льготники.Выгрузить();//зачем лишняя ТЗ?
//  Если ФИОЛг.Количество() > 3 Тогда //это условие вообще для чего?
к = ЛСОб.Льготники.Количество()-1;
Пока к >= 0  Цикл
    Если Дата(ЛСОб.Льготники[к].ДатаВыдачи) = Дата("01.01.0001 0:00:00") Тогда
        ЛСОб.Льготники.Удалить(к);
    КонецЕсли;  
    к = к -1;
КонецЦикла;
ЛСОб.Записать();
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
12.10.2016, 19:54  [ТС] 5
GreenkA, этим условия я проверю если больше 3 строк тогда удалить
0
12.10.2016, 19:54
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.10.2016, 19:54

Ввести строку и слово, удалить все вхождения слова и вывести строку
Доброго времени суток всем ! написал лр2 (Ввести строку и слово, удалить все...

Ввести строку и слово, удалить все вхождения слова и вывести строку
Написал код. Вот условие: "Ввести строку и слово, удалить все вхождения слова и...

Найти в матрице строку где сумма элементов минимальна и удалить эту строку
Написать программу, что бы она находила в матрице строку где сумма элементов...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru