Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
Daniel001
0 / 0 / 0
Регистрация: 30.05.2015
Сообщений: 5
#1

Обмен данными: метод объекта не обнаружен (ЗаписатьСообщениеСИзменениями)

16.10.2016, 12:00. Просмотров 711. Ответов 4
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаСервереБезКонтекста
Процедура ВыполнитьОбменНаСервере() Экспорт 
    ВыборкаУзлов = ПланыОбмена.Филиалы.Выбрать(); 
    Пока ВыборкаУзлов.Следующий() Цикл
          // Произвести обмен данными со всеми узлами, кроме текущего(ЭтотУзел).  
          Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда
              УзелОбъект = ВыборкаУзлов.ПолучитьОбъект();
   // Получить сообщение.
   УзелОбъект.ПрочитатьСообщениеСИзменениями();
   // Сформировать сообщение.
   УзелОбъект.ЗаписатьСообщениеСИзменениями();
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.10.2016, 12:00
Ответы с готовыми решениями:

Метод объекта не обнаружен
В общем, есть конфигурация рукодельная, на 8.2 , и я хотел вывести при запуске...

Метод объекта не обнаружен
Создал форму в которой выбирается документ(любой) из базы данных и Параметр...

Метод объекта не обнаружен
ОбновитьТаблицуДоступныхНастроекПользователю Помогите опытные воротилы

Метод объекта не обнаружен (Печать)
Здраствуйте. Проблема... Создаю внешний печатный отчет расходного кассового...

Метод объекта не обнаружен (напечатать строку)
Здравствуйте. При печатании чека вылазит ошибка: Помогите пожалуйста, уже...

4
GreenkA
(◉‿◉)
Эксперт 1С
1965 / 1518 / 474
Регистрация: 25.06.2009
Сообщений: 5,440
16.10.2016, 12:07 #2
Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Daniel001, а у вас есть такая процедура в плане обмена? Должна быть экспортной.
0
Daniel001
0 / 0 / 0
Регистрация: 30.05.2015
Сообщений: 5
16.10.2016, 12:10  [ТС] #3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
Процедура ПрочитатьСообщениеСИзменениями() Экспорт
 Каталог = КаталогВременныхФайлов();
 // Сформировать имя файла. 
 ИмяФайла = Каталог + ?(Прав(Каталог, 1) = "", "", "") + "Message" + СокрЛП(Ссылка.Код) + "_" +
 СокрЛП(ПланыОбмена.Филиалы.ЭтотУзел().Код) + ".xml"; 
 Файл = Новый Файл(ИмяФайла); 
 Если Не Файл.Существует() Тогда  
     Возврат; 
 КонецЕсли;
 // *** Чтение документов XML 
 // Попытаться открыть файл.
 ЧтениеXML = Новый ЧтениеXML;
 Попытка   ЧтениеXML.ОткрытьФайл(ИмяФайла);
 Исключение
     Сообщение = Новый СообщениеПользователю;
     Сообщение.Текст = "Невозможно открыть файл обмена данными.";
     Сообщение.Сообщить();
  Возврат;
 КонецПопытки;
 Сообщение = Новый СообщениеПользователю;
 Сообщение.Текст = "-------- Загрузка из " + Строка(ЭтотОбъект) + " ------------";
 Сообщение.Сообщить(); 
 Сообщение = Новый СообщениеПользователю;
 Сообщение.Текст = " – Считывается файл " + ИмяФайла;
 Сообщение.Сообщить(); 
 // Загрузить из найденного файла 
 // *** Инфраструктура сообщений.
 ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();
 // Читать заголовок сообщения обмена данными – файла XML.
 ЧтениеСообщения.НачатьЧтение(ЧтениеXML);
 // Сообщение предназначено не для этого узла.
 Если ЧтениеСообщения.Отправитель <> Ссылка Тогда
     ВызватьИсключение "Неверный узел";
 КонецЕсли;
 // Удаляем регистрацию изменений для узла отправителя сообщения 
 // *** Служба регистрации изменений. 
 ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель,
 ЧтениеСообщения.НомерПринятого);
 // Читаем данные из сообщения *** XML-сериализация.
  Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл
  // Читаем очередное значение.   
  Данные = ПрочитатьXML(ЧтениеXML);
  // Не переносим изменение, полученное в главный из неглавного,
  // если есть регистрация изменения.  
  Если Не ЧтениеСообщения.Отправитель.Главный И
      ПланыОбмена.ИзменениеЗарегистрировано(
      ЧтениеСообщения.Отправитель, Данные) Тогда
      Сообщение = Новый СообщениеПользователю;
      Сообщение.Текст = " – Изменения отклонены";
      Сообщение.Сообщить();
   Продолжить;
  КонецЕсли;
  // Записать полученные данные.
  Данные.ОбменДанными.Отправитель = ЧтениеСообщения.Отправитель;
  Данные.ОбменДанными.Загрузка = Истина;
  Данные.Записать();
 КонецЦикла;
 ЧтениеСообщения.ЗакончитьЧтение();
 ЧтениеXML.Закрыть();
 УдалитьФайлы(ИмяФайла);
 Сообщение = Новый СообщениеПользователю;
 Сообщение.Текст = "-------- Конец загрузки ------------";
 Сообщение.Сообщить();
КонецПроцедуры
0
GreenkA
(◉‿◉)
Эксперт 1С
1965 / 1518 / 474
Регистрация: 25.06.2009
Сообщений: 5,440
16.10.2016, 12:11 #4
Daniel001, у вас же на отсутствие другой процедуры ругается) где запись сообщения с изменениями?
1
Daniel001
0 / 0 / 0
Регистрация: 30.05.2015
Сообщений: 5
16.10.2016, 12:14  [ТС] #5
Косяяяк точно)
0
16.10.2016, 12:14
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.10.2016, 12:14

Получить ТЧ документа. Метод объекта не обнаружен (ПолучитьОбъект)
Здравствуйте! Пишу обработку. Есть табличная часть &quot;ТЧ_СписокДокументов&quot; с...

Ошибка печати "Метод объекта не обнаружен"
Здравствуйте. Помогите решить проблему. При нажатии на печать сметы выдает...

Метод контекста не обнаружен
&quot;метод контекста не обнаружен&quot; выдаёт при фызове из модуля формы процекдуры в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru