Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Far323
0 / 0 / 0
Регистрация: 30.12.2015
Сообщений: 25
1

Выбор значения в зависимости от типа движений

26.10.2016, 17:07. Просмотров 911. Ответов 8
Метки нет (Все метки)

Всем привет!
Пытаюсь собрать свою конфигурацию. 1С 8.3 В управляемом приложении
Документ РКО. Форма документа.

ФирмаА

Поле ввода "ТипРКО" Тип ПеречислениеСсылка.ТипыРасходИзКассы
ТипыРасходИзКассы: ОплатаПоставщику, НаРасчСчет, ВыдачаВДругуюКассу

Поле ввода "Аналитика" Составной тип СправочникСсылка.Поставщики, ПеречислениеСсылка.РасчСчетаФирмаА, ПеречислениеСсылка.КассыФирмыА, ПеречислениеСсылка.КассыФирмыБ

1. Нужно чтобы при выборе из списка ТипРКО, напимер ОплатаПоставщику, сразу открывался справочник Поставщики,
и при выборе поставщика заполнялось поле Аналитика.
а при выборе НаРасчСчет открывался список РасчСчетаФирма, и аналогично заполнялось поле Аналитика.
2. Нужно чтобы при проведении РКО с ТипомРКО ВыдачаВДругуюКассу и Аналитикой КассыФирмыБ (КассаФирмыБ), автоматом создавался, заполнялся и проводился документ ПКО КассыФирмыБ с Типом ПКО ИзКассыФирмыА, с Аналитикой КассыФирмыА (КассаФирмыА).

Помогите с кодом пожалуйста...
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.10.2016, 17:07
Ответы с готовыми решениями:

1с отчет СКД выбор данных в зависимости от значения логического параметра
Здравствуйте. Платформа 1С: Предприятие 8.3. Столкнулась с такой проблемой....

Выбор значения номенклатуры типа СправочникСсылка
Добрый день! Подскажите пожалуйста. Есть у меня две табличные части, одна...

Формирование движений
Всем добрый день, помогите разобраться, в программировании 1С я новичек,...

Нет движений по расходной накладной по РБ
Не могу понять, почему расходная накладная не делает движения по РБ...

Выбор типа в начале выбора
Имеется форма на ней поле, для которого пишется процедура начала выбора из...

8
Joker_vad
Эксперт 1С
471 / 409 / 92
Регистрация: 26.09.2012
Сообщений: 1,826
26.10.2016, 17:45 2
Приравниваешь свой реквизит пустой ссылке, для элемента управления убираешь возможность выбора типа.
1C
1
2
3
4
5
6
7
8
9
10
&НаСервере
Процедура Команда1НаСервере()
    Реквизит1 = Справочники.Валюты.ПустаяСсылка();
КонецПроцедуры
 
&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
    Элементы.Реквизит1.ВыбиратьТип = Ложь;
КонецПроцедуры
В этом коде по нажатию на кнопку поле приводится к виду
0
Far323
0 / 0 / 0
Регистрация: 30.12.2015
Сообщений: 25
26.10.2016, 17:58  [ТС] 3
Я только учусь и поэтому ничего не понял...
Растолкуйте пожалуйста неучу поподробнее...
0
GreenkA
Модератор
Эксперт 1С
2310 / 1789 / 511
Регистрация: 25.06.2009
Сообщений: 6,581
27.10.2016, 00:55 4
Joker_vad, а почему бы не использовать ПривестиЗначение()?
0
Joker_vad
Эксперт 1С
471 / 409 / 92
Регистрация: 26.09.2012
Сообщений: 1,826
27.10.2016, 12:47 5
Цитата Сообщение от GreenkA Посмотреть сообщение
Joker_vad, а почему бы не использовать ПривестиЗначение()?
Как то давно нарывался на то что, ПривестиЗначение() не работало, спас как раз этот метод.

Добавлено через 33 секунды
Цитата Сообщение от Far323 Посмотреть сообщение
Я только учусь и поэтому ничего не понял...
Кидай конфигурацию, покажу на ней
0
Far323
0 / 0 / 0
Регистрация: 30.12.2015
Сообщений: 25
27.10.2016, 13:31  [ТС] 6
Пороль "1"
0
Вложения
Тип файла: zip 1Cv8.zip (186.1 Кб, 0 просмотров)
Far323
0 / 0 / 0
Регистрация: 30.12.2015
Сообщений: 25
27.10.2016, 13:37  [ТС] 7
не ту скинул. там типов не хватает. вот эта
0
Вложения
Тип файла: zip 1Cv8.zip (190.6 Кб, 2 просмотров)
Joker_vad
Эксперт 1С
471 / 409 / 92
Регистрация: 26.09.2012
Сообщений: 1,826
27.10.2016, 15:23 8
Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Тут первая часть, частично сделана. 1Cv8.rar

По поводу второй, идея какая то не очень) Мне не нравится. А как быть если этот документ будет проведен по ошибке и в последствии удален?
2
Far323
0 / 0 / 0
Регистрация: 30.12.2015
Сообщений: 25
28.10.2016, 01:26  [ТС] 9
Спасибо огромное!
Работает!
А я где то вокруг да около бродил...
Со 2 частью действительно наверное не стоит. Это я из лени... думаю зачем лишнее движение делать...

Добавлено через 9 часов 54 минуты
А ещё один вопрос можно...
Нужно получить результат:

Вот этого как записать? Тн.ТоварКоэффициент он подчиненый Объект.Товары.Товар.Коэффициент

1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ТоварыМетровПриИзменении(Элемент)
    РассчитатьТоннаж();
КонецПроцедуры
 
&НаКлиенте
Процедура  РассчитатьТоннаж()
    Тн=Элементы.Товары.ТекущиеДанные;
    Тн.Тонн=Тн.ТоварКоэффициент*Тн.Метров;
КонецПроцедуры
0
28.10.2016, 01:26
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.10.2016, 01:26

Формирование движений без перепроведения документов
Добрый день! Конфигурация Управление торговлей, редакция 11.1.6.17. Создал...

Задание условий для движений документа по регистрам
Друзья, помогите плиз! Имеется документ с двумя реквизитами, пусть будет...

Удаление движений при установке отметки удаления
Я пока не профи по 1С..... Есть у меня такая задача - создать так, чтобы при...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru