Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
Melec354
0 / 0 / 0
Регистрация: 13.11.2016
Сообщений: 23
1

Заполнение реквизита тч документа из справочника

17.11.2016, 15:24. Просмотров 1096. Ответов 4
Метки нет (Все метки)

Всем доброго времени суток. Прошу помощи
Часто создаваемая тема, но все же. Есть справочник ОбъектПроката с реквизитами Наименование и ИнвентарноыйНомер. Нужно автозаполнить реквизит табличной части документа "ПеремещениеОбъекта" ИнвентарноыйНомер при выборе ОбъектаПроката из справочника.
Вот модуль формы документа
1C
1
2
3
4
5
6
7
&НаСервере
Функция ПолучитьИнвентарныйНомер()
    
    ИнвентНом = Справочники.ОбъектПроката.ИнвентарныйНомер;
    Возврат ИнвентНом;
    
КонецФункции
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура ОбъектыПрокатаОбъектПрокатаПриИзменении(Элемент)
    
        // текущая строка ТБ
        ИнНом = Элементы.ОбъектыПроката.ТекущиеДанные;
        // получить инв.номер
        ИнНом.ИнвентарныйНомер = ПолучитьИнвентарныйНомер() ;
        
КонецПроцедуры
0
Миниатюры
Заполнение реквизита тч документа из справочника   Заполнение реквизита тч документа из справочника  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.11.2016, 15:24
Ответы с готовыми решениями:

Подстановка значение реквизита справочника в ТЧ Документа
Здорова.Есть справочник "Компьютеры" с реквизитами "Наименование" и "ИнвНомер"....

Проверка на заполнение реквизита справочника
Добрый день! Имеется справочник "Коэффициенты перевода" с реквизитами: Код...

Автоматическое заполнение реквизита из справочника
Имеется договор клиента, в нём реквизит "Организация" который ссылается на...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и...

Получение реквизита из справочника в табличную часть документа
Здравствуйте, полный нуб в 1с. Прошу больно не пинать. Вопрос самый простой и...

4
Melec354
0 / 0 / 0
Регистрация: 13.11.2016
Сообщений: 23
17.11.2016, 20:36  [ТС] 2
мужики выручайте
0
Melec354
0 / 0 / 0
Регистрация: 13.11.2016
Сообщений: 23
17.11.2016, 20:52  [ТС] 3
Сделал вот так,
1C
1
2
3
4
5
6
7
&НаСервере
Функция ПолучитьИнвентарныйНомер(ОбъектПроката)
 
    ИнвентНом = Справочники.ОбъектПроката.НайтиПоНаименованию(ОбъектПроката).ИнвентарныйНомер;
    Возврат ИнвентНом;
    
КонецФункции
1C
1
2
3
4
5
6
7
8
&НаКлиенте
Процедура ОбъектыПрокатаОбъектПрокатаПриИзменении(Элемент)
    
        
        ИнНом = Элементы.ОбъектыПроката.ТекущиеДанные;
        ИнНом.ИнвентарныйНомер = ПолучитьИнвентарныйНомер(ИнНом.ОбъектПроката) ;
        
КонецПроцедуры
и так оно подставляет ИнвНомер только самого первого элемента справочника. Подозреваю, что оно выдает мне первое совпадение с именем объекта
0
Миниатюры
Заполнение реквизита тч документа из справочника   Заполнение реквизита тч документа из справочника  
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
18.11.2016, 00:00 4
Лучший ответ Сообщение было отмечено Melec354 как решение

Решение

1C
1
2
3
4
5
6
7
&НаСервере
Функция ПолучитьИнвентарныйНомер(ОбъектПроката)
 
    ИнвентНом = ОбъектПроката.ИнвентарныйНомер;
    Возврат ИнвентНом;
    
КонецФункции
1
Melec354
0 / 0 / 0
Регистрация: 13.11.2016
Сообщений: 23
18.11.2016, 11:47  [ТС] 5
Спасибо, работает))
0
18.11.2016, 11:47
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.11.2016, 11:47

Получение реквизита из справочника в табличную часть документа
Доброе время суток!Скорее всего мой вопрос очень глупый , но прошу помочь....

Получение реквизита из справочника в табличную часть документа
Помогите пожалуйста! Как только ни пробовала, не могу понять в чем дело.......

Данные реквизита из справочника перенести в реквизит документа
Есть справочник Автомобиль и в нем реквизит ГодВыпуска, нужно чтобы в документе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru