Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/26: Рейтинг темы: голосов - 26, средняя оценка - 5.00
Nick96
6 / 6 / 2
Регистрация: 24.04.2014
Сообщений: 107
1

Передача текущей строки табличной части из клиента на сервер.

06.12.2016, 22:28. Просмотров 5291. Ответов 4
Метки нет (Все метки)

Необходимо перекинуть текущую строку табличной части из Клиента на Сервер. Подскажите, как это возможно? Если через Временное хранилище, то получается ошибка.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
&НаСервере
Процедура ПереченьКоличествоОкончаниеВводаТекстаНаСервере()
ТекДанные = ПолучитьИзВременногоХранилища(ТекДанные);
 
РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;
ОтборПоТовару = Новый Структура ();
ОтборПоТовару.Вставить ("Товар", ТекДанные.Товар);
Данные = РегистрЗаказОстатки.Остатки (, ОтборПоТовару);
Количество = 0;
 
Для каждого Зап из Данные цикл
Количество = Количество + Зап.Количество;
КонецЦикла;
 
Если Количество >= 0 Тогда
Сообщить (Количество);
Иначе 
Сообщить ("Не может быть отрицательного значения! ");
КонецЕсли;
 
КонецПроцедуры
 
&НаКлиенте
Процедура ПереченьКоличествоОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
      ТекДанные = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
       ПоместитьВоВременноеХранилище(ТекДанные);    
    ПереченьКоличествоОкончаниеВводаТекстаНаСервере();
КонецПроцедуры
0
Миниатюры
Передача текущей строки табличной части из клиента на сервер.  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.12.2016, 22:28
Ответы с готовыми решениями:

Ошибка при расчете суммы текущей строки табличной части в управляемой форме документа
Подскажите что не так ? Почему не срабатывает подсчёт? ...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

В табличной части документа выводить историю покупок клиента за все время
нужно в табличной части документа выводить историю покупок клиента за все время программа выводит...

Запрос. Условие: строка из первой табличной части равна любой строке из другой табличной части
Есть документ "РаспределениеМатериаловНаВыпуск". У этого документа имеется "Форма документа". На...

Передача табличной части обработки в запрос
Здравствуйте. Делаю внешнюю обработку для Документооборота. Сделал запрос для вывода просроченных...

4
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
06.12.2016, 23:09 2
Лучший ответ Сообщение было отмечено Nick96 как решение

Решение

Nick96, передавайте в серверную процедуру только нужные поля строки и обойдете без хранилища:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
&НаСервере
Процедура ПереченьКоличествоОкончаниеВводаТекстаНаСервере(Товар)
РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;
ОтборПоТовару = Новый Структура ();
ОтборПоТовару.Вставить ("Товар", Товар);
Данные = РегистрЗаказОстатки.Остатки (, ОтборПоТовару);
Количество = 0;
 
Для каждого Зап из Данные цикл
Количество = Количество + Зап.Количество;
КонецЦикла;
 
Если Количество >= 0 Тогда
Сообщить (Количество);
Иначе 
Сообщить ("Не может быть отрицательного значения! ");
КонецЕсли;
 
КонецПроцедуры
 
&НаКлиенте
Процедура ПереченьКоличествоОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
    ТекДанные = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
    ПереченьКоличествоОкончаниеВводаТекстаНаСервере(ТекДанные.Товар);
КонецПроцедуры
1
Nick96
6 / 6 / 2
Регистрация: 24.04.2014
Сообщений: 107
07.12.2016, 07:11  [ТС] 3
В этом случае появляются следующие ошибки:
0
Миниатюры
Передача текущей строки табличной части из клиента на сервер.  
Nick96
6 / 6 / 2
Регистрация: 24.04.2014
Сообщений: 107
07.12.2016, 08:15  [ТС] 4
А нет, всё отлично! Большое спасибо, GreenkA!)

Добавлено через 49 минут
Цитата Сообщение от GreenkA Посмотреть сообщение
Nick96, передавайте в серверную процедуру только нужные поля строки
И всё же, как передать два параметра? Например, мне нужно передать на Сервер ещё и ТекДанные.Количество.
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
07.12.2016, 10:29 5
Nick96, так же)
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ПереченьКоличествоОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
    ТекДанные = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
    ПереченьКоличествоОкончаниеВводаТекстаНаСервере(ТекДанные.Товар, ТекДанные.Количество);
КонецПроцедуры
 
&НаСервере
Процедура ПереченьКоличествоОкончаниеВводаТекстаНаСервере(Товар, Количество)
...
КонецПроцедуры
1
07.12.2016, 10:29
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.12.2016, 10:29

Передача значение констант в строку табличной части документа
Добрый день!Только начинаю программировать в 1с поэтому прошу помощи более опытных людей....

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru