Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.73/11: Рейтинг темы: голосов - 11, средняя оценка - 4.73
Юрий7788
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 13
1

Заполнение табличной части документа данными из справочника

09.12.2016, 09:44. Просмотров 1941. Ответов 5
Метки нет (Все метки)

Добрый день! Очень нужна ваша помощь ! Есть справочник Должности (на каждую должность список спец средств ) есть табличная часть с такими реквизитами Наименование спец средства,колличество,маркировка и т.д .
Есть документ личная карточка в котором тоже есть табличная часть ,как сделать чтобы при заполнении карточки при выборе профессии табличная часть карточки заполнялась автоматически данными из справочника
Заполнение табличной части документа данными из справочника
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.12.2016, 09:44
Ответы с готовыми решениями:

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...

Заполнение табличной части документа данными из нескольких документов
Здравствуйте! Столкнулась с такой проблемой. Имеется 2 документа: "Акт" и "Ведомость". Документ...

Заполнение табличной части одного документа данными из ТЧ другого
Здравствуйте. Есть 2 документа: 1) "Выдача книги" с табличной частью "Список" с реквизитами...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Из табличной части справочника в табличную часть документа
1С:8.2! Здраствуйте, имеются объекты: 1) справочник "Продукция" реквизиты:"Наименование"(указаны...

5
Joker_vad
Эксперт 1С
473 / 411 / 92
Регистрация: 26.09.2012
Сообщений: 1,844
09.12.2016, 12:20 2
А зачем использовать табличную часть и хранить эту информацию в базе в двух местах? Или она может меняться. А так
При изменении профессии, на сервере через ссылку перебираешь табличную часть и добавляешь в свою табличную часть

1C
1
2
3
4
5
6
7
&НаСервере
Процедура ПриИзмененииПрофессииНаСервере()
Для Каждого Текстр из Объект.Профессия.ТвояТабличнаяЧасть
    НоваяСтрока = Объект.ТабличнаяЧастьДока.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, ТекСтр);//Это если имена реквизитов сопадают, если нет то по реквизитам через равенство
КонецЦикла;
КонецПроцедуры
Имена реквизитов вставляй свои.
0
Юрий7788
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 13
09.12.2016, 12:59  [ТС] 3
Че-то не работает((((

Добавлено через 1 минуту
Че-то не работает(((( а где цикл должен стоять ,(я молодой в 1с)
0
Joker_vad
Эксперт 1С
473 / 411 / 92
Регистрация: 26.09.2012
Сообщений: 1,844
09.12.2016, 13:07 4
Открываете свойства поля с профессией, Выбираете событие при изменении, создаете два события на клиенте и на сервере и в том что на сервере прописываете код по типу того что я предствил
0
Юрий7788
0 / 0 / 0
Регистрация: 27.04.2016
Сообщений: 13
09.12.2016, 15:09  [ТС] 5
Я так и сделал ,только в самом коде где слово цикл? конецЦикла я нашел а где начало?

Добавлено через 18 секунд
спасибо
0
Joker_vad
Эксперт 1С
473 / 411 / 92
Регистрация: 26.09.2012
Сообщений: 1,844
09.12.2016, 15:10 6
а ну да слова цикл нет вот тут
1C
1
2
3
4
5
6
7
&НаСервере
Процедура ПриИзмененииПрофессииНаСервере()
Для Каждого Текстр из Объект.Профессия.ТвояТабличнаяЧасть ЦИКЛ
    НоваяСтрока = Объект.ТабличнаяЧастьДока.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, ТекСтр);//Это если имена реквизитов сопадают, если нет то по реквизитам через равенство
КонецЦикла;
КонецПроцедуры
0
09.12.2016, 15:10
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.12.2016, 15:10

Автозаполнение полей документа, из табличной части справочника
Здравствуйте, столкнулся со следующей проблемой. Необходимо сделать автозаполнение полей документа,...

Заполнение из ексель табличной части справочника
Добрый день. Подскажите пожалуйста, как заполнить табличную часть справочника из ексель, если...

1С запрос из табличной части справочника в табличную часть документа
Здравствуйте! У меня есть справочник "Концерты" с табличной частью "Цены" (1 и 2 рисунки). Строки...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru