Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 105
#1

1C 8.x (тонкий) Выбор значений разных типов из списка - 1С

13.12.2016, 14:00. Просмотров 322. Ответов 7
Метки нет (Все метки)

Всем привет! Создал реквизит в справочнике с составным типом данных (строка,число,булево). Нужно, чтобы можно было выбрать его тип из списка.
А затем этот реквизит принимал выбранный тип и можно было его вбивать.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
    &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Элементы.СпособОценки.РежимВыбораИзСписка = Истина;     
Элементы.СпособОценки.СписокВыбора.ЗагрузитьЗначения(ПолучитьСписокВыбора());
КонецПроцедуры
 
&НаСервере
Функция ПолучитьСписокВыбора()
    
    СписокВыбора = Новый Массив;
    СписокВыбора.Добавить(Тип("Строка"));
    СписокВыбора.Добавить(Тип("Число"));
    СписокВыбора.Добавить(Тип("Булево"));      
    Возврат СписокВыбора;
    
КонецФункции
Делаю так, список открывается, но тип не выбирается. Что еще нужно дописать?
0
Миниатюры
Выбор значений разных типов из списка  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.12.2016, 14:00
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x (тонкий) Выбор значений разных типов из списка (1С):

1C 8.x суммирование разных типов значений - 1С
Надо в печатной форме вывести сумму НДС. Для этого делаю: СуммаНДС = СуммаСНДС * СтавкаНДС / (100 + СтавкаНДС); Проблема в том, что...

1C 8.x Выбор из списка - 1С
Подскажите что не так. Мне нужно вывести в колонку Улицу, дом и корпус Процедура АдресаГРОАдресНачалоВыбораИзСписка(Элемент,...

Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число - 1С
Подскажите в чем ошибка? при попытке перхода в режим пользователя появляется ошибка Операции сравнения на больше-меньше допустимы только...

Выбор документов из списка - 1С
Подскажите пожалуйста, как проверить список документов за определённый период (месяц) на одинаковые реквизиты (сотрудник), чтобы после...

1C 8.x Множественный выбор из списка - 1С
есть форма, в ней списокЗначений регистра. к нему применяется некий отбор или даже множественный выбор. при нажатии на кнопку завершить...

1C 8.x (тонкий) Выбор из динамичного списка - 1С
Нужно решить такую задачку: в документе есть табличная часть и динамический список, привязанный к справочнику с номенклатурами. Необходимо...

Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
GreenkA
Модератор
Эксперт 1С
1677 / 1170 / 393
Регистрация: 25.06.2009
Сообщений: 2,954
13.12.2016, 19:37 #2
Roman2408, а без всего этого, что тип сразу выбирать нельзя?Галочку в свойствах поставьте 'выбирать тип'. Плюс, по-моему, описанный способ работает для обычной формы,а у вас управляемая.
0
Tklwegsd
569 / 416 / 138
Регистрация: 24.07.2013
Сообщений: 1,450
13.12.2016, 21:40 #3
Roman2408, Выбор типа для составного реквизита - это штатный механизм платформы.
Здесь вообще ничего делать не надо, по умолчанию все и так должно работать.
0
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 105
14.12.2016, 10:20  [ТС] #4
Цитата Сообщение от Tklwegsd Посмотреть сообщение
Выбор типа для составного реквизита - это штатный механизм платформы.
Здесь вообще ничего делать не надо, по умолчанию все и так должно работать.
Работает не так, как нужно. Не через выбор из списка, а через поп-ап все работает, но мне надо, чтобы было через список. Штатно через список не вылезает никаких типов для выбора.
Цитата Сообщение от GreenkA Посмотреть сообщение
а без всего этого, что тип сразу выбирать нельзя?Галочку в свойствах поставьте 'выбирать тип'
И так стоит, но не помогает.
Цитата Сообщение от GreenkA Посмотреть сообщение
Плюс, по-моему, описанный способ работает для обычной формы,а у вас управляемая.
Для управляемой работает частично - типы загружаются в список, но когда пытаешься выбрать любой из них ничего не происходит
0
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 105
15.12.2016, 18:46  [ТС] #5
Ну как, никто не знает пути решения данной проблемы?

Добавлено через 5 часов 4 минуты
Все, решил проблему сам. Немного с извратом, правда, но все же работает нормально.
0
renat_dmitriev
93 / 93 / 26
Регистрация: 26.08.2016
Сообщений: 308
15.12.2016, 19:10 #6
Без изврата:

1C
1
2
3
4
5
6
7
8
9
Функция ПолучитьСписокВыбора()
    
    СписокВыбора = Новый Массив;
    СписокВыбора.Добавить("", "Строка");
    СписокВыбора.Добавить(0, "Число");
    СписокВыбора.Добавить(Ложь, "Булево");      
    Возврат СписокВыбора;
    
КонецФункции
1
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 105
16.12.2016, 09:24  [ТС] #7
Цитата Сообщение от renat_dmitriev Посмотреть сообщение
Функция ПолучитьСписокВыбора()
СписокВыбора = Новый Массив;
СписокВыбора.Добавить("", "Строка");
СписокВыбора.Добавить(0, "Число");
СписокВыбора.Добавить(Ложь, "Булево");
Возврат СписокВыбора;
КонецФункции
хорошо еще, если бы это работало. Но в массив можно добавлять значение только с одним параметром. СписокВыбора.Добавить("", "Строка") - не пркоанает. Можно только либо СписокВыбора.Добавить("") либо СписокВыбора.Добавить("Строка");
0
renat_dmitriev
93 / 93 / 26
Регистрация: 26.08.2016
Сообщений: 308
16.12.2016, 21:34 #8
Замените тип на список значений и не загружайте а просто присваивайте
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.12.2016, 21:34
Привет! Вот еще темы с ответами:

1C 8.x Выбрать из списка значений - 1С
как выбрать из списка значений запросом ВЫБРАТЬ список.наименование поместить времтаб ИЗ &списокНоменклатуры как список пишет не...

1C 8.x Множественный выбор в Таблицу значений - 1С
Доброго времени суток УТ 10.3 (Обычное приложение, 8.1) Вопрос такой: Есть ТаблицаЗначений на Форме, в неё добавляется...

Форма документа и выбор значений - 1С
Привет.Знающие люди подскажите. Как при выборе в форме документа коэффициента премирования взять не ячейку из столбца Наименование а ячейку...

Перебор значений динамического списка (1с 8.2, управляемые формы) - 1С
Добрый день всем. Столкнулся с проблемой. В общем задача: Есть два Excel документа. один большой, а другой маленький и у них разная...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
Yandex
Объявления
16.12.2016, 21:34
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru