Форум программистов, компьютерный форум CyberForum.ru

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 98
#1

1C 8.x (тонкий) Выбор значений разных типов из списка - 1С

13.12.2016, 14:00. Просмотров 297. Ответов 7
Метки нет (Все метки)

Всем привет! Создал реквизит в справочнике с составным типом данных (строка,число,булево). Нужно, чтобы можно было выбрать его тип из списка.
А затем этот реквизит принимал выбранный тип и можно было его вбивать.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
    &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Элементы.СпособОценки.РежимВыбораИзСписка = Истина;     
Элементы.СпособОценки.СписокВыбора.ЗагрузитьЗначения(ПолучитьСписокВыбора());
КонецПроцедуры
 
&НаСервере
Функция ПолучитьСписокВыбора()
    
    СписокВыбора = Новый Массив;
    СписокВыбора.Добавить(Тип("Строка"));
    СписокВыбора.Добавить(Тип("Число"));
    СписокВыбора.Добавить(Тип("Булево"));      
    Возврат СписокВыбора;
    
КонецФункции
Делаю так, список открывается, но тип не выбирается. Что еще нужно дописать?
Миниатюры
Выбор значений разных типов из списка  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.12.2016, 14:00     1C 8.x (тонкий) Выбор значений разных типов из списка
Посмотрите здесь:
Выбор из списка 1С 1C 8.x
Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число 1С
1С 1C 8.x Множественный выбор из списка
Выбор из динамичного списка 1С 1C 8.x (тонкий)
1С 1C 8.x Выбрать из списка значений
1С 1C 8.x Отбор записей динамического списка по выбранному значению отбора в виде выпадающего списка
Отбор в таблице значений по условию четных и нечетных значений 1С
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
GreenkA
Модератор
Эксперт 1С
1658 / 1151 / 388
Регистрация: 25.06.2009
Сообщений: 2,899
13.12.2016, 19:37     1C 8.x (тонкий) Выбор значений разных типов из списка #2
Roman2408, а без всего этого, что тип сразу выбирать нельзя?Галочку в свойствах поставьте 'выбирать тип'. Плюс, по-моему, описанный способ работает для обычной формы,а у вас управляемая.
Tklwegsd
543 / 390 / 131
Регистрация: 24.07.2013
Сообщений: 1,365
13.12.2016, 21:40     1C 8.x (тонкий) Выбор значений разных типов из списка #3
Roman2408, Выбор типа для составного реквизита - это штатный механизм платформы.
Здесь вообще ничего делать не надо, по умолчанию все и так должно работать.
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 98
14.12.2016, 10:20  [ТС]     1C 8.x (тонкий) Выбор значений разных типов из списка #4
Цитата Сообщение от Tklwegsd Посмотреть сообщение
Выбор типа для составного реквизита - это штатный механизм платформы.
Здесь вообще ничего делать не надо, по умолчанию все и так должно работать.
Работает не так, как нужно. Не через выбор из списка, а через поп-ап все работает, но мне надо, чтобы было через список. Штатно через список не вылезает никаких типов для выбора.
Цитата Сообщение от GreenkA Посмотреть сообщение
а без всего этого, что тип сразу выбирать нельзя?Галочку в свойствах поставьте 'выбирать тип'
И так стоит, но не помогает.
Цитата Сообщение от GreenkA Посмотреть сообщение
Плюс, по-моему, описанный способ работает для обычной формы,а у вас управляемая.
Для управляемой работает частично - типы загружаются в список, но когда пытаешься выбрать любой из них ничего не происходит
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 98
15.12.2016, 18:46  [ТС]     1C 8.x (тонкий) Выбор значений разных типов из списка #5
Ну как, никто не знает пути решения данной проблемы?

Добавлено через 5 часов 4 минуты
Все, решил проблему сам. Немного с извратом, правда, но все же работает нормально.
renat_dmitriev
93 / 93 / 26
Регистрация: 26.08.2016
Сообщений: 308
15.12.2016, 19:10     1C 8.x (тонкий) Выбор значений разных типов из списка #6
Без изврата:

1C
1
2
3
4
5
6
7
8
9
Функция ПолучитьСписокВыбора()
    
    СписокВыбора = Новый Массив;
    СписокВыбора.Добавить("", "Строка");
    СписокВыбора.Добавить(0, "Число");
    СписокВыбора.Добавить(Ложь, "Булево");      
    Возврат СписокВыбора;
    
КонецФункции
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 98
16.12.2016, 09:24  [ТС]     1C 8.x (тонкий) Выбор значений разных типов из списка #7
Цитата Сообщение от renat_dmitriev Посмотреть сообщение
Функция ПолучитьСписокВыбора()
СписокВыбора = Новый Массив;
СписокВыбора.Добавить("", "Строка");
СписокВыбора.Добавить(0, "Число");
СписокВыбора.Добавить(Ложь, "Булево");
Возврат СписокВыбора;
КонецФункции
хорошо еще, если бы это работало. Но в массив можно добавлять значение только с одним параметром. СписокВыбора.Добавить("", "Строка") - не пркоанает. Можно только либо СписокВыбора.Добавить("") либо СписокВыбора.Добавить("Строка");
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.12.2016, 21:34     1C 8.x (тонкий) Выбор значений разных типов из списка
Еще ссылки по теме:
Объединить несколько значений в таблице значений 1С
1С 1C 8.x суммирование разных типов значений
C (СИ) Запись в память и чтение значений разных типов
C++ Функция swap перестановки значений двух переменных для данных разных типов. Используйте template
MySQL Выбор двух значений из разных строк в одном запросе

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
renat_dmitriev
93 / 93 / 26
Регистрация: 26.08.2016
Сообщений: 308
16.12.2016, 21:34     1C 8.x (тонкий) Выбор значений разных типов из списка #8
Замените тип на список значений и не загружайте а просто присваивайте
Yandex
Объявления
16.12.2016, 21:34     1C 8.x (тонкий) Выбор значений разных типов из списка
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru