Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
CJX
14 / 14 / 4
Регистрация: 26.11.2015
Сообщений: 235
#1

1C 8.x Не проставляется оклад при печати трудового договора - 1С

16.12.2016, 11:21. Просмотров 229. Ответов 0
Метки нет (Все метки)

Привет всем. Есть обработка, которая выводит в doc-файл форму трудового договора. Все данные работают нормально, кроме Оклада. Вне зависимости от выбранного сотрудника - всегда оклад = 0 рублей. Подскажите, пожалуйста, в связи с чем это может быть. Спасибо.

Оклад:
1C
1
2
3
4
5
6
7
8
9
10
ЭтоТарифнаяСтавка = Ложь;
    Оклад = ПолучитьОкладТарифнуюСтавку (Стр.Сотрудник, ЭтоТарифнаяСтавка);
    
    Если НЕ ЭтоТарифнаяСтавка Тогда
        Данные.Вставить ("Оклад", Оклад);
        Данные.Вставить ("ТарифнаяСтавка", "");
    Иначе
        Данные.Вставить ("Оклад", "");
        Данные.Вставить ("ТарифнаяСтавка", Оклад);
    КонецЕсли;
Функция
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Функция ПолучитьОкладТарифнуюСтавку (Сотрудник, ЭтоТарифнаяСтавка)
    Отбор = Новый Структура ("Сотрудник", Сотрудник);
    Начисления = СсылкаНаОбъект.ОсновныеНачисления.НайтиСтроки (Отбор);
    Для Каждого Стр Из Начисления Цикл
        Если Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням Тогда
            ЭтоТарифнаяСтавка = Ложь;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ТарифЧасовой Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        КонецЕсли;
    КонецЦикла;
    
    ЭтоТарифнаяСтавка = Ложь;
    Возврат 0;
КонецФункции // ПолучитьОкладТарифнуюСтавку
Добавлено через 7 минут
Конфигурация ЗУП 2.5

Добавлено через 43 минуты
Конфигурация ЗУП 2.5
Цитата Сообщение от CJX Посмотреть сообщение
Возврат 0;
Всё из-за этого кусочка. Если его вообще убрать - то там вообще нет ничего. При попытке сделать
1C
1
Вовзрат Оклад
выдает ошибку, переменная не определена.

Добавлено через 4 минуты
Всё сделал. Извините за захламление.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.12.2016, 11:21
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x Не проставляется оклад при печати трудового договора (1С):

В 1С. Управление торговлей ред.11.1 при печати ценника не проставляется цена - 1С
Добрый день. Помогите, пожалуйста, разобраться, в чем дело. В 1С. Управление торговлей ред.11.1 при печати ценника не проставляется...

1C 8.x (тонкий) ЗУП 10.3. Не проставляется подразделение при формировании приказа приказа на премию - 1С
Привет. Есть внешний отчет для формирования премиального приказа. Проблема заключается в том, что после формирования, как видно на...

Во всех печатных формах проставляется дата начало года - 1С
Добрый день! Используем управление торговлей 11 версию. На SQL 2008 сервер в терминальном режиме. С сегодняшнего дня на трех клиентских...

1C 8.x 1С ЗУП и форма трудового договора - 1С
Подскажите, существует ли внешняя печатная форма трудового договора, для 1С 8.2 ЗУП, что бы заполнялись все пустые поля, согласно Карточке...

При изменении цены в каталоге, не проставляется цена на странице товара - 1С Битрикс
Добрый день, столкнулся с проблемой, не проставляется цена, при вводе через админку: каталог - элемент - торговый каталог. Меня базовую...

Как при печати отчета программно установить параметры печати? - Visual Basic
как при печати отчета ( VBA ) программно установить параметры печати ( ширину полей )

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.12.2016, 11:21
Привет! Вот еще темы с ответами:

Kyocera FS-1370DN не сохранятся профиль печати при печати из под общего доступа - Принтеры, МФУ
Добрый день уважаемые форумчане !!! в недавнем времени приобрели такой аппарат - Kyocera FS-1370DN. Печать нужна в основном для 1с-ки...

Подсчет трудового стажа - SQL Server
привет всем! помогите плиз, над посчитать стаж работы. :( к примеру на работу приняли 12 мая 2001 ---- а уволили 24 ноября 2008 ===...

Как сделать так, чтобы при выборе любого договора из списка в таблице, изменялись значения edit внизу? - Delphi БД
как сделать так, чтобы когда выбирал любой договор, менялись значения внизу в edit ах? поля переносил из таблиц подключенного...

Расчет трудового стажа сотрудников - MS Access
Всем доброго времени суток. Нужна помощь!!! Есть база расчета стажа сотрудников. В поле период службы, есть 3 строки с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru