Форум программистов, компьютерный форум CyberForum.ru

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
CJX
14 / 14 / 4
Регистрация: 26.11.2015
Сообщений: 228
#1

1C 8.x Не проставляется оклад при печати трудового договора - 1С

16.12.2016, 11:21. Просмотров 209. Ответов 0
Метки нет (Все метки)

Привет всем. Есть обработка, которая выводит в doc-файл форму трудового договора. Все данные работают нормально, кроме Оклада. Вне зависимости от выбранного сотрудника - всегда оклад = 0 рублей. Подскажите, пожалуйста, в связи с чем это может быть. Спасибо.

Оклад:
1C
1
2
3
4
5
6
7
8
9
10
ЭтоТарифнаяСтавка = Ложь;
    Оклад = ПолучитьОкладТарифнуюСтавку (Стр.Сотрудник, ЭтоТарифнаяСтавка);
    
    Если НЕ ЭтоТарифнаяСтавка Тогда
        Данные.Вставить ("Оклад", Оклад);
        Данные.Вставить ("ТарифнаяСтавка", "");
    Иначе
        Данные.Вставить ("Оклад", "");
        Данные.Вставить ("ТарифнаяСтавка", Оклад);
    КонецЕсли;
Функция
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Функция ПолучитьОкладТарифнуюСтавку (Сотрудник, ЭтоТарифнаяСтавка)
    Отбор = Новый Структура ("Сотрудник", Сотрудник);
    Начисления = СсылкаНаОбъект.ОсновныеНачисления.НайтиСтроки (Отбор);
    Для Каждого Стр Из Начисления Цикл
        Если Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням Тогда
            ЭтоТарифнаяСтавка = Ложь;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ТарифЧасовой Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        КонецЕсли;
    КонецЦикла;
    
    ЭтоТарифнаяСтавка = Ложь;
    Возврат 0;
КонецФункции // ПолучитьОкладТарифнуюСтавку
Добавлено через 7 минут
Конфигурация ЗУП 2.5

Добавлено через 43 минуты
Конфигурация ЗУП 2.5
Цитата Сообщение от CJX Посмотреть сообщение
Возврат 0;
Всё из-за этого кусочка. Если его вообще убрать - то там вообще нет ничего. При попытке сделать
1C
1
Вовзрат Оклад
выдает ошибку, переменная не определена.

Добавлено через 4 минуты
Всё сделал. Извините за захламление.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.12.2016, 11:21     1C 8.x Не проставляется оклад при печати трудового договора
Посмотрите здесь:

1C 8.x (тонкий) ЗУП 10.3. Не проставляется подразделение при формировании приказа приказа на премию - 1С
Привет. Есть внешний отчет для формирования премиального приказа. Проблема заключается в том, что после формирования, как видно на...

Адрес при печати документа - 1С
Здравствуйте. Имеется процедура печати в которой адрес собирается в одну строку Процедура Печать(ТабДок, Ссылка) Экспорт ...

Как убрать повторы при печати? - 1С
Здравствуйте, имеется форма с кнопкой, при нажатии на которую создается печатный макет Проблема в том, что в этом макете повторяется...

1C 8.x Группировка в запросе при печати документа. - 1С
Приветствую профи 1С, сам новичок в 1С, хотел бы узнать, как можно получить такой результат, как показан на рисунке (красным)? Делался...

Не применяются настройки печати при предварительном просмотре - 1С
Здравствуйте. Возникла одна проблема. При печати некоторых документов небольшая часть таблицы табличного документа и подвальная часть...

Как привязать Оклад к Должности? - 1С
Нужно сделать так, что бы Оклад был привязан к определенной должности, то есть при приеме на работу человека, при выборе должности, не...

1C 8.x Печать договора из документа - 1С
Добрый день! Нужно осуществить печать договора из документа по кнопке печать. Хотелось бы как-то прикрепить шаблон word-овского договора...

1C 8.x Заполнить из 1С шаблон договора в Excel - 1С
Здравствуйте. Такой вопрос. Есть шаблон договора в Excel, нужно заполнить графы этого договора из 1С. Как это сделать? Загружать договор в...

Функции печати в УТ 11.2 - 1С
Где в УТ 11 находятся функции формирования данных для печати и печатных форм? В УТ 10 открыл модуль нужной формы там все лежит.

1C 8.x Внешняя обработка печати - 1С
Добрый день, не разу не работал со внешней обработкой печати, подскажите что не так. Работаю с УТ 10.3. Поставили мне задачу заменить...

1C 7.x Настройка печати чека для 77 как в 82 - 1С
Здравствуйте. У нас стоит фискальный регистратор компании АТОЛ и установлен его драйвер, подскажите область поиска участка кода который...

1C 8.x Вывод ТЗ на уже созданный макет печати - 1С
На форме документа есть ТЗ СтоимостьУслуг, которая заполняется по кнопке из внешней базы. Данные с этой ТЗ нужно поместить на макет печати...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru