Форум программистов, компьютерный форум CyberForum.ru

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
#1

Разбить период на подпериоды - 1С

20.12.2016, 09:18. Просмотров 330. Ответов 3
Метки нет (Все метки)

Здравствуйте, столкнулся с такой проблемой, есть период с 1.10.16 по 31.10.16, он разбит в таблице значений на дату начала и дату окончания с таким видом:
1.10.16 - 1.10.16;
2.10.16 - 2.10.16;
3.10.16 - 3.10.16;
...и так до 31.10.16, то есть каждый день в новой строке, теперь хочу свернуть этот период по условию, что если была оплата или сумма долга поменялась, хочу что бы свернулся так :
1.10.16 - 12.10.16;
13.10.16 - 23.10.16;
24.10.16 - 31.10.16;
не могу понять как это можно реализовать, подскажите пожалуйста...(
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 09:18     Разбить период на подпериоды
Посмотрите здесь:

1C 8.x Фактический период действия - 1С
Доброго времени суток. Помогите разобраться почему код не работает.НаборЗаписей = РегистрыРасчета.НачиселнияУслуг.СоздатьНаборЗаписей(); ...

1C 8.x (тонкий) Не работает стандартный период - 1С
Добрый день уважаемые форумчане !!! Прошу помощи у гуру ... Раньше по Стандартному периоду вообще не заморачивался - так как постоянно...

Запрос из СКД не выдает период - 1С
Здравствуйте. Проблема такая. В СКД создал запрос, вот его начальная часть: Этот запрос получаю в коде из макета компоноки, и...

1C 8.x Запрос по регистру накопления за период - 1С
Здравствуйте! Создаю запрос по регистру накопления остатки и обороты с параметрами "ДатаНачала" и "ДатаКонца". За выбранный период,...

1C 8.x Реализация отбора за период в регистре сведений - 1С
&НаСервереБезКонтекста Процедура Команда1НаСервере() з =...

1C 8.x про период регистра накопления (почему пустой?) - 1С
ест регистр накопления, тип остатки. подчинен регитсратору, в модуле объекта регистратора в обработкаПроведения пишу ...

После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 837
20.12.2016, 10:34     Разбить период на подпериоды #2
циклом пройдись по таблице
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
20.12.2016, 10:41  [ТС]     Разбить период на подпериоды #3
Цитата Сообщение от SonicQ Посмотреть сообщение
циклом пройдись по таблице
Покажите как, я понимаю что пройтись, то я пройдусь, а вот с условием не очень понимаю, типа
если строка2(значение)<> строка1(значение) тогда
строка1(датаОкончания) = новСтр.ДатаОкончания ...
так типа или нет ?
как правельно поиндексу строку определять, я просто новичек и не очень разбераюсь в этом ..
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.12.2016, 11:31     Разбить период на подпериоды
Еще ссылки по теме:

1C 8.x Как задать единственность записи на период в регистре сведений? - 1С
опять про баранов:) имеется некое измекрение с некоей периодичностью, причем значение этого измерения в течении периода должно быть...

1C 8.x Как достать данные за период из регистра накопления в документ - 1С
Доброго времени суток. У меня есть документ о посещениях детского сада. Из него данные передаются в регистр накопления посещений. Мне нужно...

1C 8.x Отчет в 1С:Бух, который выберет суммы НДС за период по счету 10.05 - 1С
Всем доброго дня. Только начал изучать 1С. Подскажите, что почитать, куда заглянуть, что сделать. Задача: создать новый отчет в 1С:Бух,...

Вывод данных по начислениям за период в табличный документ заданного вида - 1С
Здравствуйте, подскажите как реализовать вывод на макет всех значений обхода результата запроса. По запросу у меня выводит &quot; начисления за...

В отчете вывести заказ-наряды за период, которые не утверждены клиентом - 1С
Всем доброго времени суток. В отчете нужно вывести заказ-наряды за период, которые не утверждены клиентом и не прошли осмотр места, и...

С помощью диаграммы Ганта показать фактический период действия записей с разбивкой по сотрудникам - 1С
Мое решение задачи 3.12. Буду рад услышать критику. Условие ниже: Начисление зарплаты сотрудникам предприятия осуществляется...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 837
20.12.2016, 11:31     Разбить период на подпериоды #4
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
КопияТаблицы = ТаблицаСПериодами.Скопировать();
КопияТаблицы .Очистить();
 
ТекПериод = Дата(1,1,1);
Для каждого Строка из ТаблицаСПериодами цикл
    Если НЕ ЗначениеЗаполнено(ТекПериод) Тогда
        ТекПериод = Строка.ДатаНач;
    КонецЕсли;
    Если Строка.Сумма<>0 Тогда
        НС = КопияТаблицы.Добавить();
        НС.ДатаНач = ТекПериод;
        НС.ДатаКон = Строка.ДатаКон;
        НС.Сумма    = Строка.Сумма;
        ТекПериод = Дата(1,1,1);
    КонецЕсли;
КонецЦикла;
Yandex
Объявления
20.12.2016, 11:31     Разбить период на подпериоды
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru