Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
#1

Разбить период на подпериоды - 1С

20.12.2016, 09:18. Просмотров 366. Ответов 3
Метки нет (Все метки)

Здравствуйте, столкнулся с такой проблемой, есть период с 1.10.16 по 31.10.16, он разбит в таблице значений на дату начала и дату окончания с таким видом:
1.10.16 - 1.10.16;
2.10.16 - 2.10.16;
3.10.16 - 3.10.16;
...и так до 31.10.16, то есть каждый день в новой строке, теперь хочу свернуть этот период по условию, что если была оплата или сумма долга поменялась, хочу что бы свернулся так :
1.10.16 - 12.10.16;
13.10.16 - 23.10.16;
24.10.16 - 31.10.16;
не могу понять как это можно реализовать, подскажите пожалуйста...(
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 09:18
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Разбить период на подпериоды (1С):

Разбить период по дням в запросе - 1С
Как разбить период по дням в запросе? Только так? ВЫБРАТЬ ДОБАВИТЬКДАТЕ(&НачалоПериода, ДЕНЬ, РазностьДат.НомерДняИзДиапазона) КАК...

Период из запроса разбить на начало периода и конец периода - 1С
есть запрос "выбрать оборотыпродажи. период как период из продажиобороты " на выходе имеем поле период которое указывается в...

1C 8.x Период - 1С
1С 8.2 Здравствуйте! Необходимо создать отчет по регистру "Продажи". Должен выбираться период, т.е. данные должны выводиться от такого-то...

Отчет-период - 1С
Здравствуйте, подскажите пожалуйста, как в отчет добавить период, или два параметра для дат, чтобы вывести подходящие значения? период...

период в отчете - 1С
Добрый день. Помогите, пожалуйста. Надо сделать справку о заработной плате. Как правильно сделать период, который будет пользователь...

1C 8.x Ут 10.3 Цены на период - 1С
Всем привет. Ут 10.3 У поставщика в файле(файл присылается) есть строки устанавливающие цены на определенную номенклатуру на...

Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 837
20.12.2016, 10:34 #2
циклом пройдись по таблице
0
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
20.12.2016, 10:41  [ТС] #3
Цитата Сообщение от SonicQ Посмотреть сообщение
циклом пройдись по таблице
Покажите как, я понимаю что пройтись, то я пройдусь, а вот с условием не очень понимаю, типа
если строка2(значение)<> строка1(значение) тогда
строка1(датаОкончания) = новСтр.ДатаОкончания ...
так типа или нет ?
как правельно поиндексу строку определять, я просто новичек и не очень разбераюсь в этом ..
0
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 837
20.12.2016, 11:31 #4
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
КопияТаблицы = ТаблицаСПериодами.Скопировать();
КопияТаблицы .Очистить();
 
ТекПериод = Дата(1,1,1);
Для каждого Строка из ТаблицаСПериодами цикл
    Если НЕ ЗначениеЗаполнено(ТекПериод) Тогда
        ТекПериод = Строка.ДатаНач;
    КонецЕсли;
    Если Строка.Сумма<>0 Тогда
        НС = КопияТаблицы.Добавить();
        НС.ДатаНач = ТекПериод;
        НС.ДатаКон = Строка.ДатаКон;
        НС.Сумма    = Строка.Сумма;
        ТекПериод = Дата(1,1,1);
    КонецЕсли;
КонецЦикла;
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.12.2016, 11:31
Привет! Вот еще темы с ответами:

1C 8.x Период в СКД - 1С
Добрый день! Наверное, я далеко не первая... Но вот такая фигня. Нужно отобрать документы по периоду. В запросе добавила строку ...

Разбить некий временной период - MySQL
Задача, подскажите в каком двигаться на майскле: Есть некий временной интервал t0, t1 : TIME Есть дата-временной период dt0, dt1 :...

Разбиение периода времени на подпериоды - PHP
Есть период времени $start = '10:00'; $end = '12:30'; Как можно разбить время на интервалы по 30 мин, чтоб выводилось: 10:00-10:30 ...

1C 8.x Как сделать отчет по продажам за период (период в колонках) без СКД? - 1С
Всем привет! Покажите, пожалуйста, как сделать отчёт за период, период должен выводиться в колонки, и может быть разным (месяцы, года). ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
Yandex
Объявления
20.12.2016, 11:31
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru