Форум программистов, компьютерный форум CyberForum.ru

Разбить период на подпериоды - 1С

Восстановить пароль Регистрация
 
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
20.12.2016, 09:18     Разбить период на подпериоды #1
Здравствуйте, столкнулся с такой проблемой, есть период с 1.10.16 по 31.10.16, он разбит в таблице значений на дату начала и дату окончания с таким видом:
1.10.16 - 1.10.16;
2.10.16 - 2.10.16;
3.10.16 - 3.10.16;
...и так до 31.10.16, то есть каждый день в новой строке, теперь хочу свернуть этот период по условию, что если была оплата или сумма долга поменялась, хочу что бы свернулся так :
1.10.16 - 12.10.16;
13.10.16 - 23.10.16;
24.10.16 - 31.10.16;
не могу понять как это можно реализовать, подскажите пожалуйста...(
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 09:18     Разбить период на подпериоды
Посмотрите здесь:

Как задать единственность записи на период в регистре сведений? 1С 1C 8.x
1С Запрос из СКД не выдает период
1С 1C 8.x про период регистра накопления (почему пустой?)
1С 1C 8.x Фактический период действия
Как достать данные за период из регистра накопления в документ 1С 1C 8.x
1С С помощью диаграммы Ганта показать фактический период действия записей с разбивкой по сотрудникам
1С 1C 8.x Отчет в 1С:Бух, который выберет суммы НДС за период по счету 10.05
1С В отчете вывести заказ-наряды за период, которые не утверждены клиентом
1С 1C 8.x Запрос по регистру накопления за период
Реализация отбора за период в регистре сведений 1С 1C 8.x
1С 1C 8.x (тонкий) Не работает стандартный период
1С Создание отчета в СКД, разбить таблицу по периодам

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 833
20.12.2016, 10:34     Разбить период на подпериоды #2
циклом пройдись по таблице
zaver
0 / 0 / 0
Регистрация: 12.02.2016
Сообщений: 25
20.12.2016, 10:41  [ТС]     Разбить период на подпериоды #3
Цитата Сообщение от SonicQ Посмотреть сообщение
циклом пройдись по таблице
Покажите как, я понимаю что пройтись, то я пройдусь, а вот с условием не очень понимаю, типа
если строка2(значение)<> строка1(значение) тогда
строка1(датаОкончания) = новСтр.ДатаОкончания ...
так типа или нет ?
как правельно поиндексу строку определять, я просто новичек и не очень разбераюсь в этом ..
SonicQ
160 / 160 / 12
Регистрация: 20.02.2012
Сообщений: 833
20.12.2016, 11:31     Разбить период на подпериоды #4
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
КопияТаблицы = ТаблицаСПериодами.Скопировать();
КопияТаблицы .Очистить();
 
ТекПериод = Дата(1,1,1);
Для каждого Строка из ТаблицаСПериодами цикл
    Если НЕ ЗначениеЗаполнено(ТекПериод) Тогда
        ТекПериод = Строка.ДатаНач;
    КонецЕсли;
    Если Строка.Сумма<>0 Тогда
        НС = КопияТаблицы.Добавить();
        НС.ДатаНач = ТекПериод;
        НС.ДатаКон = Строка.ДатаКон;
        НС.Сумма    = Строка.Сумма;
        ТекПериод = Дата(1,1,1);
    КонецЕсли;
КонецЦикла;
Yandex
Объявления
20.12.2016, 11:31     Разбить период на подпериоды
Ответ Создать тему
Опции темы

Текущее время: 14:29. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru