Форум программистов, компьютерный форум CyberForum.ru

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
#1

1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 - 1С

20.12.2016, 19:15. Просмотров 466. Ответов 5
Метки нет (Все метки)

Здравствуйте. Имеется команда для вывода на печать (ПечатьДопФорм) и два макета печати ПечатьП1, ПечатьП2. На форме документа есть два реквизита (П1 и П2) являющихся флажками - в зависимости от установки флажка, должен выводится на печать соответствующий макет (либо оба макета). Не могу реализовать это в модуле команды, подскажите что поправить?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    //Если Как-тоОбратитьсяКРеквизитуП1 Тогда
    ТабДок = Новый ТабличныйДокумент;
    ПечатьП1(ТабДок, ПараметрКоманды);
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать("Макет1");
    //Иначе
    //ТабДок = Новый ТабличныйДокумент;
    //ПечатьП1(ТабДок, ПараметрКоманды);
    //ТабДок.ОтображатьСетку = Ложь;
    //ТабДок.Защита = Ложь;
    //ТабДок.ТолькоПросмотр = Ложь;
    //ТабДок.ОтображатьЗаголовки = Ложь;
    //ТабДок.Показать("Макет2");
    // КонецЕсли;
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП1(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП1(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП2(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП2(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 19:15
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 (1С):

Вывод на печать - 1С
не получаеться у меня есть дисциплина которая при том что она истина должно добавляться при выводе на печать еще слово(курсовая робота) но...

Вывод на печать номенклатуры с комплектующими - 1С
Здравствуйте! Передо мной стоит задача вывести в печатной форме документа СчетНаОплатуПокупателю номенклатуру с комплектацией. Делаю я...

1C 8.x Учетная политика (вывод на печать) - 1С
Ребят, всё облазила, не могу найти нигде - подскажите, пожалуйста, учетную политику в 1с 8.2 на печать вывести нельзя что ли?

Вывод на печать через макет 1С - 1С
Здравствуйте. Помогите вывести данные в макет. Имеется справочник и документ из которых необходимо взять данные и вывести в один макет..На...

Вывод на печать табличной части - 1С
Здравствуйте! В документе Док есть табл. часть Работник, которая содержит поля Фамилия, Возраст. Есть общий макет. Как из ТЧ вывести...

Вывод на печать данных справочника - 1С
Добрый день, форумчане! У меня в ходе выполнения работы возник вопрос. Поясняю, в чем он заключается: Имеется заполненный справочник...

Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Dethmontt
Модератор
Эксперт 1С
2502 / 2311 / 362
Регистрация: 10.03.2011
Сообщений: 8,104
Записей в блоге: 1
Завершенные тесты: 1
20.12.2016, 23:30 #2
1C
1
Если ПараметрКоманды.П1 = Истина Тогда
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
22.12.2016, 11:23  [ТС] #3
Пишет "поле объекта не обнаружено (П1)"

Добавлено через 1 минуту
П1 и П2 - это реквизиты на форме документа, может он не может к ним обратиться напрямую?

Добавлено через 11 часов 58 минут
Эммм, все? Больше ни у кого идей нет?

Добавлено через 15 часов 26 минут
Кто-нибудь!
renat_dmitriev
93 / 93 / 26
Регистрация: 26.08.2016
Сообщений: 308
22.12.2016, 19:58 #4
zersturen, На клиенте они должны быть доступны напрямую Если П1 Тогда

И непонятно зачем два флажка а не переключатель. Либо де разные команды, что еще проще.
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
23.12.2016, 17:33  [ТС] #5
Не, пробовал напрямую не работает. Процедуры обрабатываются в модуле созданной Команды ПечатьДопФорм документа СчетЗаказ, из этого модуля не могу обратиться напрямую. Про два флажка - смысл заключается в следующем: есть 10 печатных макетов, которые будут выводится в зависимости от того, заполнены данные в реквизитах документа или нет (например, Реквизит ДатаОтгрузки и Реквизит ДатаПолучения, если ДатаОтгрузкизаполнена, то выводится Макет1, если ДатаПолучениязаполнена, то выводится Макет2, если оба реквизита заполнено, то соответственно выводятся оба макета). Флажки я совсем убрал, из-за ненадобности, хочу сделать так, что при нажатии на кнопку ПечатьДопФорм выводились нужные макеты

Добавлено через 20 часов 52 минуты
Все уже на новогодних праздниках что ли?
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
24.12.2016, 17:52  [ТС] #6
В общем, решил проблему сам, засунул все процедуры в модуль формы документа и там отработал необходимые действия, немного подправив код
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.12.2016, 17:52
Привет! Вот еще темы с ответами:

Вывод на печать табличной части справочника. - 1С
Имеется ФормаСписка справочника Выплаты_сотрудникам, и мне нужно вывести на печать вот эти данные которые находятся в табличке. ...

Вывод на печать табличных частей документов - 1С
Здравствуйте Есть документ, в котором две табличные части. В первой ТЧ: Работник и ДатаРождения Во второй ТЧ: Работник и Фактор ...

Подстановка данных в Word и вывод на печать - 1С
Так и не могу понять ,как сделать подстановку данных в документ. Надо сделать через "двоичные данные". Создал макет...

1С8.2 - Вывод на печать из поля HTML - 1С
Друзья, доброго времени суток! Очень нужна ваша помощь! Стоит задача: напечатать документ так, чтобы с точностью до мм нужные реквизиты...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
Yandex
Объявления
24.12.2016, 17:52
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru