Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 166
1

Вывод на печать с условием 1С 8.3

20.12.2016, 19:15. Просмотров 1179. Ответов 5
Метки нет (Все метки)

Здравствуйте. Имеется команда для вывода на печать (ПечатьДопФорм) и два макета печати ПечатьП1, ПечатьП2. На форме документа есть два реквизита (П1 и П2) являющихся флажками - в зависимости от установки флажка, должен выводится на печать соответствующий макет (либо оба макета). Не могу реализовать это в модуле команды, подскажите что поправить?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    //Если Как-тоОбратитьсяКРеквизитуП1 Тогда
    ТабДок = Новый ТабличныйДокумент;
    ПечатьП1(ТабДок, ПараметрКоманды);
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать("Макет1");
    //Иначе
    //ТабДок = Новый ТабличныйДокумент;
    //ПечатьП1(ТабДок, ПараметрКоманды);
    //ТабДок.ОтображатьСетку = Ложь;
    //ТабДок.Защита = Ложь;
    //ТабДок.ТолькоПросмотр = Ложь;
    //ТабДок.ОтображатьЗаголовки = Ложь;
    //ТабДок.Показать("Макет2");
    // КонецЕсли;
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП1(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП1(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП2(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП2(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 19:15
Ответы с готовыми решениями:

Вывод и печать слов с условием
Найти и вывести на печать слова, у которых первая буква входит в слово еще раз. Черт, уже второй...

Макрос Excel. Вывод на печать с условием
Здравствуйте. Написал макрос - выводит на лист информацию в виде блоков, по 4 строки. Вот так:...

Печать отчетов с условием
Добрый всем день. На форме кнопка ,которая выводит отчеты из двух подчиненных таблиц. Возможно ли...

Вывод с условием
Как вывести только те значения которые в combobox ????Помогите пожалуйста using (SqlConnection...

Вывод строки с условием
Имеет текстовый файл, из которого считывается информация, необходимо дописать условие так чтобы...

5
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,799
Записей в блоге: 1
Завершенные тесты: 1
20.12.2016, 23:30 2
1C
1
Если ПараметрКоманды.П1 = Истина Тогда
0
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 166
22.12.2016, 11:23  [ТС] 3
Пишет "поле объекта не обнаружено (П1)"

Добавлено через 1 минуту
П1 и П2 - это реквизиты на форме документа, может он не может к ним обратиться напрямую?

Добавлено через 11 часов 58 минут
Эммм, все? Больше ни у кого идей нет?

Добавлено через 15 часов 26 минут
Кто-нибудь!
0
renat_dmitriev
390 / 292 / 121
Регистрация: 26.08.2016
Сообщений: 901
22.12.2016, 19:58 4
zersturen, На клиенте они должны быть доступны напрямую Если П1 Тогда

И непонятно зачем два флажка а не переключатель. Либо де разные команды, что еще проще.
0
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 166
23.12.2016, 17:33  [ТС] 5
Не, пробовал напрямую не работает. Процедуры обрабатываются в модуле созданной Команды ПечатьДопФорм документа СчетЗаказ, из этого модуля не могу обратиться напрямую. Про два флажка - смысл заключается в следующем: есть 10 печатных макетов, которые будут выводится в зависимости от того, заполнены данные в реквизитах документа или нет (например, Реквизит ДатаОтгрузки и Реквизит ДатаПолучения, если ДатаОтгрузкизаполнена, то выводится Макет1, если ДатаПолучениязаполнена, то выводится Макет2, если оба реквизита заполнено, то соответственно выводятся оба макета). Флажки я совсем убрал, из-за ненадобности, хочу сделать так, что при нажатии на кнопку ПечатьДопФорм выводились нужные макеты

Добавлено через 20 часов 52 минуты
Все уже на новогодних праздниках что ли?
0
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 166
24.12.2016, 17:52  [ТС] 6
В общем, решил проблему сам, засунул все процедуры в модуль формы документа и там отработал необходимые действия, немного подправив код
0
24.12.2016, 17:52
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.12.2016, 17:52

Вывод отчета с условием
Пробую вывести отчет, есть два запроса на вывод в DBgrid список получающих социальную стипендию и...

Вывод на экран с условием
Как вывести на экран список сотрудников, так, чтобы если в имени встречается буква А система ...

Вывод списка с условием
Заданиесостоит в том, чтобы реализовать очередь(функции добавления, изъятия и вывода на экран...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru