Форум программистов, компьютерный форум CyberForum.ru

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
#1

1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 - 1С

20.12.2016, 19:15. Просмотров 287. Ответов 5
Метки нет (Все метки)

Здравствуйте. Имеется команда для вывода на печать (ПечатьДопФорм) и два макета печати ПечатьП1, ПечатьП2. На форме документа есть два реквизита (П1 и П2) являющихся флажками - в зависимости от установки флажка, должен выводится на печать соответствующий макет (либо оба макета). Не могу реализовать это в модуле команды, подскажите что поправить?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    //Если Как-тоОбратитьсяКРеквизитуП1 Тогда
    ТабДок = Новый ТабличныйДокумент;
    ПечатьП1(ТабДок, ПараметрКоманды);
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать("Макет1");
    //Иначе
    //ТабДок = Новый ТабличныйДокумент;
    //ПечатьП1(ТабДок, ПараметрКоманды);
    //ТабДок.ОтображатьСетку = Ложь;
    //ТабДок.Защита = Ложь;
    //ТабДок.ТолькоПросмотр = Ложь;
    //ТабДок.ОтображатьЗаголовки = Ложь;
    //ТабДок.Показать("Макет2");
    // КонецЕсли;
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП1(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП1(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
 
&НаСервере
Процедура ПечатьП2(ТабДок, ПараметрКоманды)
    
    Документы.СчетЗаказ.ПечатьП2(ТабДок, ПараметрКоманды);
    
КонецПроцедуры
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.12.2016, 19:15     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3
Посмотрите здесь:

1С 1C 8.x Печать договора из документа
1С Печать системной даты
1С 1C 8.x Запрос с заполнением данных( с двойным условием выборки)
Множественная печать 1С 1C 8.x (тонкий)
Печать табличного документа 1С 1C 8.x
Запрос с множественным условием 1С 1C 8.x
Печатная форма с условием 1С
Групповая печать документов 1С 1C 8.x
Вывод на печать данных справочника 1С
1С Вывод на печать через макет 1С
Печать макета 1С 1C 8.x
1С 1C 8.x Печать пакета документов

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Dethmontt
Модератор
Эксперт 1С
2377 / 2186 / 325
Регистрация: 10.03.2011
Сообщений: 7,652
Записей в блоге: 1
Завершенные тесты: 1
20.12.2016, 23:30     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 #2
1C
1
Если ПараметрКоманды.П1 = Истина Тогда
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
22.12.2016, 11:23  [ТС]     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 #3
Пишет "поле объекта не обнаружено (П1)"

Добавлено через 1 минуту
П1 и П2 - это реквизиты на форме документа, может он не может к ним обратиться напрямую?

Добавлено через 11 часов 58 минут
Эммм, все? Больше ни у кого идей нет?

Добавлено через 15 часов 26 минут
Кто-нибудь!
renat_dmitriev
92 / 92 / 26
Регистрация: 26.08.2016
Сообщений: 308
22.12.2016, 19:58     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 #4
zersturen, На клиенте они должны быть доступны напрямую Если П1 Тогда

И непонятно зачем два флажка а не переключатель. Либо де разные команды, что еще проще.
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
23.12.2016, 17:33  [ТС]     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 #5
Не, пробовал напрямую не работает. Процедуры обрабатываются в модуле созданной Команды ПечатьДопФорм документа СчетЗаказ, из этого модуля не могу обратиться напрямую. Про два флажка - смысл заключается в следующем: есть 10 печатных макетов, которые будут выводится в зависимости от того, заполнены данные в реквизитах документа или нет (например, Реквизит ДатаОтгрузки и Реквизит ДатаПолучения, если ДатаОтгрузкизаполнена, то выводится Макет1, если ДатаПолучениязаполнена, то выводится Макет2, если оба реквизита заполнено, то соответственно выводятся оба макета). Флажки я совсем убрал, из-за ненадобности, хочу сделать так, что при нажатии на кнопку ПечатьДопФорм выводились нужные макеты

Добавлено через 20 часов 52 минуты
Все уже на новогодних праздниках что ли?
zersturen
0 / 0 / 1
Регистрация: 12.03.2012
Сообщений: 152
24.12.2016, 17:52  [ТС]     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3 #6
В общем, решил проблему сам, засунул все процедуры в модуль формы документа и там отработал необходимые действия, немного подправив код
Yandex
Объявления
24.12.2016, 17:52     1C 8.x (тонкий) Вывод на печать с условием 1С 8.3
Ответ Создать тему
Опции темы

Текущее время: 04:22. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru