Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
juristbrn
2 / 2 / 2
Регистрация: 21.04.2014
Сообщений: 213
#1

Зашифровать модуль используя СЛК - 1С

26.12.2016, 10:52. Просмотров 331. Ответов 1
Метки нет (Все метки)

Подскажите, как зашифровать с помощью слк объекты. Перенес в свою конфу нужные общие модули(СЛК,МенеджерОбъектовСЛК) Слк и т.д . Дальше я должен в модулях объекта что-то прописывать для проверки ключа? Не совсем понял документацию ....

Допустим надо отчет закрыть то в модуле объекта или менеджера надо писать что-то подобное?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
// Ссылка на менеджер объектов, который создал этот объект, получена 
// в предопредленной процедуре "ПриСозданииОбъекта"
Перем _менеджерОбъектов;
 
//
// Предопределенная процедура, вызывающаяся при создании объекта методом "СоздатьОбъект"
//
// Позволяет разработчику запретить создание обаботки, для чего 
// необходимо установить значение параметра "Отказ" в "Истина"
//
// МенеджерЛицензий - ссылка на менеджре лицензий, которым создан объект
// Отказ            - признак запрета создания
// ОписаниеОшибки   - описание ошибки, устанавливаемое разработчиком в случае запрета 
// создания объекта
// 
// В этой процедуре рекомендуется проверять значения лицензионных 
// параметров и в зависимости от них разрешить или запретить создание 
// объекта.
//
Процедура ПриСозданииОбъекта(МенеджерОбъектов, Отказ, ОписаниеОшибки) Экспорт
    _менеджерОбъектов = МенеджерОбъектов;
КонецПроцедуры
 
//
// Предопределенная процедура, вызывающаяся при создании объекта методом 
// "СоздатьОбъект" перед проверкой лицензии сеанса
//
// Позволяет разработчику отказаться от проверки лицензии, для чего 
// необходимо установить значение параметра "Отказ" в "Истина".
//
// Используется в случае когда достаточно только защитить код и данные объекта и 
// нет необходимости в контроле лицензий
//
Процедура ПередКонтролемЛицензии(Отказ) Экспорт
    Отказ = Ложь;
КонецПроцедуры
 
//
// Предопределенная процедура, вызывающаяся при создании объекта методами 
// "Создать" и "СоздатьПоСсылке"
//
Процедура ПриСоздании(МенеджерЛицензий, КлиентскаяСылка, Отказ, ОписаниеОшибки) Экспорт
    // Контроль лицензий сеанса выполняется при создании объекта методом 
    // "СоздатьОбъект". 
    //
    // Чтобы объект было невозможно создать старвми методами без контроля 
    // лицензий сеанса запрещаем создание
    Отказ = Истина;
КонецПроцедуры
 
//
// Пример функции, использующей значение лицензионного параметра. Для получения 
// значения используется менеджер объектов, установленный в предопредленной 
// процедуре "ПриСозданииОбъекта" (см. выше)
//
Функция МетодОбъекта() Экспорт
    Стр = 
      ЭтотОбъект.Метаданные().ПолноеИмя() + Символы.ПС +
      "Ключ = " + Строка(_менеджерОбъектов.ПолучитьНомерКлюча()) +
      ", ТипПриложения=" + _менеджерОбъектов.ПолучитьЗначениеПараметра("ТипПриложения");
    Возврат Стр;
КонецФункции
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.12.2016, 10:52
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Зашифровать модуль используя СЛК (1С):

Создайте модуль, в котором будет храниться процедура создания следующей картинки. Используя модуль, поместите картинку по углам экрана и в центре. - Pascal ABC
Помогите пожалуйста Создайте модуль, в котором будет храниться процедура создания следующей картинки. Используя модуль, поместите...

Зашифровать файл, используя исключающее или - C++
Здравствуйте. Задача: Есть файл, в котором записаны какие-то символы. Надо поочередно брать каждый символ и менять в нем 1 на 0...

Зашифровать текст, используя перемешанный алфавит. - Pascal
Зашифровать заданный текст (не более 255 символов ) используя один перемешанный алфавит, полученный случайной перестановкой всех букв...

Как зашифровать информацию, используя XOR - Visual Basic
А можно об этом подробнее. Спасибо за ответ.

Используя треугольник паскаля, зашифровать исходное предложение - C++
Задание 2: 1)Запросить у пользователя максимально возможную по условиям длинну LenMax строки. 2)Создать динамический символьный...

Зашифровать исходное предложение используя треугольник Паскаля - C#
C клавиатуры вводится предложение, слова в котором разделены символом ‘_’. Используя треугольник Паскаля зашифруйте исходное предложение по...

1
Dethmontt
Модератор
Эксперт 1С
2525 / 2333 / 376
Регистрация: 10.03.2011
Сообщений: 8,186
Записей в блоге: 1
Завершенные тесты: 1
26.12.2016, 14:25 #2
juristbrn, ну наверное объекта, мы же не знаем что ты хочешь защитить ))))
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.12.2016, 14:25
Привет! Вот еще темы с ответами:

Зашифровать текст, используя таблицу ASCII-кодов - C++
Помогите зашифровать данный текст, используя таблицу ASCII-кодов: Компилятор. Добавлено через 7 минут #include <iostream> ...

Зашифровать сообщение, используя шифр Цезаря со сдвигом k - C#
В шифре Цезаря алфавит размещается на круге по часовой стрелке. За последней буквой алфавита идет первая буква алфавита, т.е. после буквы...

Зашифровать текстовый файл, используя метод обратного чтения - Free Pascal
создать текстовый файл.зашифровать его,используя метод обратного чтения.

Зашифровать данный текст, используя таблицу ASCII-кодов - Программирование iOS
1. Зашифровать данный текст, используя таблицу ASCII-кодов: Информатика Решение – 136 173 228 174 224 172 160 226 168 170/ ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru