С Новым годом! Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Corwin707
0 / 0 / 1
Регистрация: 20.01.2015
Сообщений: 43
#1

Запись в ячейку макета табличного документа - 1С

03.01.2017, 15:23. Просмотров 392. Ответов 1

Добрый день. Формирую в цикле значения ячеек табличного документа, значение записывается в макет, на вывод я ничего не получаю.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
        ОбластьМакета=Макет.ПолучитьОбласть("ТиражПервыйБезНДССтрока");
        Для Каждого ЗначениеРент из Рентабельности Цикл
            ОбластьМакета.Параметры.РентабельностьРасчет=ЗначениеРент;
            РасчетТекущий=Расчет;
            РасчетТекущий.Вставить("Рентабельность",ЗначениеРент);
            Для К=2 по 11 Цикл
                ЯчейкаЦены=ОбластьМакета.Область(1,К);
                Если Тиражи[К-2]>0 Тогда
                    РасчетТекущий.Вставить("Тираж",Тиражи[К-2]);            
                    РасчетКалькуляции.Расчитать(РасчетТекущий);
                    ЗначениеЦены=(((Расчет.СтоимостьПечати+Расчет.СтоимостьРолевогоМатериала+Расчет.СтоимостьЛКМ)*(1+ЗначениеРент/100)+Расчет.СтоимостьУпаковки+Расчет.ДопечатнаяПодготовка)/Тиражи[К-2])*100;
                    ОбластьМакета.Область(1,К).Текст=ЗначениеЦены;
                КонецЕсли;
            КонецЦикла;
            Таб.Вывести(ОбластьМакета);
Если же я пишу напрямую в табличный документ без макета, все пишется, но в результатах нет форматирования ячеек. То, что я записываю через параметры, выводится нормально.

Добавлено через 2 часа 47 минут
Пришлось поизвращаться со структурами, сделал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
    ЗаполнитьМассивы(Рентабельности,Тиражи);
    ОбластьМакета.Параметры.Заполнить(Тиражи);
 
Процедура ЗаполнитьМассивы(Массив_Рентабельности,Тиражи);//,Рентабельность,Тираж)
    Элемент=Новый Структура;
    Элемент.Вставить("Тираж");
    Элемент.Вставить("Колонка");
    Для К=0 По 6 Цикл
        Массив_Рентабельности[К]=?(К<3,Рентабельность-5*(3-К),Рентабельность+10*(К-3));
    КонецЦикла; 
    Элемент=Новый Структура;
    Для К=0 По 10 Цикл
        ЗначениеТиража=?(К<5,?((Тираж-ШагТиражВниз*(5-К))>0,Тираж-ШагТиражВниз*(5-К),0),?((Тираж+ШагТиражВверх*(К-5))>0,Тираж+ШагТиражВверх*(К-5),0));
        Элемент.Вставить("Тираж"+(К+1),ЗначениеТиража);
    КонецЦикла; 
    Тиражи=Элемент;
КонецПроцедуры
Процедура
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.01.2017, 15:23
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Запись в ячейку макета табличного документа (1С):

1C 8.x Печать табличного документа - 1С
Всем привет! Создал обработку заполнения табличных частей докумета,в которую добавил две ТЧ.Из одной из них (ТЧ1),по задумке,номенклатура...

Сохранение табличного документа в файл - 1С
Ситуация какая то шаманская. База SQL крутится на сервере Есть процедура глСохранитьТаблицуВФайл находящаяся в общем модуле...

1C 8.x Сохранение табличного документа в pdf - 1С
Добрый день! При сохранении табличного документа в pdf-файл слетает выравнивание текста по ширине. В макете везде установлено равнение по...

Изменения размера табличного документа - 1С
Добрый день. Коллеги программисты нужна помощь. Есть задача: Необходимо реализовать обработку по печати ярлыков номенклатуры, при...

1C 8.x Удалить области табличного документа - 1С
Добрый вечер. Такая проблема: есть документ &quot;прием специалиста&quot;, где пациенту назначают план лечения, и одно из назначений, например,...

Активизировать поле табличного документа - 1С
проблема. сделал отчет с собственной расшифровкой, неограниченный уровень вложенносчти отрабаотывает, две таблицы выводит диаграмму...

1
Kawa_Cykan
Заблокирован
07.01.2017, 03:16 #2
а что в самой выводимой области?
верни массив областей и посмотри их на клииенте.
таб доки - это морока еще та.
помню чета было не раотало когда пишешь
область= макет.получитьобласть("область")
и чета с этой областью было не так.
при том что переменной "область" заведомо не было.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.01.2017, 03:16
Привет! Вот еще темы с ответами:

1C 8.x Редактирование формата табличного документа - 1С
Всем привет. Дело вот в чём. Есть таблица, в которой есть лишние данные (выделены на скрине) Их удалил программно, поэтому при печати...

1C 8.x (тонкий) Вывод области табличного документа в цикле - 1С
Приветствую, господа форумчане. Не могу исправить кусочек кода, уже перепробовал множество вариантов. Суть в следующем: у номенклатуры есть...

1C 8.x Открыть форму и заполнить поле табличного документа - 1С
Привет, народ! подскажите, как открыть форму программно , сформировать макет и выводить этот макет в табличное поле на этой форме? ...

1C 8.x Расшифровка ячейки табличного документа, созданного программно - 1С
Всем привет. Есть печатная форма, которая формируется программно от и до. нет ни макетов, ни табличного документа на форме. ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.