Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Volexovich
199 / 175 / 29
Регистрация: 24.10.2011
Сообщений: 696
1

Создание универсальной обработки для различных конфигураций

13.01.2017, 13:08. Просмотров 865. Ответов 6
Метки нет (Все метки)

Задача: Пишу обработку накладных и хочу сделать ее универсальной, одна из ее задач проведение документов. Документы стандартные реализация и счет-фактура.
Но так как в "Бухгалтерских" конфигурациях необходимо проставлять счета в табличную часть, то соответственно необходимо и запускать функции которых нет в "торговых" конфигурациях.

Вопрос: Как можно разделить код в зависимости от типа конфигурации, что бы можно было написать универсальную обработку и в "торговлях" не ругался на глобальные функции присущие "бухгалтериям"?
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.01.2017, 13:08
Ответы с готовыми решениями:

Создание обработки для проверки позиций сайта в яндексе и гугле.
Добрый день! Я только учусь по этому прошу помощи у знающих людей....

печатная форма для универсальной формы подбора объектов
Здравствуйте,хотелось бы узнать в 1С бухгалтерии 7.7 в сервисе-дополнительных...

Что нужно для разработки 1С конфигураций?
решил заняться 1С программированием, но не знаю че качать для этого. гугл...

Виды конфигураций 1С: в чем различия(для программиста)?
Всем доброго времени суток. Народ, можете объяснить, я немного занялся...

можно ли сделать 1С сетевой для разных конфигураций???
Доброе время суток. Вообщем, задача такая: два компа (локалка), на одном...

6
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
13.01.2017, 13:50 2
1C
1
2
Если подститема есть Тогды
ОбщийМодуль.Найти("МодульБухни")
0
Volexovich
199 / 175 / 29
Регистрация: 24.10.2011
Сообщений: 696
13.01.2017, 14:34  [ТС] 3
Неудачно видимо выразился. Если в модуле будет вызов
1C
1
СчетаУчетаВДокументах.ИнтерактивноПерезаполнитьСчетаУчета(....
, то при запуске в торговле модуль сообщит об ошибке, нет там модуля "СчетаУчетаВДокументах".
Я конечно обошел это тупо перегрузив десяток функций, но хотелось бы знать есть у кого опыт по обходу данной проблемы или это невозможно?
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
13.01.2017, 14:49 4
Volexovich, удачно.

Добавлено через 27 секунд
1C
1
2
3
    Метаданные.ОбщиеМодули.Найти("СчетаУчетаВДокументах");
    
    Метаданные.Подсистемы.Найти("БухгалтерскийУчет");
0
Volexovich
199 / 175 / 29
Регистрация: 24.10.2011
Сообщений: 696
13.01.2017, 16:07  [ТС] 5
Dethmontt, а как я через метаданные вызову функцию найденного модуля?
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
13.01.2017, 16:29 6
Лучший ответ Сообщение было отмечено Volexovich как решение

Решение

Volexovich, ну или как в типовых сделай

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
// Возвращает ссылку на общий модуль по имени.
//
// Параметры:
//  Имя          - Строка - имя общего модуля, например:
//                 "ОбщегоНазначения",
//                 "ОбщегоНазначенияКлиент".
//
// Возвращаемое значение:
//  ОбщийМодуль.
//
Функция ОбщийМодуль(Имя) Экспорт
    
    Модуль = Вычислить(Имя);
    
#Если НЕ ВебКлиент Тогда
    Если ТипЗнч(Модуль) <> Тип("ОбщийМодуль") Тогда
        ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Общий модуль ""%1"" не найден.'"), Имя);
    КонецЕсли;
#КонецЕсли
    
    Возврат Модуль;
    
КонецФункции
1
Volexovich
199 / 175 / 29
Регистрация: 24.10.2011
Сообщений: 696
13.01.2017, 16:49  [ТС] 7
Цитата Сообщение от Dethmontt Посмотреть сообщение
Модуль = Вычислить(Имя);
Огромное спасибо, это то что я искал!)
0
13.01.2017, 16:49
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
13.01.2017, 16:49

Создание внешней обработки 2.0
В документе Отчет о розничных продажах на основании уже вбитой номенклатуры по...

Создание внешней обработки документа
Добрый день! Мне необходимо создать документ КС-2 в 1С:Бухгалтерия 8.2. ...

Создание счёта из внешней обработки
Добрый день. Пишу внешнюю обработку для 1С 8.1:Предприятие. В ходе этой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru