Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
kokoz9br
0 / 0 / 1
Регистрация: 01.05.2012
Сообщений: 56
1

Запрос с параметром

13.01.2017, 23:49. Просмотров 587. Ответов 4
Метки нет (Все метки)

Хочу получить запросом запись из справочника. Конкретную запись получаю через параметр. Потом запросом заполняю макет.На нем есть кнопка и реквизит "Цель"
Но проблема в том,что запрос в результате оказывается пустой. Подскажите,как решить проблему?!

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
        
&НаКлиенте
Процедура СформироватьОтчет(Команда)
    ЗаполнитьТабДок(ТабДок,Цель);
КонецПроцедуры
 
 
&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок,Цель)
    
    ТабДок.Очистить();
    Макет = Отчеты.ТестовыйОтчет.ПолучитьМакет("Макет");
    
    ОблШапка = Макет.ПолучитьОбласть("Шапка");
    ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
    
    ОблШапка.Параметры.ДатаОтчета = Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy; ДЛФ=DDT");
    ТабДок.Вывести(ОблШапка);
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ПрограммыТренировок.Программа.Реквизит1,
                   |    ПрограммыТренировок.Ссылка
                   |ИЗ
                   |    Справочник.ПрограммыТренировок КАК ПрограммыТренировок
                   |ГДЕ
                   |    ПрограммыТренировок.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка",Цель);
    Результат = Запрос.Выполнить();
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        ОблЭлемент.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(ОблЭлемент);
    КонецЦикла;
    
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.01.2017, 23:49
Ответы с готовыми решениями:

Запрос с параметром
Здравствуйте, уважаемые форумчане! Помогите пожалуйста написать запрос по...

Отчет с параметром
Всем добрый вечер! У меня такая проблема: есть некий созданный документ в...

Создание отчета с параметром
При формировании отчета ругается на строку...

1cv77 ТиС вызов отчета с параметром.
Здравствуйте..я только встал на путь изучения 1с и сразу возникла проблема....

Отобрать с параметром по номенклатуре и серийному номеру все документы
Я делаю отчет, в процессе выполнения выяснилось, что на стандартных 1С запросах...

4
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
14.01.2017, 06:02 2
kokoz9br, значит что-то не так с параметром запроса...
В вашем случае запрос вообще не нужен, если Цель - и есть ссылка на справочник ПрограммыТренировок, значение реквизита получайте как Цель.Программа.Реквизит1. Только может Программа - это табличная часть, а не реквизит справочника?
Лучше выложите вашу базу, посмотрим, что не так)
0
kokoz9br
0 / 0 / 1
Регистрация: 01.05.2012
Сообщений: 56
14.01.2017, 12:39  [ТС] 3
Цель- это ссылка на перечисление.

Отчет - ТестовыйОтчет
0
Вложения
Тип файла: rar 1Cv8 Диплом маг 14012017.rar (1.21 Мб, 0 просмотров)
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
15.01.2017, 03:47 4
Цитата Сообщение от kokoz9br Посмотреть сообщение
ПрограммыТренировок.Ссылка = &Ссылка";
А почему твоя программа тренировок должны ровняться с целью?
Цитата Сообщение от kokoz9br Посмотреть сообщение
Запрос.УстановитьПараметр("Ссылка",Цель);
0
kokoz9br
0 / 0 / 1
Регистрация: 01.05.2012
Сообщений: 56
15.01.2017, 12:15  [ТС] 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
А почему твоя программа тренировок должны ровняться с целью?
В справочнике ПрограммыТренировок записаны все варианты программ для различных целей(сушка,набор массы,похудение и т.д.). Соответственно в у каждой записи есть своя ТЧ и самой программой.

Есть перечисление, в которую предопределил эти самые цели(сушка,набор массы,похудение и т.д.).

Количество перечислений будет совпадать с количеством записей в справочнике.

Мне нужно при выборе цели получить данные ТЧ,чтобы вывести в макет.
0
15.01.2017, 12:15
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.01.2017, 12:15

7.7 Запрос или бухгалтерский запрос?
Добрый день. Задача такова: необходимо сформировать отчет о доходах и расходах...

Запрос с параметром
Здравствуйте, имеется БД с тремя таблицами, на основе одной таблицы (cloub)...

Запрос с параметром
Добрый день! Как в MS SQL Server реализовать запрос с параметром, чтобы...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru