Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
CJX
14 / 14 / 4
Регистрация: 26.11.2015
Сообщений: 235
1

Ломбард. Добавление параметра в печатную форму

16.01.2017, 09:38. Просмотров 711. Ответов 1
Метки нет (Все метки)

Здравствуйте. Есть внешняя обработка с анкетой физического лица, которую надо немного отредактировать. Макет печатной формы содержится в Word-файле. Рядом с датой рождения должно указываться и место рождения. Данная инфа находится в справочнике Контрагенты. Ну и, соответственно, информация об отдельном залогодателе находится в форме элемента.
Ломбард. Добавление параметра в печатную форму
- в ПолеКИ8 находится информация о месте рождения, как раз. Там обычная строка.
"Полный код процедуры ПодготовкаКОтображению в модуле формы элемента
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
Процедура ПодготовкаКОтображениюКИ()
 
    мСтруктураРедактированияКИ = УправлениеКонтактнойИнформацией.ПодготовитьСтруктуруДляОтображенияКИ(
            Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты,
            Новый Действие("НажатиеДопКнопкиКИ"),
            НаборКонтактнойИнформации,
            ЭлементыФормы.Панель,
            ЭлементыФормы.Панель.Страницы.КонтактнаяИнформация,
            Неопределено,
            ЭлементыФормы.ПолеВводаПрочаяКИ,
            Справочники.ВидыКонтактнойИнформации.ДругаяИнформацияКонтрагента,
            Неопределено,
            Ложь
        );
    // Ломбард +
    ТаблицаНастроек = мСтруктураРедактированияКИ.Настройки;
    СтрокаНастройки = ТаблицаНастроек.Найти(ЛМБ_ОбщегоНазначенияПереопределяемый.НайтиСоздатьВидКонтактнойИнформации("Дата рождения", Перечисления.ТипыКонтактнойИнформации.Другое, Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты), "Вид");
    Если Не СтрокаНастройки = Неопределено И ТаблицаНастроек.Количество() > 3 Тогда
        ТаблицаНастроек.Сдвинуть(СтрокаНастройки, 3 - ТаблицаНастроек.Индекс(СтрокаНастройки));
    КонецЕсли;
    СтрокаНастройки = ТаблицаНастроек.Найти(ЛМБ_ОбщегоНазначенияПереопределяемый.НайтиСоздатьВидКонтактнойИнформации("Серия паспорта", Перечисления.ТипыКонтактнойИнформации.Другое, Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты), "Вид");
    Если Не СтрокаНастройки = Неопределено И ТаблицаНастроек.Количество() > 4 Тогда
        ТаблицаНастроек.Сдвинуть(СтрокаНастройки, 4 - ТаблицаНастроек.Индекс(СтрокаНастройки));
    КонецЕсли;
    СтрокаНастройки = ТаблицаНастроек.Найти(ЛМБ_ОбщегоНазначенияПереопределяемый.НайтиСоздатьВидКонтактнойИнформации("Номер паспорта", Перечисления.ТипыКонтактнойИнформации.Другое, Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты), "Вид");
    Если Не СтрокаНастройки = Неопределено И ТаблицаНастроек.Количество() > 5 Тогда
        ТаблицаНастроек.Сдвинуть(СтрокаНастройки, 5 - ТаблицаНастроек.Индекс(СтрокаНастройки));
    КонецЕсли;
    СтрокаНастройки = ТаблицаНастроек.Найти(ЛМБ_ОбщегоНазначенияПереопределяемый.НайтиСоздатьВидКонтактнойИнформации("Выдача паспорта", Перечисления.ТипыКонтактнойИнформации.Другое, Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты), "Вид");
    Если Не СтрокаНастройки = Неопределено И ТаблицаНастроек.Количество() > 6 Тогда
        ТаблицаНастроек.Сдвинуть(СтрокаНастройки, 6 - ТаблицаНастроек.Индекс(СтрокаНастройки));
    КонецЕсли;
    СтрокаНастройки = ТаблицаНастроек.Найти(ЛМБ_ОбщегоНазначенияПереопределяемый.НайтиСоздатьВидКонтактнойИнформации("Место рождения", Перечисления.ТипыКонтактнойИнформации.Адрес, Перечисления.ВидыОбъектовКонтактнойИнформации.Контрагенты), "Вид");
    Если Не СтрокаНастройки = Неопределено И ТаблицаНастроек.Количество() > 7 Тогда
        ТаблицаНастроек.Сдвинуть(СтрокаНастройки, 7 - ТаблицаНастроек.Индекс(СтрокаНастройки));
    КонецЕсли;
    // Ломбард -
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ1, Неопределено, ЭлементыФормы.ПолеКИ1);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ2, Неопределено, ЭлементыФормы.ПолеКИ2);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ3, Неопределено, ЭлементыФормы.ПолеКИ3);
    // Ломбард +
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ4, Неопределено, ЭлементыФормы.ПолеКИ4);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ5, Неопределено, ЭлементыФормы.ПолеКИ5);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ6, Неопределено, ЭлементыФормы.ПолеКИ6);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ7, Неопределено, ЭлементыФормы.ПолеКИ7);
    УправлениеКонтактнойИнформацией.ДобавитьКнопкуИПоле(мСтруктураРедактированияКИ, ЭлементыФормы.НадписьКИ8, Неопределено, ЭлементыФормы.ПолеКИ8);
    // Ломбард -
КонецПроцедуры


1C
1
2
3
4
5
6
7
8
9
10
Данные.Вставить ("СтоимостьКредита", СтруктУсловияДоговора.СтоимостьКредитаБезПериода); 
    Данные.Вставить ("НазваниеОрганизации2", СтруктЛеваяЧасть.ОрганизацияНаименование);
    Данные.Вставить ("ИННОрганизации", СтруктЛеваяЧасть.ОрганизацияИНН);
    Данные.Вставить ("КППОрганизации", СтруктЛеваяЧасть.ОрганизацияКПП);
    Данные.Вставить ("ЮрАдресОрганизации", СтруктЛеваяЧасть.ОрганизацияАдресЮридический);
    Данные.Вставить ("ТелефонОрганизации", СтруктЛеваяЧасть.ОрганизацияТелефон);
    Данные.Вставить ("РуководительОрганизации", СтруктРасчетОплаты.ФИОРуководителя);
    Данные.Вставить ("НазваниеКонтрагента", СтруктЛеваяЧасть.ФИОЗалогодателя);
    Данные.Вставить ("Паспорт", СтруктЛеваяЧасть.ПаспортныеДанныеЗалогодателя);  
    Данные.Вставить ("ДатаРождения", СтруктЛеваяЧасть.ДатаРожденияЗалогодателя);
Это часть кода общего модуля. Вот эта часть работает без проблем, т.е. все данные выводятся (указываю на них использованием закладок в макете)

А вот место рождения вообще не пойму, как добавить. Пробовал. Ничего не выходит. Ошибки нету, просто поле ячейка таблицы остается пустая (пропадает вместе с датой рождения)
1C
1
Данные.Вставить ("МестоРождения", СтруктЛеваяЧасть.МестоРожденияЗалогодателя);
1C
1
Данные.Вставить ("МестоРождения", СтруктЛеваяЧасть.МестоРождения);
1C
1
Данные.Вставить ("МестоРождения", СтруктЛеваяЧасть.МестоРожденияЗалогодателя);
1C
1
Данные.Вставить ("МестоРождения", СтруктЛеваяЧасть.ПолеКИ8);
Надеюсь на помощь. Спасибо.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.01.2017, 09:38
Ответы с готовыми решениями:

Добавление поля в печатную форму
1С 8.2 Неуправляемое приложение. Такая проблема - надо добавить итоговую скидку по документу в...

добавление поля в печатную форму
Есть документ с готовой печатной формой. Я добавил в него реквизит ОбщаяСкидка (в нем содержится...

Добавление в печатную форму ценника код товара.
Здрасте, подскажите пожалуйста, как в 1с 8.1. сделать, чтобы при распечатки ценника в нем...

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме "приходная накладная" ут 11 создал область, параметр, в...

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме нужно вывести данные, в табл часть шаблон вставил, в модуле...

1
CJX
14 / 14 / 4
Регистрация: 26.11.2015
Сообщений: 235
16.01.2017, 10:53  [ТС] 2
:C Спасите-помогите
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.01.2017, 10:53

Добавить печатную форму 1С v8
Необходимо Документы - Ведомость в кассу добавить печатную форму 0504403. Зашел в конфигуратор -...

ТаблицаЗначений в печатную форму
Помогите, такая вот проблема нужно вывести в строку в печатной форме значений из таблицы значений....

Выбрать печатную форму
У клиентов свои печатные формы актов, поэтому чтобы не делать кучу печатных форм в кнопке "Печать",...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.