Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
1

Отправку писем с периодичностью

18.01.2017, 14:25. Просмотров 899. Ответов 8
Метки нет (Все метки)

Добрый день! Я отправляю письма с помощью этого кода
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
    ОчиститьСообщения();
    
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    АдресО                       = "*********";
    Пароль                       = "*********";
    АдресСервера                 = "smtp.gmail.com";    
    Профиль.АдресСервераSMTP     = АдресСервера; 
    Профиль.ПортSMTP             = 465;
    Профиль.Пользователь         = АдресО;
    Профиль.Пароль               = Пароль;
    Профиль.АутентификацияSMTP   = СпособSMTPАутентификации.ПоУмолчанию;
    Профиль.ИспользоватьSSLSMTP  = Истина;
    Профиль.ПарольSMTP           = Пароль;
    Профиль.ПользовательSMTP     = АдресО; 
    
    Почта = Новый ИнтернетПочта;
    Попытка
        Почта.Подключиться(Профиль);
    Исключение
        Сообщить("Ошибка при подключении к серверу" + ОписаниеОшибки());
        Возврат;
    КонецПопытки;
    
    Для Каждого Стр из ТабличнаяЧасть1 Цикл
        АдресП = Стр.mail;
        Если АдресП="Нет данных" Тогда
            Продолжить;
        КонецЕсли;      
        Сообщение = Новый ИнтернетПочтовоеСообщение;
        Сообщение.Отправитель = АдресО;
        Сообщение.Получатели.Добавить(АдресП);
        Сообщение.Тема = ТемаПисьма;
        Сообщение.Тексты.Добавить(Текст,ТипТекстаПочтовогоСообщения.HTML);
        Состояние("Идет отправка посты на адрес: "+АдресП); 
        Почта.Послать(Сообщение);
        Сообщить("Почта отправлена: "+ АдресП);
    КонецЦикла;
    Почта.Отключиться();
Можете подсказать как сделать чтобы отправлять по 20 писем через 1 минуту?
Спасибо
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.01.2017, 14:25
Ответы с готовыми решениями:

Неверно Строится Отчет Продажи С Периодичностью Месяц
Проблемма следующая - формирую отчет за июнь: если в группировках не ставлю периодичности -...

Настроить отправку писем не только на mail.ru
Здравствуйте! Хочу отправить письмо с отчетом. Проблема в следующем письма уходят только с...

Как в Debian 7 отключить отправку писем кроном
Всем доброго времени суток, Дорогие товарищи, подскажите как отключить отправку писем кроном?...

Как запретить отправку писем в домены заканчивающиеся на .ТК
Как запретить отправку писем в домены заканчивающиеся на .ТК Уже все перепробовал (((

Как сделать отправку писем через JavaScript?
Как сделать отправку писем через JavaScript?

8
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
18.01.2017, 14:47 2
Ermak27, сделайте счетчик + обработчик ожидания.
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
18.01.2017, 15:06  [ТС] 3
GreenkA, можете показать пример обработчик ожидания со счетчиком. Отдельно я счетчик делал, но как вместе сделать мне не понятно.
0
Dethmontt
Модератор
Эксперт 1С
2657 / 2445 / 420
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
18.01.2017, 18:02 4
Ermak27, что значит каждую минуту по 20 писем?
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
18.01.2017, 22:30 5
Лучший ответ Сообщение было отмечено Ermak27 как решение

Решение

Ermak27, это обычное приложение?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Перем Индекс;
 
Процедура НачатьОтправкуПисем(Кнопка)
    Индекс = 0;
    ПодключитьОбработчикОжидания("ОтправкаПисем", 60);
КонецПроцедуры
 
Процедура ОтправкаПисем()
    Для к = 1 по 20 Цикл
        Если Индекс <= ТабличнаяЧасть1.Количество()-1 Тогда
            //отправляем письма, адрес = ТабличнаяЧасть1[Индекс].mail
            Индекс = Индекс + 1;            
        Иначе
            ОтключитьОбработчикОжидания("ОтправкаПисем");//закончились адресаты
            Прервать;
        КонецЕсли;
    КонецЦикла; 
КонецПроцедуры
3
Dethmontt
20.01.2017, 02:49
  #6

Не по теме:

GreenkA, а если в табличной части 30 адресатов?

0
GreenkA
20.01.2017, 10:42
  #7

Не по теме:

Dethmontt, там же идет проверка индекса и количества строк в ТЧ перед отправкой письма. Или ты про то, почему именно 20 писем каждую минуту?) Это скорее вопрос к ТС:gpardon:
Но можно сделать механизм более гибким и прописывать не фиксировано 20, а получать из какой настройки...

0
Dethmontt
20.01.2017, 13:35
  #8

Не по теме:

Цитата Сообщение от GreenkA Посмотреть сообщение
Или ты про то, почему именно 20 писем каждую минуту?
Я про то что будет с последними 10 строками если в ТЧ 30 записей? Они никогда не получат уведомление?

0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
20.01.2017, 14:24 9

Не по теме:

Dethmontt, почему не получат? Здесь же условие по индексу и количеству строк ТЧ прописано, 20 здесь ни о чем:

1C
1
2
3
4
Для к = 1 по 20 Цикл
        Если Индекс <= ТабличнаяЧасть1.Количество()-1 Тогда
            //отправляем письма, адрес = ТабличнаяЧасть1[Индекс].mail
            Индекс = Индекс + 1;
Вызов процедуры будет происходить как раз до полной отправки всем адресатам, только потом отключаем обработчик ожидания.



Добавлено через 6 минут
Внесла коррективы:
1C
1
Индекс = Индекс + 1;
Но думаю, Денис все равно не об этом)
1
20.01.2017, 14:24
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.01.2017, 14:24

Реализовать отправку писем после оплаты товара на почту
Требуется реализовать функцию доступа для скачивания после оплаты как на этом сайте....

BSOD с разной периодичностью
p4s800mx - SE (материнка) Помогите ребят!

Вывод текста на страницу с периодичностью
голос «против» избранное Здравствуйте, есть скрипт: $text = 39; if( $text &lt;= 50 ) { echo...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru