Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
NeSpecz
0 / 0 / 0
Регистрация: 25.01.2017
Сообщений: 1
1

Исключить строки при печати документа 1с 8.1

25.01.2017, 09:00. Просмотров 244. Ответов 0
Метки нет (Все метки)

Добрый день!
Имеется справочник "АналогиНоменклатура", который содержит Эталон и Аналоги(элементы которые, аналогичны Эталону, содержатся в табличной части). Пытаюсь реализовать возможность, чтобы при выводе на печать табличнй части "ИсходныеКомплектующие" справочника "СпецификацииНоменклатуры", исключались аналоги, если они есть.
Написал часть кода, проверки только на Эталон, выдает на печать пустой документ.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
Функция ПроверкаНаЭталон(Эталон)
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийЭлемент", ЭтотОбъект.Ссылка);
    Запрос.Текст = "ВЫБРАТЬ
                   |    АналогиНоменклатура.Эталон,
                   |    СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура
                   |ИЗ
                   |    Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК СпецификацииНоменклатурыИсходныеКомплектующие,
                   |    Справочник.АналогиНоменклатура КАК АналогиНоменклатура
                   |ГДЕ
                   |    СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура = АналогиНоменклатура.Эталон
                   | ИЛИ СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура = АналогиНоменклатура.Аналоги.Аналог";
     
       Выборка = Запрос.Выполнить().Выбрать();
     Пока Выборка.Следующий() = Истина Цикл
        Эталон =  Выборка.Эталон;
        Прервать;
    КонецЦикла;
    Возврат Эталон
    
    КонецФункции
 
 
Функция ПечатьБезАналогов()
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_БезАналогов";
 
    Макет = ПолучитьМакет("БезАналогов");
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаб");
    ОбластьСтрокаТаблицы = Макет.ПолучитьОбласть("СтрокаТаб");
    
    ОбластьШапка.Параметры.НаименованиеСпецификации = Наименование;
    ОбластьШапка.Параметры.КодСпецификации = Код;
    ТабДокумент.Вывести(ОбластьШапка);
    
    ТабДокумент.Вывести(ОбластьШапкаТаблицы);
       
    Для Каждого СтрокаИсходныеКомпл Из ИсходныеКомплектующие Цикл
        
        Если  ПроверкаНаЭталон(СтрокаИсходныеКомпл.Номенклатура)= Истина Тогда
           
            ОбластьСтрокаТаблицы.Параметры.Номенклатура = СтрокаИсходныеКомпл.Номенклатура;
            ОбластьСтрокаТаблицы.Параметры.Код = СтрокаИсходныеКомпл.Номенклатура.Артикул;
            ОбластьСтрокаТаблицы.Параметры.Наименование = СтрокаИсходныеКомпл.Номенклатура.Наименование;
            ОбластьСтрокаТаблицы.Параметры.КолВИзд = СтрокаИсходныеКомпл.Количество;
            ОбластьСтрокаТаблицы.Параметры.ПоНорме = СтрокаИсходныеКомпл.Норма;
            ОбластьСтрокаТаблицы.Параметры.ЕдИзм = СтрокаИсходныеКомпл.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Наименование;
            ТабДокумент.Вывести(ОбластьСтрокаТаблицы);      
        Иначе           
        КонецЕсли;
    КонецЦикла;
    Возврат ТабДокумент;
КонецФункции
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.01.2017, 09:00
Ответы с готовыми решениями:

Адрес при печати документа
Здравствуйте. Имеется процедура печати в которой адрес собирается в одну строку...

Группировка в запросе при печати документа.
Приветствую профи 1С, сам новичок в 1С, хотел бы узнать, как можно получить...

Ошибка 0x80020005 при печати двоичного документа
Добрый день, вообщем при печати двоичного документа выскакивает такая ошибка на...

Где находится конструктор печати документа?
Где находится конструктор печати документа?

Пересчет цены за все услуги при удалении строки табличной части документа.
Если убрать одну услугу отсюда, то цена остается вместе с предыдущей услугой...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.01.2017, 09:00

Ошибка при расчете суммы текущей строки табличной части в управляемой форме документа
Подскажите что не так ? Почему не срабатывает подсчёт? ...

Изменение Внешней обработки печати накладной Для документа Реализация товаров и услуг
Суть задачи такова. Есть документ - РеализацияТоваровУслуг. Есть внешняя...

Как изменить текст надписи формы документа при записи документа
Здравствуйте уважаемые, у меня простой вопрос - как мне при записи документа...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru