Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
1

Создание обработки: получение данных справочника запросом. Почему в результате только одна ссылка?

25.01.2017, 13:14. Просмотров 894. Ответов 15
Метки нет (Все метки)

Не могу понять, почему после выполнения запроса в Выборке только одна ссылка, хотя в Справочнике 4 элемента.

Почему так?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ
                   |    Клиенты.Ссылка
                   |ИЗ
                   |    Справочник.Клиенты КАК Клиенты";
                   
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        Строка = Объект.Посетители.Добавить();
        Строка.ФИО = Выборка.Наименование;
        Строка.Присутствие = Ложь; 
    КонецЦикла
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.01.2017, 13:14
Ответы с готовыми решениями:

В результате запроса выводится только одна запись
Есть текстареа, по каждой строке текста в нем должен происходить поиск по бд. В результате запроса...

Nginx и php и 1(одна ссылка/адресация) в правило/место для php обработки
Вообщем. На сервере для каждого сайта создаётся *.conf. В нём автоматом прописываются настройки....

Получение в документе данных ФИО и оклада из справочника Сотрудники
Здравствуйте помогите пожалуйста а то что то не получается. Есть справочник сотрудники, в нем фио...

Почему выводится только одна строка?
Добрый вечер. Имеется длинная функция create or replace FUNCTION get_week_list2(i_code IN...

Почему выводится только одна запись из бд?
Вроде ж все нормально. Почему не выводит все. Не пойму :( while($myrow =...

15
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
25.01.2017, 14:01 2
Тамика, а если так?
1C
1
2
3
4
5
6
7
8
9
10
    Запрос = Новый Запрос()
    Запрос.Текст = "ВЫБРАТЬ
                   |    Клиенты.Наименование КАК Наименование,
                   |    ЛОЖЬ КАК Присутствие 
                   |ИЗ
                   |    Справочник.Клиенты КАК Клиенты";
 
ТЗ = Запрос.Выполнить().Выгрузить();
 
Объект.Посетители.Загрузить(ТЗ)
1
1c_user
Заблокирован
25.01.2017, 14:31 3
рлсы на пользователя под которым обработочка есть ?

Добавлено через 51 секунду
"наименование " - как то отработало ? 0_о
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 14:52  [ТС] 4
Phil, попробовала. Тот же эффект..
Строчки создаёт, но сами имена не выводит...
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
25.01.2017, 14:58 5
Тамика, можно обработку?
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 14:59  [ТС] 6
Phil, это всё
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаСервере
Процедура ПолучитьСписокКлиентов()
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ
                   |    Клиенты.Наименование КАК Наименование,
                   |    ЛОЖЬ КАК Присутствие 
                   |ИЗ
                   |    Справочник.Клиенты КАК Клиенты";
 
    ТЗ = Запрос.Выполнить().Выгрузить();
     
    Объект.Посетители.Загрузить(ТЗ);
 
КонецПроцедуры
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
25.01.2017, 15:07 7
Тамика, какие колонки имеет табличная часть Посетители? (и типы этих колонок)
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 15:30  [ТС] 8
Dethmontt, Колонка ФИО - Тип Справочники.Ссылка.Клиенты и Присутствие - Булево
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
25.01.2017, 15:33 9
1C
1
2
3
4
5
  Запрос.Текст = "ВЫБРАТЬ
 | Клиенты.Ссылка КАК Наименование, 
 | ЛОЖЬ КАК Присутствие 
 |ИЗ 
 | Справочник.Клиенты КАК Клиенты";
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
25.01.2017, 15:37 10
+ Объект.Посетители.Загрузить(ТЗ);
0
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 16:08  [ТС] 11
Phil, Dethmontt, не понимаю... Всё равно ничего не выводит.
Верно ведь?
1C
1
2
3
4
5
6
7
8
9
10
11
    
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ
         | Клиенты.Ссылка КАК Наименование, 
         | ЛОЖЬ КАК Присутствие 
         |ИЗ 
         | Справочник.Клиенты КАК Клиенты";
 
 
    ТЗ = Запрос.Выполнить().Выгрузить();
    Объект.Посетители.Загрузить(ТЗ);
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
25.01.2017, 16:49 12
Лучший ответ Сообщение было отмечено Тамика как решение

Решение

Тамика, так надо?
1
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 17:41  [ТС] 13
Phil, да! Спасибооо!

Простите, а что значит эта строка запроса?
1C
1
ЛОЖЬ КАК ЭтоМойБанк
И обязательно выбирать определённые кол-во строк в запросе? Если я не знаю сколько будет?
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
25.01.2017, 17:43 14
Тамика,
У Вас всё равно в выборке всем строчкам присваивалась ложь, я сразу в запросе сделал столбик заполненный, а чтобы выводились все записи сотрите
1C
1
Первые 7
1
Тамика
Котовчанин
929 / 470 / 199
Регистрация: 16.02.2010
Сообщений: 3,305
Записей в блоге: 32
25.01.2017, 17:53  [ТС] 15
Phil, странно... Перенесла эту обработку в документ, ничего не меняла, а опять не работает. Как так может быть?

Вот обработка внутри модуля формы Документа
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаСервере
Процедура ПолучитьФамилии()
    
    Запрос =  новый запрос;
    Запрос.Текст = "ВЫБРАТЬ 
     |  Клиенты.Ссылка КАК Наименование,
     |  ЛОЖЬ КАК ЭтоМойКлиент
     |ИЗ
     |  Справочник.Клиенты КАК Клиенты";
     
     Объект.Посетили.Загрузить(Запрос.Выполнить().Выгрузить());
    
КонецПроцедуры
 
 
 
&НаКлиенте
Процедура Заполнить(Команда)
    ПолучитьФамилии();
КонецПроцедуры
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
25.01.2017, 17:56 16
Цитата Сообщение от Тамика Посмотреть сообщение
Верно ведь?
нет

вот так
1C
1
 | Клиенты.Ссылка КАК ФИО,
Добавлено через 50 секунд
Тамика, колонки должны называться одинаково!!! И типы должны быть одинаковы!!!
0
25.01.2017, 17:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.01.2017, 17:56

Почему выводится только одна строка матрицы
#include <stdafx.h> #include <iostream> #include <clocale> #include <ctime> #include <conio.h>...

Почему срабатывает только одна итерация цикла
Только начал изучать язык, и хотел бы разобраться с Loop ' ми. писал и так и эдак, гуглил тоже по...

Почему работает только одна форма из двух?
Помогите, пожалуйста, сам я в javascript понимаю слабо. Сделал две аналогичных формы, запускаемых...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru