Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
alexmax
0 / 0 / 0
Регистрация: 11.09.2014
Сообщений: 16
1

Перенос данных из управляемой формы на форму документа

26.01.2017, 20:55. Просмотров 346. Ответов 1
Метки нет (Все метки)

Добрый день товарищи. Возникла проблема при написании конфигурации. Вопрос вот в чем:
- Есть справочник "Номенклатура" и два документа Приходная и расходная накладные. Справочник хранит наименования продукции. В документе "Приходная накладная" осуществляются поступления средств (в таблчной части реквизиты (номенклатура(ссылка.справочник.номенклатура), срокгодности, и количество. При проведении расходной накладной - во время выбора номенклатуры открывается список наименований в разрезе сроков годностей для списания. Вот сдесь и возникла ошибка. При выборе номенклатуры появляется управляемая форма, а вот записать эти данные в основную форму документа не выходит.
код в форме документа
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
&НаКлиенте
Процедура СписокНоменклатурыНоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Если ТипЗнч(ВыбранноеЗначение) = Тип("СправочникСсылка.Номенклатура") Тогда
        СтруктураПараметры = Новый Структура("Номенклатура, ДатаДокумента");
        СтруктураПараметры.Номенклатура = ВыбранноеЗначение;
        СтруктураПараметры.ДатаДокумента = Объект.Дата;
        ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаЭл", СтруктураПараметры, ЭтаФорма);
    КонецЕсли;
КонецПроцедуры
 
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    Если ТипЗнч(ВыбранноеЗначение) = Тип("Структура") Тогда
        СтандартнаяОбработка= Ложь;
        ТекСтрока = Элементы.СписокНоменклатуры.ТекущиеДанные;
        ТекСтрока.Номенклатура = ВыбранноеЗначение.Номенклатура;
        ТекСтрока.СрокГодности = ВыбранноеЗначение.СрокГодности;
        ТекСтрока.Количество = ВыбранноеЗначение.Количество;
    КонецЕсли;
    КонецПроцедуры
в форме справочника(УФ)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
&НаСервере
Функция ЗаполнитьПриОткрытииНаСервере(ДатаДокумента, Номенклатура)
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |   ОстаткиТовараОстатки.Номенклатура,
    |   ОстаткиТовараОстатки.СрокГодности,
    |   ОстаткиТовараОстатки.КоличествоОстаток КАК Количество
    |ИЗ
    |   РегистрНакопления.ОстаткиТовара.Остатки(&ДатаДокумента, Номенклатура = &Номенклатура) КАК ОстаткиНоменклатурыОстатки";
    Запрос.УстановитьПараметр("ДатаДокумента", ДатаДокумента);
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
    
    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    
    Массив = Новый Массив;
    СтруктураВыборка = Новый Структура("Номенклатура, СрокГодности, Количество");
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СтруктураВыборка = Новый Структура("Номенклатура, СрокГодности, Количество");
        ЗаполнитьЗначенияСвойств(СтруктураВыборка, ВыборкаДетальныеЗаписи);
        Массив.Добавить(СтруктураВыборка);
    КонецЦикла;
    
    Возврат Массив;
    
    
        
КонецФункции
 
 &НаКлиенте
 Процедура НакладнаяСписокВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
     СтандартнаяОбработка = Ложь;
     ОповеститьОВыборе (Новый Структура("Номенклатура, СрокГодности, Количество", Элемент.ТекущиеДанные.Номенклатура, Элемент.ТекущиеДанные.СрокГодности, Элемент.ТекущиеДанные.Количество));
ЭтаФорма.Закрыть();  
 КонецПроцедуры
 
     
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        СтруктураВыборкаМассив = ЗаполнитьПриОткрытииНаСервере(Параметры.ДатаДокумента, Параметры.Номенклатура); 
    
    Для Каждого  СтруктураВыборка Из СтруктураВыборкаМассив Цикл
        Строка = НакладнаяСписок.Добавить();
        ЗаполнитьЗначенияСвойств(строка, СтруктураВыборка);
    КонецЦикла;
 
КонецПроцедуры
&НаКлиенте
Процедура НакладнаяСписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
              СтандартнаяОбработка = Ложь;
    ОповеститьОВыборе(Новый Структура("Номенклатура,СрокГодности,Количество",Элемент.ТекущиеДанные.Номенклатура,
    Элемент.ТекущиеДанные.СрокГодности,Элемент.ТекущиеДанные.Количество));
 
КонецПроцедуры
Подскажите где ошибка, или другой способ как отразить данные на основной форме
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.01.2017, 20:55
Ответы с готовыми решениями:

Перенос данных из справочника в табличную часть формы документа
Здравствуйте. Создаю документ в конфигурации Бухгалтерия предприятия, редакция 2.0 (2.0.43.6) на...

Перенос макета печатной формы из одного документа в другой.
Подскажите, реально ли перенести макет печатной формы из одного документа в другой?

Перенос данных из формы в форму
Всем здравствуйте! Подскажите пожалуйста, как в приложенном примере осуществить перенос данных из...

Перенос данных из подчиненной формы в другую форму
Проблема в следующем: в подчиненной форме отображаются данные в виде таблицы по запросам (что-то...

Передача параметров из управляемой формы обработки в управляемую форму другой обработки
Есть 2 обработки, в одной из них(Назовём её первой) есть кнопка, при нажатии на которую открывается...

1
alexmax
0 / 0 / 0
Регистрация: 11.09.2014
Сообщений: 16
26.01.2017, 22:22  [ТС] 2
Конфигурация прилагается
0
Вложения
Тип файла: rar 4.rar (55.4 Кб, 1 просмотров)
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.01.2017, 22:22

Перенос данных с формы и одной ячейки dataGridView в другую форму и ячейку dataGridView
Подскажите пожалуйста, у меня есть две таблицы которые выводятся на разных формах в dataGridView...

перенос из формы в форму
У меня в одной программе есть две формы в одной задан цикл и считается переменная Y(у нее значений...

Перенос записей из формы в другую форму
Здравствуйте, помогите пожалуйста. Нужно в готовой базе данных Microsoft Access, сделать так, чтобы...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru