Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
provodnikmv
0 / 0 / 0
Регистрация: 23.01.2015
Сообщений: 37
#1

Добавление в макет подчиненногоэлемента табличной части через запрос - 1С/1C 8.x

19.02.2017, 22:28. Просмотров 151. Ответов 0
Метки нет (Все метки)

Здравствуйте!
Имеется самописная конфа.
Не могу вывести в печатную форму подчиненный элемент табличной части. (Инвентарный номер)
В таблице в форме получилось добавить этот элемент в таблицу, а вывести в макет не получается (вложения)
На данный момент имеется такой запрос:
Кликните здесь для просмотра всего текста

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
Процедура ПечатьПриложений(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(ПечатьПриложений)
    Макет = Документы.ДоговорОтветствХран.ПолучитьМакет("ПечатьПриложений");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ЦЗН.ДиректорЦЗНсокр,
    |   ДоговорОтветствХран.Дата,
    |   ДоговорОтветствХран.ДоговорНом,
    |   ДоговорОтветствХран.ЦЗНполн,
    |   ДоговорОтветствХран.ИнвСписок.(
    |       НомерСтроки,
    |       НаименованиеТех.ИнвНом, //ВОТ ТУТ ПРОБЛЕМА, вот это надо вывести
    |       НаименованиеТех
    |   ),
    |   ДоговорОтветствХран.ИнвСписокБН.(
    |       НомерСтроки,
    |       НаименованиеТехБН,
    |       Количество
    |   )
    |ИЗ
    |   Справочник.ЦЗН КАК ЦЗН,
    |   Документ.ДоговорОтветствХран КАК ДоговорОтветствХран
    |ГДЕ
    |   ДоговорОтветствХран.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьИнвСписокШапка = Макет.ПолучитьОбласть("ИнвСписокШапка");
    ОбластьИнвСписок = Макет.ПолучитьОбласть("ИнвСписок");
    ОбластьИнвСписокБНШапка = Макет.ПолучитьОбласть("ИнвСписокБНШапка");
    ОбластьИнвСписокБН = Макет.ПолучитьОбласть("ИнвСписокБН");
    Подвал = Макет.ПолучитьОбласть("Подвал");
    Подвал.Параметры.ДиректорФскр = Константы.РуководительФсокр.Получить();
    //Поля страницы
    ТабДок.Автомасштаб=истина;
    ТабДок.ПолеСлева=30;
    ТабДок.ПолеСправа=15;
    ТабДок.ПолеСверху=20;
    ТабДок.ПолеСнизу=20;
    ТабДок.Очистить();
 
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
 
        //ТабДок.Вывести(ОбластьЗаголовок);
        //первая таблица
        НомерПП=1;
        Шапка.Параметры.НомерПП=НомерПП;
        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());
        
        ТабДок.Вывести(ОбластьИнвСписокШапка);
        ВыборкаИнвСписок = Выборка.ИнвСписок.Выбрать();
        Пока ВыборкаИнвСписок.Следующий() Цикл
            ОбластьИнвСписок.Параметры.Заполнить(ВыборкаИнвСписок);
            ТабДок.Вывести(ОбластьИнвСписок, ВыборкаИнвСписок.Уровень());
        КонецЦикла;
        
        Подвал.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Подвал);
 
        //вторая таблица
        
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        НомерПП=2;
        Шапка.Параметры.НомерПП=НомерПП;
        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());
        
        
        ТабДок.Вывести(ОбластьИнвСписокБНШапка);
        ВыборкаИнвСписокБН = Выборка.ИнвСписокБН.Выбрать();
        Пока ВыборкаИнвСписокБН.Следующий() Цикл
            ОбластьИнвСписокБН.Параметры.Заполнить(ВыборкаИнвСписокБН);
            ТабДок.Вывести(ОбластьИнвСписокБН, ВыборкаИнвСписокБН.Уровень());
        КонецЦикла;
        
        Подвал.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Подвал);
        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры

http://www.cyberforum.ru/1c-custom/thread1916563.html
0
Миниатюры
Добавление в макет подчиненногоэлемента табличной части через запрос   Добавление в макет подчиненногоэлемента табличной части через запрос  
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.02.2017, 22:28
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x Добавление в макет подчиненногоэлемента табличной части через запрос (1С):

Как сделать форматированный вывод табличной части документа в макет?
Привет всем, подскажите пожалуйста, как правильно описать в коде? Нужно...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с...

Запрос к табличной части
Не могу понять в чем ошибка, делаю как в примере Запрос1 = новый Запрос;...

Запрос к табличной части 1С
Пожалуйсто помогите, очень хочу разобраться. Студенты-справочник Курс-...

Запрос по табличной части справочника
Добрый день. Начинаю изучать 8ку поэтому прошу прощения за глупые вопросы. Есть...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.02.2017, 22:28
Привет! Вот еще темы с решениями:

Запрос к табличной части документа
Здравствуйте, есть запрос: "ВЫБРАТЬ | Док.Работники.( | Работник,...

Передача табличной части обработки в запрос
Здравствуйте. Делаю внешнюю обработку для Документооборота. Сделал запрос для...

Запрос. Условие: строка из первой табличной части равна любой строке из другой табличной части
Есть документ "РаспределениеМатериаловНаВыпуск". У этого документа имеется...

Макет в табличной части документа
используй MSFlexGrid1.TopRow =


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru