Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Godunov
3 / 3 / 6
Регистрация: 29.03.2016
Сообщений: 116
#1

Настройка периода в СКД - 1С/1C 8.x

27.02.2017, 09:46. Просмотров 342. Ответов 5
Метки нет (Все метки)

Приветствую форумчан, затык возник у меня, для отчёта в СКД надо допилить НастройкаПериода, но не получается.
Делаю так: для процедуры "КнопкаНастройкаПериодаНажатие" прописал код для настройки периода, в отчёте нажимаю кнопку "...", открывается окно для настройки периода\интервала в окнах "период с ... по ..." выводится, затем выбираю менеджера и нажимаю кнопку "Сформировать" и получаю пустой отчёт.
А если вручную прописываю изначально дату в окнах "период с ... по ...", не входя в "..." (настройку периода), выбираю менеджера, то получаю отчёт с данными.
Можете подсказать, что не так с кодом?


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Процедура ПользователиПриИзменении(Элемент)
    Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Пользователи"));;
    Параметр.Значение = Пользователи;
    Параметр.Использование = Истина;
 
КонецПроцедуры
 
Процедура НачалоПериодаПриИзменении(Элемент)
    Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаНачала"));;
    Параметр.Значение = Период.ДатаНачала;
    Параметр.Использование = Истина;
    
КонецПроцедуры
 
Процедура КонецПериодаПриИзменении(Элемент)
    Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаОкончания"));;
    Параметр.Значение = Период.ДатаОкончания;
    Параметр.Использование = Истина;
КонецПроцедуры
 
Процедура КнопкаНастройкаПериодаНажатие(Элемент)
        
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.УстановитьПериод('20131101','20131130');
    //НастройкаПериода.УстановитьПериод(ДатаНачала, ?(ДатаОкончания='0001-01-01', ДатаОкончания, КонецДня(ДатаОкончания)));
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    //НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период; //Закладка Период
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Интервал;// Закладка Интервал
    Если НастройкаПериода.Редактировать() Тогда
        Период.ДатаНачала = НастройкаПериода.ПолучитьДатуНачала();
        Период.ДатаОкончания = НастройкаПериода.ПолучитьДатуОкончания();
    КонецЕсли;
    
КонецПроцедуры
0
Миниатюры
Настройка периода в СКД   Настройка периода в СКД   Настройка периода в СКД  

Настройка периода в СКД  
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.02.2017, 09:46
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x Настройка периода в СКД (1С):

Установить формат периода в СКД - 1С
Здравствуйте, вопрос такой: как установить формат периода при выводе отчета в скд? получается вот так "Реестр документов "Реализация...

Окно "Настройка периода" - 1С
Я часто использую свои внешние отчеты. И при выборе периода, выскакивает окошечко "Настройка периода" с выбором "Произвольный интервал". ...

1C 8.x СКД, представление периода в заголовке - 1С
Доброго времени суток. Разрабатываю отчет с использованием СКД. На вкладке "Параметры" содержится параметр "Период", который имеет тип...

Период из запроса разбить на начало периода и конец периода - 1С
есть запрос "выбрать оборотыпродажи. период как период из продажиобороты " на выходе имеем поле период которое указывается в...

Разница между СКД и консолью СКД - 1С
Доброго дня! Есть запрос в СКД следующего вида: ВЫБРАТЬ ПродажиОбороты.Контрагент, СУММА(ПродажиОбороты.КоличествоОборот) КАК...

Формат периода - 1С
Привет всем, Помогите найти ошибку в формате периода "Обороты за"+ Выбор Когда &Переодичность=6 Тогда Формат(Период,"ДФ=dd.MM.yy")...

5
wwall
188 / 183 / 11
Регистрация: 29.05.2014
Сообщений: 929
27.02.2017, 10:50 #2
Цитата Сообщение от Godunov Посмотреть сообщение
Период.ДатаНачала = НастройкаПериода.ПолучитьДатуНачала(); Период.ДатаОкончания = НастройкаПериода.ПолучитьДатуОкончания();
Тут ты просто присвоил новые значения элементам формы. А вызвать процедуры изменения - забыл.
1
Godunov
3 / 3 / 6
Регистрация: 29.03.2016
Сообщений: 116
27.02.2017, 11:09  [ТС] #3
wwall, глупый вопрос, как их вызвать, есть пример?)
0
wwall
188 / 183 / 11
Регистрация: 29.05.2014
Сообщений: 929
27.02.2017, 11:12 #4
Лучший ответ Сообщение было отмечено автором темы, экспертом или модератором как ответ
1C
1
2
3
4
5
6
7
Если НастройкаПериода.Редактировать() Тогда Период.ДатаНачала = НастройкаПериода.ПолучитьДатуНачала(); 
Период.ДатаОкончания = НастройкаПериода.ПолучитьДатуОкончания(); 
/// вот так
НачалоПериодаПриИзменении(Неопределено);
КонецПериодаПриИзменении(Неопределено)
 
КонецЕсли;
1
Godunov
3 / 3 / 6
Регистрация: 29.03.2016
Сообщений: 116
27.02.2017, 11:35  [ТС] #5
wwall, благодарю от души, заработало))
Буду знать...)
0
wwall
188 / 183 / 11
Регистрация: 29.05.2014
Сообщений: 929
27.02.2017, 11:36 #6

Не по теме:

Программисты шоколадки не пьют.



Учись, студент. Однажды и ты мне помогать будешь
1
27.02.2017, 11:36
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.02.2017, 11:36
Привет! Вот еще темы с ответами:

Установка определенного периода даты - 1С
Подскажите пожалуйста, как для реквизита справочника с типом "Дата" программно установить интервал в течении месяца. Есть реквизит...

Запрос на выбор пересекающегося периода - 1С
Доброго времени суток. Целый день читаю инет по теме и экспериментирую. Но как то безуспешно. Задача. Есть выборка по случаям. У...

1C 8.x Последнее значение периода из регистра сведений - 1С
Есть периодический регистр сведений, у него есть один ресурс. Как достать последнее имеющееся значение периода из этого регистра?

1C 8.x Получение количественного остатка на начало периода - 1С
Здравствуйте. На форме есть поля выбора периода (НачПериода и КонПериода) и поле для выбора позиции из справочника номенклатуры...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru