Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
StudentBot
0 / 0 / 2
Регистрация: 31.12.2015
Сообщений: 74
#1

Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора" - 1С

04.03.2017, 19:45. Просмотров 366. Ответов 2
Метки нет (Все метки)

При отладке нажимая F11, не проваливается в процедуру, хотя должна.
Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора"

После нажатия F11 происходит вот это:
Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора"

Поставил курсор, выбрал действие идти до курсора, и происходит вот это:
Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора"

Подскажите, что за хурма?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
&НаКлиенте
Процедура ВыполнитьЗапрос(Команда)
    ВыполнитьЗапросНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ВыполнитьЗапросНаСервере()
    // Вставить содержимое обработчика.         //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Номенклатура.Код КАК Код,
        |   Номенклатура.Наименование КАК Наименование,
        |   Номенклатура.ЦенаПокупки КАК ЦенаПокупки,
        |   Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры
        |ИЗ
        |   Справочник.Номенклатура КАК Номенклатура";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    Таблица = РезультатЗапроса.Выгрузить();
 
КонецПроцедуры
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.03.2017, 19:45
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора" (1С):

1С 8.3 Розница 2.1.4.9 "Текущая цена розницы" и "Остаток" в форме элемента "Номенклатура" - 1С
Есть ли готовое решение, можно через внешнюю форму нужно контроль "Текущая цена розницы" и "Остаток" товаров на складе. В текущей...

1C 8.x 1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура" - 1С
Всем добрый день! Нужна помощь. В Форму элемента "Номенклатура" нужно добавить два поля с выводом остатка и текущей цены в рознице для...

1C 8.x Как обратиться к табличной части документа из процедуры "ПриЗаписи" - 1С
Здравствуйте! Создается новый документ. В его модуле, в процедуре "ПриЗаписи", необходимо обратиться к табличной части документа и...

Используя процедуры и функции обработки строк, составьте слово " воз", "дело", "следствие" - Turbo Pascal
Дано слово "издательство" Используя процедуры и функции обработки строк, составьте слово " воз", "дело",...

Вывести на экран "условие выполняется", если все элементы массива положительные и "условие не выполняется", если это не так. - Pascal ABC
1)Тип массива вещественный.Число элементов 11. Вывести на экран "условие выполняется", если все элементы массива положительные и "условие...

Отладка выполняется не по нажатию кнопки Step, а по наведению на неё курсора - Python
Очень неудобно. ...Друзья! Скачал Python 3.4.0, там идёт отладчик в комплекте. Открываю какой-нибудь файл *.py, потом отладчик. Потом...

2
Dethmontt
Модератор
Эксперт 1С
2552 / 2360 / 384
Регистрация: 10.03.2011
Сообщений: 8,325
Записей в блоге: 1
Завершенные тесты: 1
05.03.2017, 01:28 #2
Лучший ответ Сообщение было отмечено автором темы, экспертом или модератором как ответ
StudentBot, скорее всего отладка на сервере не включена

Добавлено через 34 секунды
как включить отладку на сервере, подскажет гугл
0
StudentBot
0 / 0 / 2
Регистрация: 31.12.2015
Сообщений: 74
06.03.2017, 10:43  [ТС] #3
Цитата Сообщение от Dethmontt Посмотреть сообщение
StudentBot, скорее всего отладка на сервере не включена

Добавлено через 34 секунды
как включить отладку на сервере, подскажет гугл
Спасибо!
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.03.2017, 10:43
Привет! Вот еще темы с ответами:

Как в Word 2010 аккорду "Ctrl ё" присвоить действие кнопки "формат по абзацу" - MS Word
Скажите, плиз... как в Word 2010 аккорду "Ctrl+ё" присвоить действие кнопки "Формат по абзацу". Кажется все просто: Файл - параметры -...

Имеется строка "AAABBCCAA", нужно вывести на экран "3A2B2C2A", и так же сделать обратное действие - C++
Доброго времени суток. Помогите организовать, желательно с примером, такую программу: имеется строка "AAABBCCAA"(так же можно абсолютно...

Как вернуть действие по умолчанию "открыть" для объектов "Папка с файлами" - Windows XP
Когда я пытаюсь открыть папку двойным щелчком, у меня появляется консоль. Оказалось, у меня так установлено в настройках(см. вложение). В...

Как написать регулярное выражение для выдергивания английских букв и символов: "+", ",", ":", "-", " ", "!", "?" и "." - JavaScript
Не могу ни как собразить как написать регулярное выражение для выдергивания английских букв и символов: плюс, запитая, двоеточие, тире,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.