Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Дмитрий666666
0 / 0 / 0
Регистрация: 14.01.2016
Сообщений: 22
#1

Как вывести результат в документ по процедуре Завершить - 1С

06.03.2017, 21:32. Просмотров 199. Ответов 3
Метки нет (Все метки)


http://www.cyberforum.ru/1c-custom/thread1782267.html
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.03.2017, 21:32
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Как вывести результат в документ по процедуре Завершить (1С):

Как вывести табличный документ на форму?
Управляемая форма, платформа 8.3. Есть реквизит формы "ОборотыСчетаДок" тип...

Как вывести остаток из регистра накопления в документ?
как вывести остаток из регистра накопления в документ!

Как вывести результат 2 запросов в 1 файл
В общем есть два запроса, при нажатии кнопки один выгружает результаты запроса...

Как сравнить "этот" документ и документ Док
В модуле формы документа делаем вот такой код ...

Как правильно вывести результат запроса в список?
подскажите как правильно вывести результат запроса в список Процедура...

3
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
06.03.2017, 21:37 #2
Дмитрий666666, конкретнее формулируйте ваши вопросы. Результат чего вам надо вывести и куда?
0
Дмитрий666666
0 / 0 / 0
Регистрация: 14.01.2016
Сообщений: 22
06.03.2017, 21:57  [ТС] #3
Когда кто-то проходит тест результаты записываются в табличную часть и по кнопки Завершить эти записи должны записываться в документ и выдавать оценку если меньше 50% то 2, если до 80% то 5 а если свыше 80% то 5
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
07.03.2017, 09:55 #4
Дмитрий666666, если я правильно поняла, то у вас в документе есть табличная часть Ответы с полями "ОтветСтудента" и "ПравильныйОтвет". В этом случае можно обойти табличную часть, сравнивая значения ответов. Вызов серверной процедуры не обязателен.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаКлиенте
Процедура Завершить(Команда)
 ПравОтветы = 0;
 Для Каждого ТекСтрока Из Объект.Ответы Цикл
   Если ТекСтрока.ОтветСтудента = ТекСтрока.ПравильныйОтвет Тогда
     ПравОтветы = ПравОтветы + 1;
   КонецЕсли;
 КонецЦикла;
 ВсегоВопросов = Объект.Ответы.Количество();
 Процент = ПравОтветы / ВсегоВопросов * 100;
 
 Если Процент < 50 Тогда
  Оценка = 2;
 ИначеЕсли Процент >= 50 и Процент < 80 Тогда 
  Оценка = 3;
 Иначе
//разберитесь, что вы выше про оценки написали)
 КонецЕсли;
 
 Сообщение = Новый СообщениеПользователю();
 Сообщение.Текст = НСтр("ru = 'Ваша оценка = ' ") + Оценка;
 Сообщение.Сообщить();
 
КонецПроцедуры
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.03.2017, 09:55
Привет! Вот еще темы с решениями:

В процедуре в регистр AX помещается результат выражения, как его вернуть с процедуры, чтобы вывести на экран
Имеется процедура, в ней в регистр AX помещается результат выражения, как его...

Как в хранимой процедуре записывать результат в таблицу, имя которой задается переменной
Подскажите, как в хранимой процедуре SQL записывать результат в таблицу, имя...

Не получается завершить тест и просчитать результат
Очень нужна помощь, с VB встречаюсь второй раз в жизни, для зачёта надо...

Как вывести промежуточные действия в процедуре
Есть процедура сортировки методом пузырька, в ней необходимо пошагово вывести...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru